Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator
Sign in using an external account
Register Forgot Password?


Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-29-2010, 04:40 AM
roachslayer roachslayer is offline
New User
 
Join Date: Jun 2010
Posts: 12
roachslayer is starting off with a positive reputation.
Wiper wont shut off

Looking for ideas please.

My wipers will simply will not turn off unless I turn the key off. Annoying!

Everything else about them is perfectly fine. They initially turn on only when I want them, they set to the speeds I want, etc. If I turn them OFF, they behave as though I set it on the slowest intermittent setting. I have to shut the key off and back on in order to make it stop. Madness!

I have checked fuses. I have tried swapping relays (at least one relay in the main box is for the wipers, so far as I can tell). All to no avail. If anyone has insight on what else to try or look for, that would be great. It really seems like a stuck relay issue to me... but I dont know where else to look. Or, what else could it be?

2001 Expedition EB 5.4L 4x4
Reply With Quote
  #2  
Old 06-29-2010, 12:14 PM
alloro alloro is offline
Post Fiend
 
Join Date: Apr 2008
Location: 0,0,1
Posts: 9,619
alloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to all
Quote:
Originally Posted by roachslayer View Post
I have to shut the key off and back on in order to make it stop.
That sounds like the wiper delay module is acting up.
__________________
To thank someone, click the left red "Add to Reputation" button
right of the word "permalink" top right of the poster's message.
Reply With Quote
  #3  
Old 06-29-2010, 05:07 PM
roachslayer roachslayer is offline
New User
 
Join Date: Jun 2010
Posts: 12
roachslayer is starting off with a positive reputation.
hmmmm. on this model, I believe the module/controller is in the whole turn signal wiper switch assembly itself (SW5548), needing the whole unit to be replaced. Not cheap. Dang.
Reply With Quote
  #4  
Old 07-04-2010, 08:39 PM
roachslayer roachslayer is offline
New User
 
Join Date: Jun 2010
Posts: 12
roachslayer is starting off with a positive reputation.
RESOLVED

For anyone else that comes across this or a similar issue, here is more detail.

I checked/swapped all relays related to wipers with same type relays related to other things. No change. So I knew it had to be the wiper switch. Furthermore, when hooked up to a Ford specific OBD II scanner, indeed, it showed an issue for the Multifunction Switch.

Replaced the switch in the steering column using these steps:
Lost the turn signals, how to replace multifunction switch - Ford Expedition Forum

...resolved the issue. Cheapest I found was around $90 online. Dealer cost was around $130. Part Number for my rig: SW5548

Either way, its a stupid rip off and a stupid thing to have go bad that should in theory never go bad. After all, there is usually a cause and effect when parts go bad. Such as water leak causes short. But no... this part failed without cause. Awesome. Of course, there is no aftermarket part for something this specific, so I expcet another failure without cause at some point.
Reply With Quote
Old 07-04-2010, 08:39 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird: Hazard / Turn Signal / Heater & AC Control Issue cpye2 Super Duty & Heavy Duty 4 12-27-2013 02:16 PM
Wipers only work on low, won't shut off 1994 f150 4x4 1987 - 1996 F150 & Larger F-Series Trucks 6 09-05-2013 03:55 PM
Wiper Motor Stays On Monzter Kuztomz Super Duty & Heavy Duty 17 07-18-2011 12:18 PM
Wipers Not Working Properly mattd860 1987 - 1996 F150 & Larger F-Series Trucks 13 05-30-2009 07:21 AM
Diagnosis of the wipers. rbengl Ranger & B-Series 1 04-18-2006 01:22 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator

Tags
2000, 2003, 2006, expedition, explorer, ford, ranger, shut, taurus, turn, windshield, wiper, wipers, wippers, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 04:37 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup