Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-21-2010, 12:41 PM
Kws3sc Kws3sc is offline
New User
 
Join Date: Jun 2006
Posts: 12
Kws3sc is starting off with a positive reputation.
Speed o meter, Tach o meter, Trans mission

My 97 Expedition (189K)recently started having issues. The tach will be reading fine then drop to zero, then work fine again. Sometimes the speedometer will bounce up and down within 5 mph. Now, the OD indicator will start blinking and the transmission will start shifting hard and take longer to shift through the gears. If I turn the ignition off and start it back, everything resets and seems to work fine for a while.

All of these issues have started over the last month. The tach problem happens at any speed, the speedometer happens with no predictible frequency and the transmission issue seems to only happens after 15 plus miles but sometimes it doesnt do it after 100 miles.

Somedays and on short drives, there doesnt seem to be anything wrong at all.

Any help would be greatly appreciated. Thanks
Reply With Quote
  #2  
Old 06-21-2010, 01:04 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
This is the 2007 and up forum.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #3  
Old 06-21-2010, 01:06 PM
Kws3sc Kws3sc is offline
New User
 
Join Date: Jun 2006
Posts: 12
Kws3sc is starting off with a positive reputation.
Thanks you.
Reply With Quote
Old 06-21-2010, 01:06 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 07:45 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup