wipers won't turn off? - Ford Truck Enthusiasts Forums



Excursion - King of SUVs 2000 - 2005 Ford Excursion SPONSORED BY:

wipers won't turn off?

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-12-2010, 08:50 PM
JKK JKK is offline
Junior User
Thread Starter
 
Join Date: Mar 2006
Location: Sugar Land, TX
Posts: 50
JKK is starting off with a positive reputation.
wipers won't turn off?

Hi all,

Did some searching but couldn't find a close answer. My wipers won't turn off...even in off position the run as if they were at the lowest intermittent speed. I worked the swich back & forth a number of times to make sure it wasn't sticking & no luck.

Any ideas or do I have to replace the entire wiper stalk assembly (assuming its the switch which is faulty & I know the entire assembly is all or nothing on replacement)?

Thanks in advance...I think I gotta replace the whole thing BUT just in case someone has an idea on a quick fix figured I'd post it here.

Thanks!
Reply With Quote
  #2  
Old 06-13-2010, 07:30 PM
JKK JKK is offline
Junior User
Thread Starter
 
Join Date: Mar 2006
Location: Sugar Land, TX
Posts: 50
JKK is starting off with a positive reputation.
okay, just ordered a new turn signal stalk/wiper control assembly on EBAY...dang cheapo switches cost way too much to replace..ha


if anyone has an 00' Excursion front license plate bracket they want to unload please message me...thanks!
Reply With Quote
  #3  
Old 06-13-2010, 09:26 PM
jh818's Avatar
jh818 jh818 is offline
Postmaster
 
Join Date: Jul 2009
Location: Chino, California
Posts: 2,638
jh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputation
I bought my license plate holder off Ebay for $13 last year. It was also OEM Ford.
Reply With Quote
  #4  
Old 06-19-2010, 11:00 PM
JKK JKK is offline
Junior User
Thread Starter
 
Join Date: Mar 2006
Location: Sugar Land, TX
Posts: 50
JKK is starting off with a positive reputation.
Hi all,

STILL having issues w/ wipers. I figured since they would not go off in the off position switch was bad. Ordered a new switch/turn signal assembly. Put in in today, popped fuse back in & now they don't go off at all, in high speed position, & the rear wiper won't go off either??? I figured it would just have been a bad switch but now is weirder than ever!

Anyone have any ideas?? I have no clue how to to trouble shoot this one??

Help! Thanks!

JK
Reply With Quote
  #5  
Old 06-19-2010, 11:14 PM
jdadamsjr's Avatar
jdadamsjr jdadamsjr is offline
Post Fiend
 
Join Date: Oct 2002
Posts: 11,212
jdadamsjr has a superb reputationjdadamsjr has a superb reputationjdadamsjr has a superb reputationjdadamsjr has a superb reputationjdadamsjr has a superb reputationjdadamsjr has a superb reputationjdadamsjr has a superb reputationjdadamsjr has a superb reputationjdadamsjr has a superb reputationjdadamsjr has a superb reputationjdadamsjr has a superb reputation
my uneducated guess, it's a short.... (but u knew that )

How about pulling one fuse at a time to see what effects it...


Sorry, sounds like a tough one... god luck !
Reply With Quote
  #6  
Old 06-20-2010, 01:39 AM
tonyv74 tonyv74 is offline
New User
 
Join Date: Nov 2003
Posts: 19
tonyv74 is starting off with a positive reputation.
I got a cheap turn signal lever from ebay as well and it was the same problem. The wipers wouldn't turn off after using the windshield washer fluid or just turning it on. The only way was to shut off the engine. I just sucked it up and got an OEM one at the dealer which was almost double the cost.
Reply With Quote
  #7  
Old 06-21-2010, 02:08 AM
jh818's Avatar
jh818 jh818 is offline
Postmaster
 
Join Date: Jul 2009
Location: Chino, California
Posts: 2,638
jh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputationjh818 has a superb reputation
When I replaced my multi-function switch (turn signal switch) for the 2002 Ex., it was different from the 00-01. At the time, someone on ebay from Sugarland, TX was selling the OEM for 00-01, so I couldn't use it. Bought an 02 switch from an online Ford dealership parts dept. in Ontario, OR (Gentry Ford) for $65 or something like that. My old one had the problem of the right signal not returning back after you make the turn.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
What the hell is going on with my wipers... RIKIL 1987 - 1996 F150 & Larger F-Series Trucks 3 10-04-2015 12:44 PM
wipers won't turn off except with key sammiestoyz Ranger & B-Series 2 11-26-2011 09:19 PM
wipers won't turn off except with key. 1996 ranger sammiestoyz Ranger & B-Series 2 11-26-2011 03:28 PM
1999 F-150 Wiper problems skip17 1997 - 2003 F150 4 04-06-2011 10:45 PM
wipers won't turn off???? JKK Electrical Systems/Wiring 4 06-21-2010 11:01 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
2001, 2005, 2006, 92, escape, f250, ford, jaguar, rear, shut, stalk, taurus, turn, wiper, wipers, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 06:26 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.