Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-06-2010, 07:11 AM
hsw55 hsw55 is offline
New User
 
Join Date: May 2010
Posts: 1
hsw55 is starting off with a positive reputation.
09 expedtion A/C noise

First time using A/C since I owned the vehicle. Twice now we have had the AC running when going up a hill, or going from a stop to turning up a hill, and the engine seems to drawing more power, the AC makes a quick sucking sound like a ball being sucked against a open port and once the ball is sucked against the port to close it the sound stops. It only takes a second or 2 for it to appear then stop, and once over the hill you never hear anything. The ac stays running the whole time. Any ideas
Reply With Quote
Old 05-06-2010, 07:11 AM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
03, 2010, ac, engine, expdedion, expedition, expedtion, ford, front, makes, noise, noisy, sound, sucking

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
7.3L 1993 Crew Cab 4X4 elenorzx Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 22 08-18-2014 11:15 PM
07 E350 A/C wendellsmith35 1968-2013 Full Size Vans 1 03-26-2014 07:35 AM
Looking for experience info? Country705 1994.5 - 1997 7.3L Power Stroke Diesel 19 08-29-2010 12:55 AM
A/C Vacuum Problem? raleigho Explorer, Sport Trac, Mountaineer & Aviator 4 08-05-2006 05:28 PM
1992 Explorer - A/C Fan Not Blowing, Compressor Coming On And Off runasoft Cooling, Heating, Ventilation & A/C 16 07-29-2004 11:14 AM



All times are GMT -5. The time now is 11:54 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup