Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator
Sign in using an external account
Register Forgot Password?


Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-28-2010, 04:30 PM
illgorhythm illgorhythm is offline
Freshman User
 
Join Date: Apr 2010
Posts: 38
illgorhythm is starting off with a positive reputation.
1999 Navigator Blend Door Woes....

So it would appear that I have several problems right now. A: I am only getting hot air up front.The Vent/Max AC door does work. Everything works fine in the rear, hot, cold, etc... B: Im only getting air out of the defroster, will not change between vent/floor/etc. B is not really of concern to me, I can deal with that, but A is really starting to be a B****H! Im not really sure how to diagnose the problem either. Ive read in some posts about a code (1249 i think) but I dont have a check engine light on which I assume means the computer isnt throwing out a code?? Any help appreciated.
Reply With Quote
  #2  
Old 04-28-2010, 04:47 PM
rtg143 rtg143 is offline
Junior User
 
Join Date: Jan 2010
Location: Grants Pass, Or.
Posts: 53
rtg143 is starting off with a positive reputation.
The defrost only is probably due to a vacuum leak, With no vacuum, it defaults to defrost for safety reasons. Check under the hood for vacuum lines loose, off or broken. As for the heat only, the blend door could be defective. With the engine off and the key on, turn the control from heat to cool and back while listening for the door to move. It's not very loud but you can hear it if you listen closely.
Reply With Quote
  #3  
Old 04-28-2010, 04:51 PM
illgorhythm illgorhythm is offline
Freshman User
 
Join Date: Apr 2010
Posts: 38
illgorhythm is starting off with a positive reputation.
no sound at all. silence.
Reply With Quote
  #4  
Old 04-28-2010, 04:57 PM
illgorhythm illgorhythm is offline
Freshman User
 
Join Date: Apr 2010
Posts: 38
illgorhythm is starting off with a positive reputation.
then again....

On second inspection i noticed a couple VERY faint clicks when adjusting up from 60-68 degrees, nothing after that up to 90 degrees. When I adjust back down from 90 I hear the same EXTREMELY faint clicks at 68-60. Appears to be directly behind temp control panel. Could just be some sort of relay, no clue.
Reply With Quote
  #5  
Old 04-28-2010, 05:44 PM
rtg143 rtg143 is offline
Junior User
 
Join Date: Jan 2010
Location: Grants Pass, Or.
Posts: 53
rtg143 is starting off with a positive reputation.
There are no relays controled by the dial. It's probably the blend door motor. At least they are pretty easy to get to. It's in the center of thedash and behind the lower center panel and rear air duct.
Reply With Quote
  #6  
Old 04-28-2010, 06:08 PM
illgorhythm illgorhythm is offline
Freshman User
 
Join Date: Apr 2010
Posts: 38
illgorhythm is starting off with a positive reputation.
DOH!!

HAHAHAHAH!!!! Upon FURTHER inspection..... A: The blend door is INFACT broken (Dremel'd a hole in the plenum to get to it, SOOOOO much easier than taking apart the dash!). B: There is NO BLEND DOOR ACTUATOR IN MY VEHICLE!!! WHAT??? Apparently the previous owner ripped it out in an attempt to solve the problem and then walked away from it. I realized this when I stuck my finger down the hole that the blend door sits in and my finger went through the bottom. Anyone got a part number for this thing?
Reply With Quote
  #7  
Old 04-28-2010, 07:14 PM
alloro alloro is offline
Post Fiend
 
Join Date: Apr 2008
Location: 0,0,1
Posts: 9,489
alloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to all
You can avoid removing the dash if you get the HeaterTreater kit.
1997, 1998, 1999, 2000, 2001, 2002, Lincoln Navigator, Ford Expedition, blend door auto AC heat replacement part
__________________
To thank someone, click the left red "Add to Reputation" button
right of the word "permalink" top right of the poster's message.
Reply With Quote
  #8  
Old 04-28-2010, 07:59 PM
illgorhythm illgorhythm is offline
Freshman User
 
Join Date: Apr 2010
Posts: 38
illgorhythm is starting off with a positive reputation.
Yeah HeaterTreater is where I got the idea to cut into the plenum with a dremel. Problem is they only supply the door, which is an absolute ripoff for $120.00 You can get a replacement door on ebay with a steel ring where the problem area is for around $25.00. I still need the actual actuator box.
Reply With Quote
  #9  
Old 04-28-2010, 08:17 PM
illgorhythm illgorhythm is offline
Freshman User
 
Join Date: Apr 2010
Posts: 38
illgorhythm is starting off with a positive reputation.
What the fripping heck?! I can find blend doors for this thing all day but I cant find the actuator!! AAARRRGH! Does anybody have a part number for the ACTUATOR/MOTOR ASSEMBLY?? PLEASE HELP!
Reply With Quote
  #10  
Old 04-28-2010, 10:50 PM
thecardoc thecardoc is offline
Senior User
 
Join Date: Jan 2006
Posts: 291
thecardoc is starting off with a positive reputation.
Blend door part # 660-1677 at NAPA actuator / motor # 655-1969 at NAPA
Reply With Quote
  #11  
Old 04-28-2010, 11:51 PM
illgorhythm illgorhythm is offline
Freshman User
 
Join Date: Apr 2010
Posts: 38
illgorhythm is starting off with a positive reputation.
Quote:
Originally Posted by thecardoc View Post
Blend door part # 660-1677 at NAPA actuator / motor # 655-1969 at NAPA
So heres the issue Im having, only because I dont want to buy a part and it not work. The part number you listed for the actuator/motor is specifically for a 02-03 navigator. Any search on any site for an actuator for a 98-02 navigator will ONLY yeild results for the door itself, not the actuator, even Ford OEM Parts sites DO NOT show a part number for the actuator. Its should be noted as well that the Navs had a digital temperature adjust, not a ****/potentiometer like the Expys, so I can understand if there is a SLIGHT difference between the two, But I am completely dumbfounded at the thought that NO site on the entire internet lists a part number for any 98-02 Navigator actuator/motor. Only for the door itself. Is it possible that there is any difference between the Expy actuator and the Nav???? C'mon FORD!! WTF!!!! IM SICK OF THIS DUMBF*&^%*NG NAVIGATOR! I CAN FIND ANYTHING I F(*)^&NG WANT FOR AN EXPY BUT NOT A NAV?!?!?!?! WTF!?!?!?!?!
Reply With Quote
  #12  
Old 04-29-2010, 02:51 AM
alloro alloro is offline
Post Fiend
 
Join Date: Apr 2008
Location: 0,0,1
Posts: 9,489
alloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to all
Quote:
Originally Posted by illgorhythm View Post
C'mon FORD!! WTF!!!! IM SICK OF THIS DUMBF*&^%*NG NAVIGATOR!
First off, ease up on the caffeine, second Ford doesn't make the Navigator Lincoln does. Third, I found an actuator listed on my first attempt just by clicking the link to this forum's sponsor ...Y2KFORDPARTS.

www.partsguyed.com
__________________
To thank someone, click the left red "Add to Reputation" button
right of the word "permalink" top right of the poster's message.
Reply With Quote
Old 04-29-2010, 02:51 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater vents? Old93junk Ranger & B-Series 2 09-06-2014 08:28 AM
No AC and heat is on full all the time 1great40 Cooling, Heating, Ventilation & A/C 7 06-10-2013 06:34 AM
1996 Ford Aerostar 3L - No Air Vent Flow rainfree619 Aerostar 5 08-13-2011 06:25 PM
'06 F350, Weird Vent Problem-Yes, another one. Osconda Cooling, Heating, Ventilation & A/C 2 09-28-2010 10:28 PM
Blend Door Problem tex599 1997 - 2003 F150 6 05-13-2004 11:39 AM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator

Tags
1978, 1999, 2003, actuator, blend, change, defrost, door, expedition, lincoln, location, navigator, navigtor, stuck, vacuum

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 07:30 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup