Factory Radio won't trun on. - Ford Truck Enthusiasts Forums



Factory Radio won't trun on.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-18-2010, 05:33 PM
Fordzilla80's Avatar
Fordzilla80 Fordzilla80 is offline
Postmaster
Thread Starter
 
Join Date: Jun 2008
Location: Florida
Posts: 4,969
Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.
Factory Radio won't trun on.

I have been looking for a Factory Ford Electronic Radio for my 1980 F100 for quite some time.Well,awhile back I picked one up from an 85 F250.I swapped my factory plug to the 85 style,added the memory wire to the clock memory circuit,and ran the speakers.Well,when I went to turn on the radio,I had nothing.I checked all my connections,and they were all fine.I was getting power on the radio side of the main connector.Well,I figured old radio,so i'll just look for another one.Well,I got a hit on two others,and tested them both.Same exact problem.None of them will turn on.There's no display,no sound,no anything.I decided to take them all apart and test all the solder points and wires to check and see if the radios are getting power internally.All the radios are getting power to just about every point I can try.I really don't understand it.It's as if there's nothing wrong,but they still won't turn on.Is there some kind of capacitor or something that could be blown causing the radio to not come on?All suggestions are greatly appreciated.Thanks guys.
Reply With Quote
  #2  
Old 04-18-2010, 08:05 PM
ReAX's Avatar
ReAX ReAX is offline
Post Fiend
 
Join Date: May 2006
Location: Central Florida
Posts: 10,007
ReAX is a splendid one to beholdReAX is a splendid one to beholdReAX is a splendid one to beholdReAX is a splendid one to beholdReAX is a splendid one to beholdReAX is a splendid one to behold
Does the clock light up?

You've talked about power, but how about your grounds? Do you have a good chassis ground as well as the pigtail's ground?
Reply With Quote
  #3  
Old 04-18-2010, 08:54 PM
Fordzilla80's Avatar
Fordzilla80 Fordzilla80 is offline
Postmaster
Thread Starter
 
Join Date: Jun 2008
Location: Florida
Posts: 4,969
Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.
My clock has the same exact problem,it does nothing,but gets power everywhere.

The grounds are good,i've checked and cleaned and rechecked everything.
Reply With Quote
  #4  
Old 04-21-2010, 09:43 PM
Fordzilla80's Avatar
Fordzilla80 Fordzilla80 is offline
Postmaster
Thread Starter
 
Join Date: Jun 2008
Location: Florida
Posts: 4,969
Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.Fordzilla80 has a great reputation on FTE.
Anybody else got any ideas?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
How to upgrade the stock sound on an Aerostar KhanTyranitar Aerostar 51 03-23-2015 07:51 PM
All of the sudden truck won't start 79F250isalive! 1973 - 1979 F-100 & Larger F-Series Trucks 1 10-19-2014 06:58 PM
I have hazards, but no blinkers..? mtfleming11 1994.5 - 1997 7.3L Power Stroke Diesel 19 10-13-2014 09:26 PM
Installed radio now no turn signal or parking light! 79F250isalive! 1973 - 1979 F-100 & Larger F-Series Trucks 0 10-08-2014 05:25 PM
Radio installation 86 f-150 RangerDude17 1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks 5 01-25-2014 05:38 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
1980, 2004, blown, check, f100, f150, factory, ford, oem, power, problem, radio, raido, stock, truck, turn, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 05:17 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.