95 explorer 4wd problems - Ford Truck Enthusiasts Forums



Explorer, Sport Trac, Mountaineer & Aviator 1991-1994, 1995-2001, 2002-2005, 2006-2010 Ford Explorer

95 explorer 4wd problems

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 03-29-2010, 07:02 PM
buckeyes8603 buckeyes8603 is offline
New User
Thread Starter
 
Join Date: Dec 2008
Posts: 16
buckeyes8603 is starting off with a positive reputation.
95 explorer 4wd problems

95 explorer 180000 miles have question on 4wd when I turn on the 4wd it will engage and run fine however the light after a short while will blink a few times and then go off and after some more time will blink again a few times then go off but I believe the 4wd is working the whole time any suggestions on what it would be or how to go about to fix the problem would be greatly appreciated<?xml:namespace prefix = o ns = "urn:schemas-microsoft-comfficeffice" /><o></o>
<o></o>
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
351 Windsor Build Micbruff 1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks 23 11-05-2014 08:17 PM
SPONGY CLUTCH? epdukes13 1987 - 1996 F150 & Larger F-Series Trucks 3 07-28-2012 12:33 PM
Tilt Steering Column Problems keithredfirebird 1973 - 1979 F-100 & Larger F-Series Trucks 5 04-30-2010 07:28 AM
Getting Frustrated with 4x4 after hub change... kittyhawksurf 1999 to 2016 Super Duty 33 07-10-2009 03:58 PM
Quits pulling - Fuel pump? avgjoe 1999 - 2003 7.3L Power Stroke Diesel 10 12-28-2004 11:42 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
1995, 4wd, 95, 96, drive, engage, explorer, ford, problem, problems, wheel, working, works

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 03:00 PM.