Speedo Acting Up...What's My Problem? - Ford Truck Enthusiasts Forums



6.0L Power Stroke Diesel 2003 - 2007 F250, F350 pickup and F350+ Cab Chassis, 2003 - 2005 Excursion and 2003 - 2009 van

Speedo Acting Up...What's My Problem?

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-01-2010, 09:50 PM
motor-man's Avatar
motor-man motor-man is offline
Senior User
Thread Starter
 
Join Date: Oct 2009
Location: Ontario
Posts: 374
motor-man is starting off with a positive reputation.
Speedo Acting Up...What's My Problem?

Hey guys.

So for about the past 3 weeks I have been putting up with my speedometer acting up. It will either...

1.) Not work what-so-ever.
2.) Try working but will be inacurate
3.) Work fine (20% of the time)
4.) Work fine, then stop working lets say at 80km/h and will stop. Next start up the truck will think that it is at zero (even though it's still at 80), so another 80km/h and it reads 160km/h.

Whats the problem here guys?

Thanks.
Reply With Quote
  #2  
Old 03-01-2010, 10:34 PM
jboczar jboczar is offline
Senior User
 
Join Date: Jun 2009
Location: Clearwater
Posts: 311
jboczar has a good reputation on FTE.jboczar has a good reputation on FTE.
more than likely you need a replacement instrument cluster. You could have your vehicle scanned for codes but if it doesn't generate any codes for either the cluster or the abs module then the cluster is bad. Try ebay or maybe a reputable you junkyard, you don't want to buy one from the dealership, they are very expensive.
Reply With Quote
  #3  
Old 03-01-2010, 10:48 PM
motor-man's Avatar
motor-man motor-man is offline
Senior User
Thread Starter
 
Join Date: Oct 2009
Location: Ontario
Posts: 374
motor-man is starting off with a positive reputation.
Quote:
Originally Posted by jboczar View Post
more than likely you need a replacement instrument cluster. You could have your vehicle scanned for codes but if it doesn't generate any codes for either the cluster or the abs module then the cluster is bad. Try ebay or maybe a reputable you junkyard, you don't want to buy one from the dealership, they are very expensive.
Thanks. A little over a week ago my ABS light came on. The next day about halfway to the dealership the light went out. I went anyways to see if there were still codes and get them checked out. The tech said there was a code for the driver front ABS, and some kind of code that required some kind of new flash (not exactly sure). After he cleared the codes, the light has not come back on, but the speedo was still whacky.
Reply With Quote
  #4  
Old 03-01-2010, 10:59 PM
bismic's Avatar
bismic bismic is offline
Post Fiend
 
Join Date: Nov 2003
Posts: 15,132
bismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputation
I have read that sometimes turning your lights on and disconnecting your batteries will correct the problem for a period of time. Might be worh a try while you look for good pricing on the parts.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
6.0 high speed, rpm's stay high, bounce Tanbeard 6.0L Power Stroke Diesel 4 05-23-2013 02:02 PM
Metric speedometer calibration shia1 1978 - 1996 Big Bronco 7 05-26-2009 05:32 AM
How fast in 4X4 high? advocate 1997 - 2003 F150 30 12-24-2008 12:59 PM
Vibration in truck jason1 Ranger & B-Series 2 11-18-2008 07:03 PM
Surging under hard throttle Manwith3fords 1987 - 1996 F150 & Larger F-Series Trucks 18 02-29-2004 05:34 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
2003, 2005, 2006, 2007, 60, cluster, dosent, f250, ford, lariet, powerstroke, quit, speedometer, sticking, work, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 01:09 AM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.