Go Back   Ford Truck Enthusiasts Forums > Diesel > Pre-Power Stroke Diesel (7.3L IDI & 6.9L)
Sign in using an external account
Register Forgot Password?


Pre-Power Stroke Diesel (7.3L IDI & 6.9L) Diesel Topics Only

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 03-01-2010, 03:32 PM
lemonshindig lemonshindig is offline
Elder User
 
Join Date: Feb 2010
Location: Port Orchard, WA
Posts: 732
lemonshindig is starting off with a positive reputation.
I need a fuse panel diagram for my '86

Can't find any diagram in the truck and can't find anything in the Chilton's manual either... worthless. There are fuses missing from the panel, and my tail lights don't work. Both filaments in the bulbs are fine, and the brake lights work, so I'm guessing there's a fuse for the tail lights.

Thanks
-Matt
Reply With Quote
  #2 (permalink)  
Old 03-01-2010, 06:13 PM
Dave Sponaugle's Avatar
Dave Sponaugle Dave Sponaugle is offline
Post Fiend
 
Join Date: Nov 2003
Location: Nutter Fort, WV
Posts: 21,266
Dave Sponaugle is a splendid one to beholdDave Sponaugle is a splendid one to beholdDave Sponaugle is a splendid one to beholdDave Sponaugle is a splendid one to beholdDave Sponaugle is a splendid one to beholdDave Sponaugle is a splendid one to beholdDave Sponaugle is a splendid one to behold
At the rear of the frame, drivers side, there is a round connector that has 4 conductors.

Park lights, left turn, right turn and reverse lights.

My guess is the park light conductor has corrosion in it.

Rear side markers are not working either would be my guess?
__________________
86 F250 HD 6.9 IDI ATS turbo "not exactly" stock 4x4 T19 BW1345 3.55LS both ends D60 front, 10.25" Sterling rear, ram air, dual stacks.

"I dig dirt"

FTE Guidelines

FTE Moderator IDI diesel forum

WV Chapter Member
Reply With Quote
  #3 (permalink)  
Old 03-01-2010, 07:50 PM
PLC7.3 PLC7.3 is offline
Post Fiend
 
Join Date: Nov 2004
Location: Manitoba
Posts: 5,638
PLC7.3 is gaining momentum as a positive member of FTE.
I would advise also check the main light switch connector under the dash and the switch contacts for burned up..... a known problem.

Truck Tech pictures from hobbies & interests photos on webshots
__________________
93 F250 SC 4x4 E4OD 355LS
Reply With Quote
Old 03-01-2010, 07:50 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Diesel > Pre-Power Stroke Diesel (7.3L IDI & 6.9L)

Tags
1986, 69, 69l, 86, box, diagram, f150, f250, f350, ford, fuse, location, main, panel, truck

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 05:17 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup