Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Super Duty & Heavy Duty
Sign in using an external account
Register Forgot Password?


Super Duty & Heavy Duty 1999 to current Ford F250, F350, F450 and F550 Super Duty with diesel V8 and gas V8 and V10 engines SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #16  
Old 11-16-2012, 03:53 PM
dpigme dpigme is offline
New User
 
Join Date: Nov 2012
Location: st louis
Posts: 3
dpigme is starting off with a positive reputation.
dan mays
i have a f250 diesel that at times when cold out the gauges will go back and forth while driving
battery light comes on and windows wont work
stop restart and its ok till the next time it happens
any help out there
iv ck all wiring to cluster and column seems t happen when tach hits 2000 rpm but not all the time
Reply With Quote
  #17  
Old 11-16-2012, 04:59 PM
intlenus intlenus is offline
New User
 
Join Date: Jan 2011
Posts: 1
intlenus is starting off with a positive reputation.
Gem Module

I just had the same problems including shift on the fly 4X4 not working. after trying everything possible as everyone has mentioned we found the GEM Module located behind the interior fuse box, actually bolted to the back of it, had a burnt electrical smell so we replaced it and all is well once more. You can get a replacement gem module at the dealer for about $600 or from autopartscheaper.com. They have a blog that explains this unit, what it does and the indications that it is going bad. use the link below
http://blog.autopartscheaper.com/?p=38

The link below was for my rig
1999 2000 Ford F-250 Super Duty or F-350 Genuine Ford GEM Module With keyless entry
Look for the on that fits your setup or call them they are very helpful.
Reply With Quote
  #18  
Old 11-17-2012, 08:39 AM
dpigme dpigme is offline
New User
 
Join Date: Nov 2012
Location: st louis
Posts: 3
dpigme is starting off with a positive reputation.
dan mays
thanks for the info
but my truck is a 02 there is no gem behind the fuse box
i think the gem is in the instrument cluster
if any of you know
or any other suggestions
i need help
Reply With Quote
  #19  
Old 12-05-2012, 10:49 PM
David_396 David_396 is offline
New User
 
Join Date: Jan 2011
Posts: 3
David_396 is starting off with a positive reputation.
Have the same problem with my 02'. Battery light flickers at times. Battery light would also stay on at times but gauges would continue to work. Now when light comes on, alll gauges widows and radio quit working. Restart, and problem goes away for weeks or days. ???????
Reply With Quote
  #20  
Old 12-06-2012, 07:27 AM
Jmatthews's Avatar
Jmatthews Jmatthews is offline
is a BAAAD MAN
 
Join Date: Apr 2005
Location: Winston Salem NC
Posts: 3,275
Jmatthews has a superb reputationJmatthews has a superb reputationJmatthews has a superb reputationJmatthews has a superb reputationJmatthews has a superb reputationJmatthews has a superb reputationJmatthews has a superb reputationJmatthews has a superb reputationJmatthews has a superb reputationJmatthews has a superb reputationJmatthews has a superb reputation
I got a new radio and my problem went away.
__________________
John
2001 7.3 F-250 LB 6sp. Dump bed, Firestone air bags, DP tuner, 4" MBRP, K&N intake with 6637, in tank mods
2002 7.3 EX limited 4x4, ccv mod, edge evo, 6637, RAS, In tank mods, diesel site tranny filter, JW valve body
Reply With Quote
  #21  
Old 03-25-2013, 07:51 AM
jimmy4321 jimmy4321 is offline
Freshman User
 
Join Date: Aug 2010
Posts: 41
jimmy4321 is starting off with a positive reputation.
I have an 04 F350 with same issues.First thing I notice is a quick brake warning light flicker followed by ALL my gauges reading zero, at the same time my radio dies and my power windows.This may last 30sec to a couple minutes, then radio turns on and all gauges max out then drop to normal readings.

Find it odd that theres no fix for this, its not all uncommon
Reply With Quote
  #22  
Old 03-26-2013, 12:48 AM
dammdoggs dammdoggs is offline
New User
 
Join Date: Mar 2013
Posts: 1
dammdoggs is starting off with a positive reputation.
Quote:
Originally Posted by freefal View Post
I have 2003 F250 SD XLT 4x4 that has problems with check engine light comes on at start up and then the radio,windows,instrument cluster and wipers all do not work. After a few seconds/minutes you hear a relay make noise and everything comes on except for the wipers. I can usually smack on the dash just above the radio and wipers will begin to work. I have replaced instrument cluster,GEM module and had entire dash apart. Had a mechanic work on it for more than 3 weeks looking all with no luck in finding reason. Could this be a ground issue under the dash or possibly a problem in the radio itself since hitting dash above radio will most of time correct????
I have a 02 f350 gasser... and I have been experiencing this for the last year or so... but finally beating on the dash no longer fixes it. As of now... when I turn the key to the on position... the guages/radio don't come on for about 15 seconds or so.. and the wipers don't work period... even after everything else comes on... I REALLY need to get my wipers working as I use this to haul heavy equipment with... and can't do it reliably until I can find a fix...

Has anyone found a fix for this yet?

Thanks ... great site btw...
Reply With Quote
  #23  
Old 11-19-2013, 09:45 AM
Arterburyka Arterburyka is offline
New User
 
Join Date: Nov 2013
Posts: 5
Arterburyka is starting off with a positive reputation.
Has anyone found out the answer to this problem I have an 07 f250 harley edition and my dash gauges radio and window locks and door locks go out my headlights will dim and get bright before this happens?
Reply With Quote
  #24  
Old 11-19-2013, 10:01 AM
jimmy4321 jimmy4321 is offline
Freshman User
 
Join Date: Aug 2010
Posts: 41
jimmy4321 is starting off with a positive reputation.
I'm not a mechanic.
When I hit the top right part of my cluster while vehicle is running, it fixes it more times than not for a breif period of time.(though increasingly gets more difficult)
I took my instrument cluster out looking for anything loose but all looked snug.There is however a pin connect at top right and got the problem to react once to me applying pressure on connector, coincidence??? Maybe.

I don't know what issues occur if that connector or anything internal near fails.
Reply With Quote
  #25  
Old 11-19-2013, 10:16 AM
Arterburyka Arterburyka is offline
New User
 
Join Date: Nov 2013
Posts: 5
Arterburyka is starting off with a positive reputation.
I tried hitting the dash and it does not make a difference on mine it does seem to act up while driving on the highway and seem to act up when letting off the throttle at 75mph and comes back on when you speed back up
Reply With Quote
  #26  
Old 11-19-2013, 10:21 AM
jimmy4321 jimmy4321 is offline
Freshman User
 
Join Date: Aug 2010
Posts: 41
jimmy4321 is starting off with a positive reputation.
Only things effected on mine are
Radio, power windows, all gauges die or max out, or combo of both.
Dome lights

My headlings uneffected.
If you find an answer, please post it.This issue is getting old.
Reply With Quote
  #27  
Old 11-19-2013, 11:13 AM
Arterburyka Arterburyka is offline
New User
 
Join Date: Nov 2013
Posts: 5
Arterburyka is starting off with a positive reputation.
I am ready to sell mine I'm tired of fixing it if anyone interested let me know
Reply With Quote
  #28  
Old 11-22-2013, 02:24 AM
big poppa's Avatar
big poppa big poppa is offline
Post Fiend
 
Join Date: Feb 2008
Location: Lancaster, Pa.
Posts: 10,970
big poppa has a spectacular reputation.big poppa has a spectacular reputation.big poppa has a spectacular reputation.big poppa has a spectacular reputation.big poppa has a spectacular reputation.big poppa has a spectacular reputation.big poppa has a spectacular reputation.big poppa has a spectacular reputation.big poppa has a spectacular reputation.big poppa has a spectacular reputation.big poppa has a spectacular reputation.
Same problem here also, windows and radio lose power but intermitinly come back on. Did notice though after getting new batteries and now the radio goes on by itself. I'll turn it off but then goes on again. My volts are higher now at 14.1 to 14.6 volts and i'm wondering if the spike in voltage is the reason for that problem now. I'm thinking voltage regulator or the gem module.
__________________
Mike's 03 [FONT=Verdana]F-250 7.3 CC SB XLT 4x4 Auto and just joined the 229,000 miles and counting. [FONT=Comic Sans MS]PAA#26 Wife's: Whoops, I mean an 08 (Explorer) Eddie B. 4.0 v6 4x4 109,000
Reply With Quote
  #29  
Old 11-22-2013, 02:58 AM
scotttahoe's Avatar
scotttahoe scotttahoe is offline
Lost in the class of AE
 
Join Date: Jan 2013
Location: North Lake Tahoe
Posts: 889
scotttahoe has a great reputation on FTE.scotttahoe has a great reputation on FTE.scotttahoe has a great reputation on FTE.scotttahoe has a great reputation on FTE.
I am assuming your glove box light does not work as well with the windows, radio, and map lights.

The problem is inside your gauge cluster and will need to be replaced. There is a circuit board inside the cluster along with a relay that is timed, what this relay does is when you turn off the truck your power windows and radio will stay on until you open the door. Now the solder on that circuit board somewhere has corroded or broken free, if it has broken free there will be no intermittent with radio, power windows etc it just plain won't work.

At Ford a new gauge cluster will cost you around 500 bucks along with reprograming for your current miles. On the Excursion side of this forum someone I think it was HOME WORKS has found a guy that will replace the cluster along with reprograming for your miles for around 265 shipped. I called the guy up and he sounds like he knows what he's talking about and will provide a discount for using this forum.

Advanced Auto Electronics
1-866-427-1112 Speak with Carey.
Hope this helps.
__________________
Scotty and the "Grinch" E99 Ford f-250 7.3 4X4, 6" lift all springs no blocks, 6637 intake kit, 4" exhaust turbo back, 6 gauges, Sinister Diesel coolant filter, Warn premium locking hubs, F-650 dash kit, HPx, 3 trumpet air chime train horn, and more.
Reply With Quote
  #30  
Old 11-22-2013, 11:16 AM
Arterburyka Arterburyka is offline
New User
 
Join Date: Nov 2013
Posts: 5
Arterburyka is starting off with a positive reputation.
Is it confirmed that this has fixed these on other vehicles I would hate to spend the money to replace it and it not work
Reply With Quote
Old 11-22-2013, 11:16 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
97 ranger door chime and some light Rangerdanger7 New Member Introductions 1 12-14-2014 01:55 AM
Tried to fix pwr window now have elec problem tnwalker01 Expedition & Navigator 3 07-16-2012 03:12 PM
Please Help! (New) rynomush1 1999 - 2003 7.3L Power Stroke Diesel 8 03-01-2009 12:42 AM
2003 F-350 Electrical Problems rynomush1 Super Duty & Heavy Duty 3 01-18-2009 07:43 PM
Noise suppression plug wires Pony Power Explorer, Sport Trac, Mountaineer & Aviator 2 03-19-2006 05:34 PM


Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Super Duty & Heavy Duty

Tags
2003, 2004, drivers, excursion, f150, f250, f350, ford, gauges, intermittent, radio, shut, truck, window, wirking, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 01:06 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup