Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-22-2009, 08:03 PM
PASBON PASBON is offline
New User
 
Join Date: Oct 2009
Posts: 5
PASBON is starting off with a positive reputation.
07 f-150 5.4 fuel problem (i think)

07 f-150 5.4 fuel problem (i think)


I have a 2007 f150 5.4 lariat that sputters when I mash the gas , 93,000 miles , just changed fuel filter (had black trash in it), added lucas injector cleaner to full tank and ran tank to neer empty, filled tank , added lucas again and burned half tank then changed fuel filter again . still has same problem , gave a code one time, turned off truck and code went off. never gave code again .checked it with a code reader and everything is fine, engine runs great at normal driving speeds , has anyone had this problem ? I can turn some wrenches, but would like to go straight to the problem if i could and not spend a weekend finding the problem. Any ideas ?
Thanks in advance
Click the image to open in full size.
Reply With Quote
  #2  
Old 10-28-2009, 03:09 PM
LxMan1's Avatar
LxMan1 LxMan1 is offline
Moderator
 
Join Date: Dec 2001
Location: Louisville,Ky.
Posts: 22,229
LxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant future
I'm going to say look into the TPS sensor and possibly cleaning the MAF.

Have you put spark plugs in it yet @ 93K?
__________________
Jimmy- FTE Moderator

88 5.0 LX Mustang
63 F100 351W/C6

Reply With Quote
  #3  
Old 10-28-2009, 04:50 PM
PASBON PASBON is offline
New User
 
Join Date: Oct 2009
Posts: 5
PASBON is starting off with a positive reputation.
I just got the truck about 3 months , and I dont think the plugs have been changed .
Reply With Quote
  #4  
Old 10-28-2009, 06:06 PM
PASBON PASBON is offline
New User
 
Join Date: Oct 2009
Posts: 5
PASBON is starting off with a positive reputation.
got it to read a code , catalintic converter , (po420) the only problem , it was doing this for a few weeks before i got the code.



where can i find instructions to clean the mass air flow ?
Reply With Quote
  #5  
Old 10-29-2009, 08:16 AM
baredog26 baredog26 is offline
Freshman User
 
Join Date: Mar 2004
Posts: 26
baredog26 is starting off with a positive reputation.
If your plugs haven't been changed I would change them first. If that doesn't work I would say your converters are bad, and with 90,000 miles they are out of warranty.
Reply With Quote
Old 10-29-2009, 08:16 AM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)

Tags
07, 46, 54, f150, filter, ford, fuel, problem, problems, troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 01:23 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup