Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 09-15-2009, 10:02 AM
MPDano MPDano is offline
Junior User
 
Join Date: Jul 2003
Posts: 56
MPDano is starting off with a positive reputation.
Exclamation 97 Expedition Headlights/Fogs not working?

Hello all!

This morning my Headlights and Fog Lights didn't turn on. All my running and parking lights work perfectly. I did go online and found the fuse chart but the fuse under the hood was fine. I even changed it out with a new one of the same amp.

Any suggestions on troubleshooting this?
Reply With Quote
  #2 (permalink)  
Old 09-15-2009, 10:44 AM
1ATony's Avatar
1ATony 1ATony is offline
PREMIUM SPONSOR
 
Join Date: Mar 2009
Location: Pepperell
Posts: 4,815
1ATony is a name known to all1ATony is a name known to all1ATony is a name known to all1ATony is a name known to all1ATony is a name known to all1ATony is a name known to all
Sounds like the switch may have gone bad.
__________________

Click Here^^ For a Great Selection Of Auto Repair Parts
Reply With Quote
  #3 (permalink)  
Old 09-15-2009, 11:00 AM
MPDano MPDano is offline
Junior User
 
Join Date: Jul 2003
Posts: 56
MPDano is starting off with a positive reputation.
Quote:
Originally Posted by 1ATony View Post
Sounds like the switch may have gone bad.
I was thinking the same thing. Do you know the part number off hand?
Reply With Quote
  #4 (permalink)  
Old 09-15-2009, 11:19 AM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,007
berry1234 is gaining momentum as a positive member of FTE.
http://shop.ebay.com/?_from=R40&_trk...All-Categories
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #5 (permalink)  
Old 09-15-2009, 06:09 PM
IQ9 IQ9 is offline
Senior User
 
Join Date: Sep 2007
Posts: 351
IQ9 is starting off with a positive reputation.
Isn't this posted in the wrong section being a 97? If you had no luck I kinda understand BUT.....
__________________
White Sand 08 Expy EL Limited 4x4 with everything but the power running boards & trip tunes.
Reply With Quote
  #6 (permalink)  
Old 09-15-2009, 06:14 PM
MPDano MPDano is offline
Junior User
 
Join Date: Jul 2003
Posts: 56
MPDano is starting off with a positive reputation.
Sorry, I just realized that. I saw 7 in the forum and didn't pay close attention.
Reply With Quote
  #7 (permalink)  
Old 09-17-2009, 02:26 AM
IQ9 IQ9 is offline
Senior User
 
Join Date: Sep 2007
Posts: 351
IQ9 is starting off with a positive reputation.
No real issue I just don't want you getting annoyed as to why very few folks help out.
__________________
White Sand 08 Expy EL Limited 4x4 with everything but the power running boards & trip tunes.
Reply With Quote
Old 09-17-2009, 02:26 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
97, 97expedition, car, change, dont, expedition, fog, foglights, ford, headlights, lamps, lights, makes, show, work, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 04:45 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup