OD light blinking - Ford Truck Enthusiasts Forums



1987 - 1996 F150 & Larger F-Series Trucks 1987 - 1996 Ford F-150, F-250, F-350 and larger pickups - including the 1997 heavy-duty F250/F350+ trucks

OD light blinking

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-11-2009, 11:08 AM
jimandjimmer jimandjimmer is offline
Freshman User
Thread Starter
 
Join Date: Jul 2006
Posts: 36
jimandjimmer is starting off with a positive reputation.
OD light blinking

Hey guys I have a 95 150 Supercab 4x4 5.0. It had been sitting for about 8 months with brake problems and I recently had it taken in and had about 850 worth of brake and other work done to it. I had 4 new tires put on, all fluids changed and something called a transtech done to the transmission (it apparently drains all the fluid and then they replace it). I also had a rear ABS sensor put on as my ABS light was showing up on the dashboard. Anyways, after I got my truck back, it runs fine, however I have noticed that my speedometer stopped working and the cruise control wont work either. The overdrive off light that is on my gear shift lever also blinks on and off, there is no apparent code it just blinks on and off and the transmission shifts and works fine. If I am in park or below about ten mph, the OD light does not blink and the speedo needle jumps up and down erratically, but as I pick up speed the needle goes down to 0 and the OD light starts blinking. On another note Ive noticed the last couple of times Ive started my truck up, the engine turns over and idles rough for about 5 minutes and then after it warms up it idles fine and runs strong, there does seem to be a slight miss but im thinking its in one of the spark plugs. Do you guys have any idea about what might be causing the light as well as the rough startup idle?
Reply With Quote
  #2  
Old 09-11-2009, 11:49 AM
subford's Avatar
subford subford is online now
Post Fiend
 
Join Date: Aug 2005
Location: Easton,Ks
Posts: 19,923
subford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud of
You have a bad or miss installed VSS sensor on the top of the rear end.
They may have also messed up the tone ring when they changed it.
Some other years called this sensor the DSS or ABS sensor.

Why did you have it replaced if it was working fine?
Reply With Quote
  #3  
Old 09-11-2009, 12:01 PM
jimandjimmer jimandjimmer is offline
Freshman User
Thread Starter
 
Join Date: Jul 2006
Posts: 36
jimandjimmer is starting off with a positive reputation.
it was showing an ABS light before i took it in, thats why i had the sensor replaced.
Reply With Quote
  #4  
Old 09-11-2009, 12:02 PM
jimandjimmer jimandjimmer is offline
Freshman User
Thread Starter
 
Join Date: Jul 2006
Posts: 36
jimandjimmer is starting off with a positive reputation.
btw what is a tone ring?
Reply With Quote
  #5  
Old 09-11-2009, 12:08 PM
rocketfootballer rocketfootballer is offline
Freshman User
 
Join Date: Mar 2009
Location: Lima, Ohio/Tionesta, Pa
Posts: 31
rocketfootballer is starting off with a positive reputation.
The tone ring is a ring mounted on the drivers side of the carrier in your rear differential. It has evenly spaced humps on it (very closely together) and then your abs sensor, which doubles as your vss picks up the magnetic pulse off of each hump and that is how it achieves a speed signal or a lock up for the abs
Reply With Quote
  #6  
Old 09-11-2009, 12:32 PM
subford's Avatar
subford subford is online now
Post Fiend
 
Join Date: Aug 2005
Location: Easton,Ks
Posts: 19,923
subford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud of
Quote:
Originally Posted by jimandjimmer View Post
it was showing an ABS light before i took it in, thats why i had the sensor replaced.
Is the ABS light still on?
Reply With Quote
  #7  
Old 09-12-2009, 06:49 AM
jimandjimmer jimandjimmer is offline
Freshman User
Thread Starter
 
Join Date: Jul 2006
Posts: 36
jimandjimmer is starting off with a positive reputation.
now it only comes on about once every other day for about 20 minutes or so, i got under the truck yesterday and wiggled the abs connector on my rear end as i was leaving work...the speedo acted like it wanted to work and the light didnt blink, but then it quit and started doing the same thing over again..blinking, erratic jumping of speedo needle etc.
Reply With Quote
  #8  
Old 09-12-2009, 07:01 AM
subford's Avatar
subford subford is online now
Post Fiend
 
Join Date: Aug 2005
Location: Easton,Ks
Posts: 19,923
subford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud of
They messed something up back there. Either the plug, the sensor or the tone ring.
Was the speedometer was working OK when you took it in?
Reply With Quote
  #9  
Old 09-12-2009, 07:07 AM
jimandjimmer jimandjimmer is offline
Freshman User
Thread Starter
 
Join Date: Jul 2006
Posts: 36
jimandjimmer is starting off with a positive reputation.
yeah the last time i drove the truck before taking it in, it worked. The ABS light was coming on then, thats why i had them replace the sensor. I dont know what all they done when they installed the new one, i just know that there is a new one on my rear end housing now. The only thing that I think they did inside the rear differential was to pop the bottom of the cover and drain the fluid and replace it with new.
Reply With Quote
  #10  
Old 09-12-2009, 07:16 AM
subford's Avatar
subford subford is online now
Post Fiend
 
Join Date: Aug 2005
Location: Easton,Ks
Posts: 19,923
subford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud of
You could try unplugging the ABS module under the dash and see if the speedometer starts working again.
If not try checking the voltage from the rear end with a meter.
Put the rear end up on stands and run it slowly up to about 30 MPH.
Does the voltage increase smoothly and continuously from 0 to approximately 3.5 volts (at connector C143) as vehicle speed increases from 0 to 30 mph?

C143 is located at the drivers side hood hinge.
Reply With Quote
  #11  
Old 09-12-2009, 07:23 AM
subford's Avatar
subford subford is online now
Post Fiend
 
Join Date: Aug 2005
Location: Easton,Ks
Posts: 19,923
subford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud ofsubford has much to be proud of
Here is a wiring diagram of the 1995 system:


C143:


/
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
no speedometer and blinking od light bcaughhorn 1999 - 2003 7.3L Power Stroke Diesel 3 11-13-2015 09:17 PM
Torque Converter Control solenoid code P0743 F150vettehauler 2004 - 2008 F150 14 06-21-2014 06:31 PM
1992 F-150 351/E4OD Blinking OD Light TX92F150 1987 - 1996 F150 & Larger F-Series Trucks 5 08-08-2013 08:32 PM
97 E4OD slip code P1728 help tuffy300 Clutch, Transmission, Differential, Axle & Transfer Case 3 05-10-2010 05:12 AM
Speedometer and odometer going bad? eehoepp Aerostar 7 04-27-2007 02:15 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
1994, 96, blinking, blinks, cruise, f150, flashing, ford, light, od, overdirive, overdrive, shutting, speedometer, truck, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 09:36 PM.