Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator
Sign in using an external account
Register Forgot Password?


Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-16-2002, 07:25 AM
DCS 03 DCS 03 is offline
Freshman User
 
Join Date: May 2002
Posts: 37
DCS 03 is starting off with a positive reputation.
Adv Trac Light

The Adv Trac light came on in our '03 Expedition (3600 miles). Message Center read Adv Trac Off. Dealer performed an IVD calibration "per SSM 1 6336" and the light is now off.

Any idea what happened? Is this a random occurrence, or should I be looking for more fixes down the road?

Thanks
Reply With Quote
  #2  
Old 11-16-2002, 10:12 PM
Mattias Mattias is offline
Senior User
 
Join Date: Jun 2002
Posts: 199
Mattias is starting off with a positive reputation.
Adv Trac Light

My AdvanceTrac kept switching itself OFF at the end of my first week of ownership.

The dealer tried resetting the software but it finally took an "update" and it's been okay (knock on wood) ever since.

"update"?!? My Expy couldn't been more than 3-4 weeks old from the manufacturing floor when this happened? Is it Microsoft software?

Good luck.
Reply With Quote
  #3  
Old 11-22-2002, 04:02 PM
mneblett mneblett is offline
Junior User
 
Join Date: Nov 2002
Posts: 56
mneblett is starting off with a positive reputation.
Adv Trac Light

This is interesting; another datapoint, FWIW:

Early today my wife called and said the "Check AdvanceTrak" message had appeared on her new one-week-old '03. She took it in to the dealer later in the morning.

This afternoon the shop called to say it was "fixed," and told her that they had "recalibrated" the AdvanceTrak system. They didn't tell her what was done to "recalibrate" it. In light of the "update" discussed above, I'm wondering whether they just executed a built-in calibration sequence using the original system, or flashed in an updated version. No way of knowing, I guess, without access to a computer that can read the software revision level.

She did ask the service manager why/how the system could have become out of calibration within only a week, and was told that it may have come from the factory out of calibration. I suppose that's possible, but if it's a simple software calibration, I would expect that would be a nearly impossible to screw-up factory procedure. Makes me wonder all the more whether our '03 was "recalibrated" or "upgraded."

In any event, if the problem recurs or I learn more about what was done, I'll "update" this post.

Mark
Reply With Quote
  #4  
Old 11-22-2002, 05:31 PM
meridian1 meridian1 is offline
Junior User
 
Join Date: May 2002
Posts: 85
meridian1 is starting off with a positive reputation.
Adv Trac Light

More data. I have had my 03 EB since June, and early adopter. When I had a few hundred miles on it, my "check advance trac" came on. I happened to be (really) right in front of a Ford dealership and it was about 8am, so I just pulled in an got an line. A service manager chatted with me, and then with some other employees, and came back and said that the truck was so new that they were not sure they would know how to service this. But, he suggested I might want to cycle the ignition and see if the warning cleared. It did. Then I drove around his lot for a while, and it did not come back, so I left. Now, I have 12,000 miles on the truck and have never seen this happen again. I have been assuming that my Advance Trac is, therefore, working.
Reply With Quote
  #5  
Old 11-29-2002, 01:37 AM
lostalien lostalien is offline
New User
 
Join Date: Sep 2002
Location: Pacifica, CA
Posts: 21
lostalien is starting off with a positive reputation.
Adv Trac Light

meridian1, I had the same thing happened to me after I actually made a couple of hard cornerings and tried to see how far I can push the truck. After it slide around for a bit the Advanctrac light came on and stayed on. I turned off the engine and started the truck again and since then I too have not seen the light come back on. Wierd???


Lostalien
03 Expy 5.4L 4x4
Waag Step Bars
www.lostalien.com


Reply With Quote
  #6  
Old 11-29-2002, 04:25 PM
kitkerr kitkerr is offline
New User
 
Join Date: Nov 2002
Location: canada
Posts: 2
kitkerr is starting off with a positive reputation.
Post Adv Trac Light

Reply With Quote
Old 11-29-2002, 04:25 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator

Tags
03, 2005, adv, advance, advancetrac, advtrac, check, code, expedition, ford, light, navigator, system, trac, warning

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 07:15 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup