Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 06-22-2009, 07:31 AM
n2umr n2umr is offline
Senior User
 
Join Date: Jul 2003
Location: NY
Posts: 251
n2umr is gaining momentum as a positive member of FTE.n2umr is gaining momentum as a positive member of FTE.
Wacked out 07 expy

So I came out to my truck this morning and found the headlight and taillights blinking, don't know why. tried to start and the battery was dead. So I connected my charger up to the battery and he truck went berserk. The info display was showing every message and symbol it could, lights were still on and the radio would turn on and off by itself, no key in the ignition. So disconnected the battery for a few minutes but no difference so I am going to leave it disconnected until I get home from work. Any ideas, could this be a result of a dead battery or something else, nothing I could see was left on overnight. WEIRD!

Mark
Reply With Quote
  #2 (permalink)  
Old 06-22-2009, 09:04 AM
function12's Avatar
function12 function12 is offline
Senior User
 
Join Date: Jan 2002
Location: houston
Posts: 496
function12 is starting off with a positive reputation.
Did someone try to steal it?
__________________
See ya,
Eric
Reply With Quote
  #3 (permalink)  
Old 06-22-2009, 09:15 AM
n2umr n2umr is offline
Senior User
 
Join Date: Jul 2003
Location: NY
Posts: 251
n2umr is gaining momentum as a positive member of FTE.n2umr is gaining momentum as a positive member of FTE.
Don't know, everything was in tact and nothing was missing. Keys were still in the center console when I opened it up because thats what I thought too. I did notice that the lock idiot light on the dash was blinking. Doors were unlocked and nothing was missing, sat radio, ham radio, CD's laptop all there. No panels removed or wire that I could see.
Reply With Quote
  #4 (permalink)  
Old 06-22-2009, 11:09 AM
Tylus's Avatar
Tylus Tylus is online now
MMNC (SS)
 
Join Date: Mar 2004
Location: Pearl Harbor
Posts: 10,510
Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.
it is your battery

these new Fords do that when the battery goes dead, or very nearly dead.


my 06 F-150 went ape**** on me one day just like you described. I took battery from my SUV and the craziness stopped. Original Battery in truck tested out bad at the store



get a new battery that is fully charged and it will go away...sorry it gave you such a scare. If you check the 04-08 F-150 area, you'll see alot of posts about this happening
__________________
2002 Excursion XLT w/ V-10 <---Build thread
2015 Chevrolet Tahoe - I've owned 4 brand new Fords since 2006. Notice that I bought a Chevy this time. That should tell you something
Reply With Quote
  #5 (permalink)  
Old 06-23-2009, 08:13 AM
n2umr n2umr is offline
Senior User
 
Join Date: Jul 2003
Location: NY
Posts: 251
n2umr is gaining momentum as a positive member of FTE.n2umr is gaining momentum as a positive member of FTE.
Well, it wasn't the battery. It did the same thing with a new battery. I called the dealer and they seem to think it is the anti theft system. Had it towed to the dealer last night, should have some results sometime this afternoon.

Mark
Reply With Quote
  #6 (permalink)  
Old 06-23-2009, 08:48 AM
Gucci_130 Gucci_130 is offline
New User
 
Join Date: Jun 2009
Location: TX
Posts: 3
Gucci_130 is starting off with a positive reputation.
Ive seen vehicles come into my dealer that have been struck by lightning with the same symptoms, also reversing the leads when you go to jump start the truck can unleash the devil into all the modules..
Reply With Quote
  #7 (permalink)  
Old 06-23-2009, 09:44 AM
gddyup's Avatar
gddyup gddyup is offline
Senior User
 
Join Date: Nov 2004
Posts: 340
gddyup is gaining momentum as a positive member of FTE.gddyup is gaining momentum as a positive member of FTE.
I've seen some weird stuff like that and most often times, like Tylus mentioned, it's just a bad cell in the battery or a wiped battery that causes some crazy conditions.

I'm curious to see what it is. Let us know once you get an answer back from the dealer.
Reply With Quote
  #8 (permalink)  
Old 06-23-2009, 10:59 AM
n2umr n2umr is offline
Senior User
 
Join Date: Jul 2003
Location: NY
Posts: 251
n2umr is gaining momentum as a positive member of FTE.n2umr is gaining momentum as a positive member of FTE.
The verdict is in. I got a call from the dealer concerning the issue, they said someone ran some wires on the passenger side through the rubber door grommet, where the wires run for the speakers and power windows, into the kick panel. Water is running down those wires and into a fuse box, plus my floor was soaking wet they said. I told them I may know who ran those wires! boy do I feel like an ***. The wires were for my amateur radio, antenna and power. I never sealed the hole I made, this might cost me, although they said they are going to try and get it covered under warranty, good luck I said.

Definitely a lesson learned! Thanks for everyone's help!

Mark
Reply With Quote
  #9 (permalink)  
Old 06-23-2009, 11:24 AM
Tylus's Avatar
Tylus Tylus is online now
MMNC (SS)
 
Join Date: Mar 2004
Location: Pearl Harbor
Posts: 10,510
Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.
ouch...too bad it wasn't the battery
__________________
2002 Excursion XLT w/ V-10 <---Build thread
2015 Chevrolet Tahoe - I've owned 4 brand new Fords since 2006. Notice that I bought a Chevy this time. That should tell you something
Reply With Quote
  #10 (permalink)  
Old 06-23-2009, 12:26 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Amateur installers! JK, hope it all works out.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #11 (permalink)  
Old 06-23-2009, 02:09 PM
function12's Avatar
function12 function12 is offline
Senior User
 
Join Date: Jan 2002
Location: houston
Posts: 496
function12 is starting off with a positive reputation.
Quote:
Originally Posted by n2umr View Post
although they said they are going to try and get it covered under warranty, good luck I said.

That is the dealer's way of saying we are going to fix it now and when you come in, tell you how hard they are going to break off in you.
__________________
See ya,
Eric
Reply With Quote
  #12 (permalink)  
Old 06-24-2009, 10:41 AM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Yeah, did they fix it for free?
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #13 (permalink)  
Old 06-24-2009, 01:37 PM
n2umr n2umr is offline
Senior User
 
Join Date: Jul 2003
Location: NY
Posts: 251
n2umr is gaining momentum as a positive member of FTE.n2umr is gaining momentum as a positive member of FTE.
They did fix it under warranty so no cost to me, YEAH! However, the service manager did notice that I haven't had any service performed at the dealer, hint hint. Guess I better schedule something and make up for the "favor" the did for me. Thanks for everyone who tried to help me with this situation.

Mark
Reply With Quote
  #14 (permalink)  
Old 06-24-2009, 01:44 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Yeah, they are like that. That was nice though as they were not obligated to fix it. Now time for the $45 oil change......
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #15 (permalink)  
Old 06-24-2009, 06:19 PM
bamp's Avatar
bamp bamp is offline
Freshman User
 
Join Date: Jun 2009
Location: Arkansas
Posts: 37
bamp is starting off with a positive reputation.
Actually around here, central Arkansas, the dealer is as cheap or cheaper than most service places. I prefer to get mine done @ the dealer for warranty purposes.
Reply With Quote
Old 06-24-2009, 06:19 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
2008, battery, dead, expedition, ford, symptoms

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 01:12 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup