Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-17-2009, 02:09 PM
clearnetedm clearnetedm is offline
Junior User
 
Join Date: Jan 2009
Location: Alberta
Posts: 66
clearnetedm is starting off with a positive reputation.
Strange Temp Settings

Anyone else notice the temp settings for the AC goes up and down in .5 increments. However when it gets down to 19.0C its next setting is 16.0C. I didn't think much of it earlier when it was cooler but now its a pain. 19 can be too warn and 16 too cold. Is this something on all the trucks, or something I need fixed?

BTW I have an 08 EXPY MAX(EL) Limited.
Reply With Quote
  #2  
Old 06-17-2009, 02:50 PM
mpm32 mpm32 is offline
New User
 
Join Date: Jan 2009
Posts: 6
mpm32 is starting off with a positive reputation.
C? what's that, Canadian temperature?

Seriously,

Mine goes from 65F to 60F so it looks like the same jump in fahrenheit as Celsius.
Reply With Quote
  #3  
Old 06-17-2009, 06:10 PM
clearnetedm clearnetedm is offline
Junior User
 
Join Date: Jan 2009
Location: Alberta
Posts: 66
clearnetedm is starting off with a positive reputation.
Wierd, so same problem, rather design, as mine. I wonder what the thinking behind that is.
Reply With Quote
Old 06-17-2009, 06:10 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What water temp and oil temp is too hot? SultanGris 6.7L Power Stroke Diesel 8 03-02-2014 10:35 AM
'06 F350, Weird Vent Problem-Yes, another one. Osconda Cooling, Heating, Ventilation & A/C 2 09-28-2010 09:28 PM
Gasket set question please ? L0ngJ0hn Y-Block V8 (239, 272, 292, 312, 317, 341, 368) 9 12-30-2006 08:43 AM
A/C on during EATC "auto" mode fordguy61mi 2004 - 2008 F150 5 04-05-2004 08:57 AM
A/C compressor runs constantly txzaphod Aerostar 1 11-10-2003 08:06 AM



All times are GMT -5. The time now is 02:44 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup