Go Back   Ford Truck Enthusiasts Forums > Small Chassis Trucks > Explorer, Sport Trac, Mountaineer & Aviator
Sign in using an external account
Register Forgot Password?


Explorer, Sport Trac, Mountaineer & Aviator 1991-1994, 1995-2001, 2002-2005, 2006-2010 Ford Explorer

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-16-2009, 03:35 PM
kostyan44 kostyan44 is offline
New User
 
Join Date: Jun 2009
Posts: 4
kostyan44 is starting off with a positive reputation.
Beeping sound in first couple minutes of driving

Hi All,

I own a 2003 Ford Explorer XLS V6 RWD. I have this issue going on which I cannot figure out how to fix:

Right after I start driving there are several (I think 3) short beeps - they come in sets - 2 or 3 sets within one minute and then the beeping stops and does not come back until next time I start driving (start the engine and go).

It's kind of weird - I checked all seat belts and door locks - looks like all that is in check. Any ideas on what this may be? Click the image to open in full size.

Alternatively - where is that little beeper \ speaker located? Is it to the right of the steering wheel?

Thank you all so much for your help. Click the image to open in full size.

KK
Reply With Quote
  #2  
Old 06-16-2009, 05:10 PM
ncranchero's Avatar
ncranchero ncranchero is offline
Postmaster
 
Join Date: May 2003
Location: E.Lincoln County, NC
Posts: 2,775
ncranchero has a good reputation on FTE.ncranchero has a good reputation on FTE.
steve.mckellop
Your air bag indicator lamp is burned out. Once you replace the bulb you will find there is some other issue with the SRS. Count the air bag indicator flashes and post here for help.
__________________
Steve,
'94 F150 4x4 4.9L/5-speed/3.55(H9) 166K miles
'00 Taurus SES DOHC 87K miles
'02 Escape XLT 3.0/auto 165K miles
'14 TRANSIT Connect
Reply With Quote
  #3  
Old 06-16-2009, 05:32 PM
kostyan44 kostyan44 is offline
New User
 
Join Date: Jun 2009
Posts: 4
kostyan44 is starting off with a positive reputation.
Thanks for your reply ncranchero! I will check that out.

However - when I turn the ignition key once all the light bulbs come on and the Air Bag light is coming up as well. Am I talking about a wrong light?

KK
Reply With Quote
  #4  
Old 06-16-2009, 05:40 PM
kostyan44 kostyan44 is offline
New User
 
Join Date: Jun 2009
Posts: 4
kostyan44 is starting off with a positive reputation.
One more question - where is that beeping speaker located (the one that actualy makes the sound) - is it to the right of the steering wheel, right under the dashboard where the small grill (speaker grill??) is?

Once again - much appreciated.

KK
Reply With Quote
  #5  
Old 06-16-2009, 05:44 PM
ncranchero's Avatar
ncranchero ncranchero is offline
Postmaster
 
Join Date: May 2003
Location: E.Lincoln County, NC
Posts: 2,775
ncranchero has a good reputation on FTE.ncranchero has a good reputation on FTE.
steve.mckellop
Yes, the air bag light is the one I'm speaking of ...... strange. I'll look into the beeping being the same on the Explorer as on the F150 which I'm much more familiar with. I'm just getting into these Exploders...........
__________________
Steve,
'94 F150 4x4 4.9L/5-speed/3.55(H9) 166K miles
'00 Taurus SES DOHC 87K miles
'02 Escape XLT 3.0/auto 165K miles
'14 TRANSIT Connect
Reply With Quote
  #6  
Old 06-16-2009, 11:35 PM
kostyan44 kostyan44 is offline
New User
 
Join Date: Jun 2009
Posts: 4
kostyan44 is starting off with a positive reputation.
ncranchero - you were absolutely correct. I opened up the dashboard and the Air bag LED was actually physically broken off - who knows how that may have happened??

Anyhow - replaced it with a new 12V Amber LED - and it's working like a charm.

Thanks for your help, man.

KK
Reply With Quote
Old 06-16-2009, 11:35 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Small Chassis Trucks > Explorer, Sport Trac, Mountaineer & Aviator

Tags
1991, 98, air, bag, beep, beeping, board, dash, explorer, f150, ford, makes, making, mustang, sound, srs, start, turned

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 05:05 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup