Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-28-2009, 06:43 AM
pm14612 pm14612 is offline
New User
 
Join Date: Mar 2009
Posts: 1
pm14612 is starting off with a positive reputation.
98 EXPY - oil gauge dead

Hello, new Epy owner. 98 Expedition, 4.6. Oil gauge does not move, ever. No engine noises. Oil level good. Truck runs great. Replaced oil sending unit. Nothing. All other gauges work great. Has anyone experianced this before ? Thanks in advance. Great forum.
Reply With Quote
  #2  
Old 03-28-2009, 11:16 AM
Kelly Aitken Kelly Aitken is offline
Junior User
 
Join Date: Jan 2006
Location: Panama city, Florida
Posts: 50
Kelly Aitken is starting off with a positive reputation.
I had 01 nav. my oil pressure guage would peg out and stay that way. replaced the sending unit and that didn't fix it so the dealer said it was the guage unit. $411. they said the presure was fine. never did fix it.

Kelly
Reply With Quote
  #3  
Old 03-29-2009, 06:01 PM
shorebird's Avatar
shorebird shorebird is offline
Wage Slave
 
Join Date: Feb 2003
Location: Long Beach, Ms.
Posts: 11,528
shorebird has a superb reputationshorebird has a superb reputationshorebird has a superb reputationshorebird has a superb reputationshorebird has a superb reputationshorebird has a superb reputationshorebird has a superb reputationshorebird has a superb reputationshorebird has a superb reputationshorebird has a superb reputationshorebird has a superb reputation
There is no way in wherever that I would pay $411 for a pressure gauge. I would buy an aftermarket gauge and put it in a pod. I also would not operate my ride without any type of pressure monitoring system.
__________________
2001 E-350SD V10 Triton 3.73LS, ROTW 01/02/10
2008 F-150 FX2 Sport 5.4L 3.73LS Scab 145" Wb; '07 Taurus SEL

Bryan L. Unique Collision Center Towing & Wreck Recovery Specialist
“Speed has never killed anyone, suddenly becoming stationary… that’s what gets you.”
Reply With Quote
Old 03-29-2009, 06:01 PM
 
 
 
Reply


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Tags
98, expedition, ford, gauge, lincoln, navigtor, oil, presssure, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 09:47 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup