Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-15-2009, 08:40 AM
thinksnow thinksnow is offline
Senior User
 
Join Date: Sep 2003
Posts: 409
thinksnow is starting off with a positive reputation.
Trans question

I'm aware of the akward shifting issue with these when it doesn't always choose the right gear after slowing to a near stop, it really doesn't bother me. I did notice one thing I found odd. Once it the while as Im slowing down for an off ramp and then onto the ramp the TC will feel like it is staying locked up. You feel the drag of the motor slowing you down. Then it will down shift and continue doing it. It doesn't always do it, only on occassion. This is what my F250 Diesel does when Im in the tow/haul mode. But that truck has the Torque shift trans. Has anyone elso had this happen? Is it normal? If so what engages it? Maybe its a function of the stability control system.
Reply With Quote
  #2  
Old 03-15-2009, 06:56 PM
chuck s chuck s is offline
Elder User
 
Join Date: Jan 2008
Location: Broadview Hts, Ohio
Posts: 512
chuck s is starting off with a positive reputation.
It may be. On long down grades with I'm coming down in 3d or 2d with the trailer behind me the transmission won't up shift all the way up again if it bump it up to Drive. Usually goes up a gear and stays there until I come off the grade or add some throttle.

Not sure if this a bug or a feature, but seems to work well.

-- Chuck
Reply With Quote
Old 03-15-2009, 06:56 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
hi. fordthunder007 New Member Introductions 5 03-13-2014 02:56 PM
2005 Escape Trans Problems, Looking for Advice sirvictory Escape & Escape Hybrid 0 12-09-2012 01:54 AM
Idle speed causing shift problem ceetwarrior 1987 - 1996 F150 & Larger F-Series Trucks 28 01-30-2005 08:45 PM
loud banging noise Schmids4.9l Ford Inline Six, 200, 250, 4.9L / 300 3 11-12-2004 11:12 PM
96 Aerostar 3.0 tranny/TC issue. MrMeister Clutch, Transmission, Differential, Axle & Transfer Case 1 07-03-2003 06:47 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 07:24 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup