Go Back   Ford Truck Enthusiasts Forums > Small Chassis Trucks > Escape & Escape Hybrid
Sign in using an external account
Register Forgot Password?


Escape & Escape Hybrid Ford Escape, Ford Escape Hybrid, Mercury Mariner, Mazda Tribute

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 01-13-2009, 12:54 PM
mtbobcat mtbobcat is offline
New User
 
Join Date: Jun 2006
Posts: 6
mtbobcat is starting off with a positive reputation.
05 - Escape 3.0 Trouble Code P0354 @#$%

I have an 05 Escape 3.0, purchased new, never had a problem, serviced regularly, 45k miles. I had purchased a Code Scout 2500 by Autoxray code reader last year for another car I had so I used it on my Escape because the engine light came on and was running poorly. It came up with a P0354 Ingition coil D primary/Secondary circuit error. After reading many of the postings on here I determined it was the front left coil pack, cyl 4. I swapped the front 3 coils several times and watched the error follow the cyl 4 coil to P0355 and P0356. I purchased a coil from NAPA and replaced it and the spark plug. It made the engine run better but the code just won't clear. I have even put one of the other good coils back in cyl 4 but makes no difference. It is now running rough, poping back through the air intake and maintains only the one same code. I unplug the wire to the coil and it makes no difference. I have even disconnected the battery and moved the new plug to a different cyl. Any help on this would be appreciated.
Reply With Quote
  #2 (permalink)  
Old 01-15-2009, 02:41 PM
mtbobcat mtbobcat is offline
New User
 
Join Date: Jun 2006
Posts: 6
mtbobcat is starting off with a positive reputation.
Guess my problem description was a little long for most to read or care. I still have an ignition issue. I can pull the coil wire off of number 4 (D) and no change. Still poping out intake. Does anyone know where the
PCM is located on the 05 Escape or what else might be upstream from the plug and coil that would have this effect?
Reply With Quote
  #3 (permalink)  
Old 01-15-2009, 10:07 PM
wptski wptski is offline
Posting Guru
 
Join Date: Feb 2002
Location: Warren, MI
Posts: 1,323
wptski is starting off with a positive reputation.
Quote:
Originally Posted by mtbobcat View Post
Guess my problem description was a little long for most to read or care. I still have an ignition issue. I can pull the coil wire off of number 4 (D) and no change. Still poping out intake. Does anyone know where the
PCM is located on the 05 Escape or what else might be upstream from the plug and coil that would have this effect?
Sounds like you have a problem in the primary coil curcuit, either it's in the harness or the PCM itself is bad.
__________________
Bill

09 Ford Escape Limited, 3.0L, 4WD
Reply With Quote
  #4 (permalink)  
Old 01-16-2009, 01:59 PM
ericsmith32 ericsmith32 is offline
Elder User
 
Join Date: Feb 2005
Location: Kansas City, KS
Posts: 549
ericsmith32 is gaining momentum as a positive member of FTE.
Sorry but don't much about the codes.. but is the coil you got Motorcraft? I've heard of others having problems with aftermarket coils. Just not on Escapes but other Fords also.
__________________
04 Escape XLT Sport 3.0L
06 Ranger XL 2.3L
The best never rest.. Built Ford Tough
Reply With Quote
  #5 (permalink)  
Old 05-03-2009, 10:08 AM
charder charder is offline
New User
 
Join Date: Jul 2004
Posts: 14
charder is starting off with a positive reputation.
My 05 is in for the same issues now. My mechanic tells me that there is a serv. bul. out regarding this issue. There are plugs initially installed that have (or either build up) excessive resistance and that works problems back to the coils and control module. My Escape just died out on the expressway as I gave it a tap on the accelerator- I thought I blew a belt. It started up rough and I was able to limp to work. Coded it out and coils a-f were coming up bad. Cleared that out and just the d coil continues to come up. Took it to my neighbor's shop and its in for a while. He changed the plugs to no avail, and a couple of coils with the same result. He tells me I could be in for a $1k bill if it goes all the way back to the control module. Gotta have it so I gotta do it.
Any chance Ford will help out here? Stop that giggling!
Reply With Quote
Old 05-03-2009, 10:08 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Small Chassis Trucks > Escape & Escape Hybrid

Tags
05, 2004, 2005, 30l, code, coil, edge, error, escape, ford, ignition, intake, p0354, p0356, taurusp0354

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 06:44 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup