Go Back   Ford Truck Enthusiasts Forums > Regional Chapters > Southern Region > Georgia Chapter
Sign in using an external account
Register Forgot Password?


Georgia Chapter Join Chapter, Leader: ChiefM SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 10-26-2008, 01:19 PM
Customlover's Avatar
Customlover Customlover is offline
Junior User
 
Join Date: Mar 2008
Location: Thomasville, Georgia
Posts: 88
Customlover is starting off with a positive reputation.
Anyone near Thomasville

I am lost on my taillight issue guys is there anyone near thomasville that might be able to give me a hand or some pointers. I just don't know what to do anymore. My break lights work as do both turn signals but my tail lights will not come on and neither will my reverse lights. I have tested bulbs, housings, and everything else...I am lost and have no clue where else to look. I cant drive my truck at night until I get this fixed. Any help is appreciated. Swamp thing is sitting up missing out on the night life and need to get him back out there as soon as possible. Thanks.
Reply With Quote
  #2 (permalink)  
Old 10-28-2008, 03:32 PM
harleyga harleyga is offline
Junior User
 
Join Date: Oct 2008
Location: Cartersville,GA
Posts: 57
harleyga is starting off with a positive reputation.
Hey man, did you get this fixed, I am lost too when it comes to the electrical part, The only thing I could tell you is just try to trace the wires back as far as you can also you can get wiring diagrams on the internet. Good Luck, Try these:

Online Ford Mechanics Answer Service & Repair Questions on Explorer, Taurus, 500, Aerostar, Bronco, Escort, Expedition, F150, Focus, Fusion, Mustang, Thunderbird, Windstar & Fiesta - Just Answer!

ALLDATAdiy.com :: Leading Source of Diagnostic and Repair Information

Automotive Wiring Diagrams
Reply With Quote
  #3 (permalink)  
Old 10-28-2008, 06:00 PM
Customlover's Avatar
Customlover Customlover is offline
Junior User
 
Join Date: Mar 2008
Location: Thomasville, Georgia
Posts: 88
Customlover is starting off with a positive reputation.
Quote:
Originally Posted by harleyga View Post
Hey man, did you get this fixed, I am lost too when it comes to the electrical part, The only thing I could tell you is just try to trace the wires back as far as you can also you can get wiring diagrams on the internet. Good Luck, Try these:

Online Ford Mechanics Answer Service & Repair Questions on Explorer, Taurus, 500, Aerostar, Bronco, Escort, Expedition, F150, Focus, Fusion, Mustang, Thunderbird, Windstar & Fiesta - Just Answer!

ALLDATAdiy.com :: Leading Source of Diagnostic and Repair Information

Automotive Wiring Diagrams
Thanks for those and no I still haven't solved this issue. I am taking it to a friend this weekend who has knowledge of this stuff. So hopefully we will get to the bottom of this. Thanks again
Reply With Quote
  #4 (permalink)  
Old 10-28-2008, 06:36 PM
harleyga harleyga is offline
Junior User
 
Join Date: Oct 2008
Location: Cartersville,GA
Posts: 57
harleyga is starting off with a positive reputation.
You're welcome, Good luck! Let us know what was wrong.
Reply With Quote
  #5 (permalink)  
Old 10-28-2008, 07:28 PM
Customlover's Avatar
Customlover Customlover is offline
Junior User
 
Join Date: Mar 2008
Location: Thomasville, Georgia
Posts: 88
Customlover is starting off with a positive reputation.
I will lol. Hopefully between me and my buddy we should figure it out. You know what I just remembered though? The Neutral safety switch broke off the other day and I don't know if that has anything to do with it or not though? Anyone know? I wouldn't think this would affect my tail lights but like i said wiring is not my forte. Either way I will report back Saturday with my findings.
Reply With Quote
  #6 (permalink)  
Old 10-29-2008, 04:39 PM
3broncocrazy's Avatar
3broncocrazy 3broncocrazy is offline
Postmaster
 
Join Date: May 2003
Location: South Ga
Posts: 4,933
3broncocrazy has a great reputation on FTE.3broncocrazy has a great reputation on FTE.3broncocrazy has a great reputation on FTE.3broncocrazy has a great reputation on FTE.3broncocrazy has a great reputation on FTE.
Quote:
Originally Posted by Customlover View Post
Thanks for those and no I still haven't solved this issue. I am taking it to a friend this weekend who has knowledge of this stuff. So hopefully we will get to the bottom of this. Thanks again
It's better with two working on a wiring problem......as long as not tooooooo much

Good luck and let us know what the problem was....
__________________
Donnie
79,79,89,96 Broncos Baby
Did you ever notice: When you put the 2 words "The" and "I R S" together it spells "THEIRS?"
IT'S BETTER TOPLESS(Broads, Broncos, and Booze)

Quote:
Originally Posted by evilbeast
you people scare me sometimes!!
"...sailors who drank beer escaped the curse of scurvy..."
Reply With Quote
  #7 (permalink)  
Old 10-30-2008, 01:04 PM
durk's Avatar
durk durk is offline
Senior User
 
Join Date: Nov 2003
Posts: 196
durk is starting off with a positive reputation.
try the switch in the column. My 69 had one go bad and I had the same symptoms
Reply With Quote
Old 10-30-2008, 01:04 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Regional Chapters > Southern Region > Georgia Chapter

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 02:44 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup