Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 10-01-2008, 09:20 AM
Jay Jay is offline
Junior User
 
Join Date: Sep 1999
Posts: 99
Jay is starting off with a positive reputation.
Bad coil

07 expy EL EB 4x4 - 35000 miles - started noticing an intermittent miss at stop lights and at highway speeds sometimes. Took it to dealer and they found the coil on the#4 cylinder was going bad. Replaced and seems fine now. SM said that this is a common problem and warranty has been extended.
Any one else experienced this problem?
Reply With Quote
  #2 (permalink)  
Old 10-01-2008, 10:34 AM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Very nice to get an extended warranty. Does the 07 have the 5yr/60,000 mile powertrain warranty? If so, would a coil fall into this?
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #3 (permalink)  
Old 02-19-2009, 11:43 PM
2001gocougs 2001gocougs is offline
Senior User
 
Join Date: Sep 2004
Posts: 130
2001gocougs is starting off with a positive reputation.
I have experienced it on the 4.6L in a 1998 F150. I had 126,000 on it at that point. I replaced my coil pack with two aftermarket units and then I just went with the motorcraft unit and that solved the problem.
__________________
2008 Escape XLT 3.0L V6/AWD 66,000 miles
2007 Expedition XLT 5.4L/4x4 68,000 miles
2001 Focus SE Sedan 2.0L Zetec/MT 124,000 miles (sold)
1998 F150 SC 4x4 4.6L/Auto XLT 139,000 (sold)
Reply With Quote
Old 02-19-2009, 11:43 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
2007, 2008, bad, coil, coils, expedition, f250, ford, item, navigator, pack, power, symptoms, train, warranty

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 11:53 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup