Is your Expy missing this? - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Is your Expy missing this?

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-30-2008, 12:42 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
Thread Starter
 
Join Date: Mar 2001
Posts: 4,132
berry1234 is gaining momentum as a positive member of FTE.
Is your Expy missing this?



This is on the drivers door b pillar. The rubber piece is missing. This happened on my 07 and I have seen other Expys missing this piece. Anyone else have this problem?
Reply With Quote
  #2  
Old 10-01-2008, 08:33 AM
myexpo02's Avatar
myexpo02 myexpo02 is offline
Senior User
 
Join Date: Feb 2006
Location: Purcell,OK
Posts: 171
myexpo02 is starting off with a positive reputation.
I will check it out tonight...when I get home.
Reply With Quote
  #3  
Old 10-02-2008, 01:13 PM
ronjeremy6's Avatar
ronjeremy6 ronjeremy6 is offline
Senior User
 
Join Date: Mar 2008
Posts: 281
ronjeremy6 is starting off with a positive reputation.
funny you post this up. i've had wind noise around my driver door since i've owned the truck (feb 08, 2005 EB). the dealer and my body guy both kept it for a day each and couldn't find where the wind was entering.

well, i took matters into my own hands and found the piece you are referring to imbedded down inside the black piece of trim. so, i dug it out, filled the void with black RTV, reinserted the piece or black ABS, and let it dry. i barely have any wind noise now.

check to see if your little piece of ABS simply fell down into the trim.
Reply With Quote
  #4  
Old 10-02-2008, 01:25 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
Thread Starter
 
Join Date: Mar 2001
Posts: 4,132
berry1234 is gaining momentum as a positive member of FTE.
Yep, mine fell into the trim. Dealer pulled it out, put some silicone, and Im good to go.
Reply With Quote
  #5  
Old 10-03-2008, 03:06 PM
cjgeorge32 cjgeorge32 is offline
Junior User
 
Join Date: Sep 2007
Posts: 71
cjgeorge32 is starting off with a positive reputation.
I learned about this missing part when the guy that washes my car cut his hand on the edge of the molding. What is black RTV?
Reply With Quote
  #6  
Old 10-03-2008, 03:47 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
Thread Starter
 
Join Date: Mar 2001
Posts: 4,132
berry1234 is gaining momentum as a positive member of FTE.
It's black silicone. RTV stands for Room Temperature Vulcanized. He used that because the piece was missing. My dealer used clear silicone and it looks fine.
Reply With Quote
  #7  
Old 10-03-2008, 05:40 PM
cjgeorge32 cjgeorge32 is offline
Junior User
 
Join Date: Sep 2007
Posts: 71
cjgeorge32 is starting off with a positive reputation.
Dumb question.....Silicone Sticks???
Reply With Quote
  #8  
Old 10-03-2008, 05:43 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
Thread Starter
 
Join Date: Mar 2001
Posts: 4,132
berry1234 is gaining momentum as a positive member of FTE.
Yeah, silicone will stick.
Reply With Quote
  #9  
Old 10-03-2008, 07:32 PM
chuck s chuck s is offline
Elder User
 
Join Date: Jan 2008
Location: Broadview Hts, Ohio
Posts: 512
chuck s is starting off with a positive reputation.
Mine's missing too. Jan '07 production.

-- Chucj
Reply With Quote
  #10  
Old 10-04-2008, 10:23 PM
rjd75 rjd75 is offline
Senior User
 
Join Date: Jan 2005
Posts: 151
rjd75 is new and has a neutral reputation at this point.
Berry, how do you come up with this stuff?? Hah.. You are the man when it comes to noticing flaws in the Expedition! I just checked both my driver and passenger doors and both have the piece pushed into the trim. The whole design looks like an after thought.. This is definitely the kind of thing that separates the japs and the germans from ford, poor fit and finish. I will be mentioning it to the dealer at my next oil change as I am definitely not going to spend my own time and money trying to seal those holes.

Don't get me wrong I love my truck, but petty little things like this **** me off.. They just should not happen!
Reply With Quote
  #11  
Old 10-06-2008, 08:48 AM
myexpo02's Avatar
myexpo02 myexpo02 is offline
Senior User
 
Join Date: Feb 2006
Location: Purcell,OK
Posts: 171
myexpo02 is starting off with a positive reputation.
Had the same problem...used some Clear RTV and fixed them...but it's not a great fit on the piece to begin with.
Reply With Quote
  #12  
Old 10-06-2008, 12:07 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
Thread Starter
 
Join Date: Mar 2001
Posts: 4,132
berry1234 is gaining momentum as a positive member of FTE.
Yeah, the rubber piece is way to small to fill that void.

I don't know how I find these things. I guess it's my OCD!
Reply With Quote
  #13  
Old 10-06-2008, 07:34 PM
IQ9 IQ9 is offline
Senior User
 
Join Date: Sep 2007
Posts: 351
IQ9 is starting off with a positive reputation.
More to check on...seems all I do with this thing.
Reply With Quote
  #14  
Old 10-07-2008, 05:37 PM
ronjeremy6's Avatar
ronjeremy6 ronjeremy6 is offline
Senior User
 
Join Date: Mar 2008
Posts: 281
ronjeremy6 is starting off with a positive reputation.
Quote:
Originally Posted by berry1234 View Post
It's black silicone. RTV stands for Room Temperature Vulcanized. He used that because the piece was missing. My dealer used clear silicone and it looks fine.
actually, i used black because the trip piece and the plastic tab were black.
Reply With Quote
  #15  
Old 10-08-2008, 10:36 AM
SemperFiDevilDog SemperFiDevilDog is offline
Senior User
 
Join Date: Feb 2008
Posts: 100
SemperFiDevilDog is starting off with a positive reputation.
Must check...looking
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Dumb ac question phillips91 Expedition & Navigator 2 04-29-2016 04:20 PM
98 Expy missing when cold, runs great when warm??? Firefighter 1406 Expedition & Navigator 15 12-28-2014 09:56 PM
03 expy nav system in a 03 expy swap ZEPHYRMIKE Expedition & Navigator 1 05-22-2014 03:44 PM
1997 Expy Center Console Removal luverofpeanuts Expedition & Navigator 8 09-28-2008 02:10 AM
Dana 60 Locking Hub 1ford1 1973 - 1979 F-100 & Larger F-Series Trucks 32 03-25-2008 08:34 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
2007, expedition, ford, missing

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 07:47 AM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.