Loud Ticking from engine... - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Loud Ticking from engine...

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-25-2008, 12:58 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
Thread Starter
 
Join Date: Mar 2001
Posts: 4,132
berry1234 is gaining momentum as a positive member of FTE.
Loud Ticking from engine...

Well my 08 with 7,500 miles is at the dealer. I started it this weekend and noticed a loud ticking coming from the engine. It varies with motor rpm. Sounds like a lifter banging. Very loud you can hear it half block away. Never got any check engine light or anything. Any ideas what could make that noise?
Reply With Quote
  #2  
Old 08-25-2008, 04:19 PM
nfntruth nfntruth is offline
Senior User
 
Join Date: Apr 2003
Location: Charleston
Posts: 201
nfntruth is starting off with a positive reputation.
Mine makes that noise as well, I just assumed it was a belt loose. Mine goes in for service next week, I have about 8K miles.
Reply With Quote
  #3  
Old 08-25-2008, 07:25 PM
IQ9 IQ9 is offline
Senior User
 
Join Date: Sep 2007
Posts: 351
IQ9 is starting off with a positive reputation.
I hope you don't hear the" Oh, thats normal...nothing wrong that the tech can find" or "Tech says they can't seem to get it to do what you are saying BUT we did note it in your file."
Reply With Quote
  #4  
Old 08-25-2008, 07:31 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
Thread Starter
 
Join Date: Mar 2001
Posts: 4,132
berry1234 is gaining momentum as a positive member of FTE.
Quote:
Originally Posted by IQ9 View Post
I hope you don't hear the" Oh, thats normal...nothing wrong that the tech can find" or "Tech says they can't seem to get it to do what you are saying BUT we did note it in your file."
No, they called. Something about variable valves acting as though there is no oil. They will know more tomorrow.
Reply With Quote
  #5  
Old 08-28-2008, 07:08 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
Thread Starter
 
Join Date: Mar 2001
Posts: 4,132
berry1234 is gaining momentum as a positive member of FTE.
Update. They are replacing the heads on the driver side of the engine. Not sure exactly happened, but I think the dealer just keeps replacing parts until things are fixed. Seems unusual for the valves to go bad in 7500 miles, but I know random things happen.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Please Help!! 2008 f150 5.4 ticking Problem. TrukProblemz 2004 - 2008 F150 5 02-10-2014 03:51 PM
Engine ticking under load rollin35s 2004 - 2008 F150 3 07-01-2011 06:29 AM
Ticking Noise. '98 5.4 164k Fox Fader 1997 - 2003 F150 9 02-02-2011 09:58 PM
429 Loud Ticking gkram Big Block V8 - 385 Series (6.1/370, 7.0/429, 7.5/460) 4 11-11-2010 05:15 PM
Ticking in a 99 F150 5.4 greese_munkey 1997 - 2003 F150 12 03-10-2006 08:02 AM


Go Back   Ford Truck Enthusiasts Forums >

Tags
2007, engin, expedition, lincoln, loud, navigator, ticking

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 07:12 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.