Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 08-22-2008, 12:15 AM
threefiftyone's Avatar
threefiftyone threefiftyone is offline
Elder User
 
Join Date: Feb 2004
Location: Oregon
Posts: 500
threefiftyone is starting off with a positive reputation.
fast turn signal

What might be the cause of a faster than normal turn signal? Our right signal is going super fast, otherwise everything ok.
__________________
1986 F350 CC 4x4 6.9 NA IDI 3.54s T19 33's straight piped and oh so loud! . 2007 EB Expedition 4x4 6SPD. 1992 Bronco Nite
Reply With Quote
  #2 (permalink)  
Old 08-22-2008, 10:38 AM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
The relay has gone bad. They are not expensive. I am not sure where they are located, look in the manual.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #3 (permalink)  
Old 08-22-2008, 01:47 PM
cfranc cfranc is offline
New User
 
Join Date: Jan 2008
Posts: 16
cfranc is starting off with a positive reputation.
I had the same problem and it turned out I had a bulb that had burned out. You may want to check that as well.
Reply With Quote
  #4 (permalink)  
Old 08-22-2008, 01:59 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
I should have put that first. Burned bulbs will cause this too, as cfranc said. If the bulbs are good, look at the relay.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #5 (permalink)  
Old 08-23-2008, 12:50 AM
threefiftyone's Avatar
threefiftyone threefiftyone is offline
Elder User
 
Join Date: Feb 2004
Location: Oregon
Posts: 500
threefiftyone is starting off with a positive reputation.
YAR! After I posted, the dealer said when the blinker blinks fast, it designates an incomplete circuit, therefore a bad bulb.
__________________
1986 F350 CC 4x4 6.9 NA IDI 3.54s T19 33's straight piped and oh so loud! . 2007 EB Expedition 4x4 6SPD. 1992 Bronco Nite
Reply With Quote
Old 08-23-2008, 12:50 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 11:35 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup