Big Thank you to the Forum users - Ford Truck Enthusiasts Forums

2004 - 2008 F150 2004, 2005, 2006, 2007 and 2008 Ford F150's with 5.4 V8, 4.6 V8 engine

Big Thank you to the Forum users

LinkBack Thread Tools Search this Thread
Old 05-11-2008, 06:15 PM
Twinsdad98 Twinsdad98 is offline
Elder User
Thread Starter
Join Date: Dec 2007
Location: Michigan
Posts: 680
Twinsdad98 is starting off with a positive reputation.
Big Thank you to the Forum users

OK, so my airbag light came on the other day. Having seen the other posts about the front sensor, that was the first placed I check. Sure enough, the pins were corroded. Disconnected the neg terminal, cleaned the contacts, put some good dielectric grease on them and 10 minutes later, good as new! Thanks for all the great help and way too many mod ideas...
Reply With Quote
Old 05-11-2008, 08:06 PM
Dustin1690 Dustin1690 is offline
Post Fiend
Join Date: Apr 2006
Location: Saskatoon Saskatchewan
Posts: 12,281
Dustin1690 is gaining momentum as a positive member of FTE.Dustin1690 is gaining momentum as a positive member of FTE.
Good to hear you got your problem fixed yeah this site is great for stuff like that
Reply With Quote

Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

All times are GMT -5. The time now is 10:43 AM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.