Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-23-2008, 05:34 PM
D-Rock D-Rock is offline
Freshman User
 
Join Date: Feb 2004
Posts: 44
D-Rock is starting off with a positive reputation.
Power Windows Slow plus...

Hey all - '07 Expy...still low miles (6k)...traded up from an '01 Mountaineer and I love it...used to frequent the Exploder forums here.

That said, a few minor things that I have noticed outside of aleady existing topics here and I'm looking for input or experiences. (it should be noted, that I am taking it in for a bunch of this stuff, so I'll update as I get more info)

When I roll up more than one window at at time, the speed of of roll up becomes ridiculous - like 15-20 seconds. This is with the engine running, while driving, with engine off....doesn't matter. Very slow if you pull more than on switch. Odd.

Rear glass closes very hard...check for missing rubber stops, but everything appears to be in place. Anyone else seen this?

Also need the tranny reflash, which they will do, so not much more that what has been said.

Any thoughts?
Reply With Quote
  #2  
Old 03-24-2008, 11:34 AM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
When I roll up more than one it gets slower, I have not timed it, but I will. I took mine back for the rear glass requiring too much pressure to shut, they said they adjusted something, but it's the same.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #3  
Old 03-24-2008, 04:56 PM
Newton007's Avatar
Newton007 Newton007 is offline
Senior User
 
Join Date: Jul 2007
Posts: 222
Newton007 is starting off with a positive reputation.
I never noticed the window speed. You will have to take it in to have the door handles fixed on warranty (recall). As far as the transmission reflash goes, good luck, see the transmission problems thread.
The transmission is a weak point and seems to problem prone.
At least the 07 engine and drive train (except transmission) brakes, steering and all seems to be working OK at 5600 miles.
No rattles, shakes or other wind noise. (yet)
The passenger door Expedition badge is falling off.
I had to paint the guage red indicators white, so I can see them in the day.
The front licence plate bracket will fall off unless you use some big long sheet metal screws to hold it on with.
The heating and cooling controls work, but have a mind of their own at times and will turn on the AC compressor in very cold weather if you don't watch it real close.

All and all I would say that my EB 4X4 07 is "OK" but that's about it.
A few good points: Great sound system.
A lot of power.
Would I buy another one?
Don't know.
I would read all these posts to get an idea what to look out for and there are some good people here that can help on those difficult problems. Everyone here has really helped me out a lot already.
Reply With Quote
  #4  
Old 03-24-2008, 06:07 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Measured the window speed. All idleing with A/C on. One front window. 4 seconds to close from full open. Two windows-5 seconds. 4 windows, 5 seconds.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #5  
Old 03-24-2008, 06:11 PM
PMarch PMarch is offline
Freshman User
 
Join Date: Nov 2007
Posts: 47
PMarch is starting off with a positive reputation.
I had the same problem on my car, not my truck. But a few weeks later, the battery died.
I was at the dealer when it died and I asked them about the windows. They said. It is the first sign that your battery is getting weak.

Hope this helps

Cheers

Paul
Reply With Quote
  #6  
Old 03-24-2008, 07:48 PM
Baumbach Baumbach is offline
Junior User
 
Join Date: Jul 2007
Posts: 82
Baumbach is starting off with a positive reputation.
Try it with the engine off, roll all windows up and down a few times and they will come to a stop, they work much better with the engine on, but I still had my back left windows so darn slow, the dealer replaced it under warranty


Quote:
Originally Posted by berry1234
Measured the window speed. All idleing with A/C on. One front window. 4 seconds to close from full open. Two windows-5 seconds. 4 windows, 5 seconds.
Reply With Quote
  #7  
Old 03-26-2008, 11:57 PM
cjgeorge32 cjgeorge32 is offline
Junior User
 
Join Date: Sep 2007
Posts: 71
cjgeorge32 is starting off with a positive reputation.
Small Problems

I would like to start this new thread by saying I LOVE MY 2007 Expy Limited EL. I am on my 4th Expedition. However my Expy has been in the shop 4 times….I have had it since June 2007 and I have 9,000 miles on it…

Problems:

1. You all know this problem I have in this thread I started a couple of months back..

2007 Chrome Clad Rims...Outraged!!


2. The strut on the motorized liftgate was making a horrible screeching sound going up and down…Problem fixed with a replacement strut.

3. Driver side mirror was very loose….Problem fixed with a replacement mirror.

4. A wind storm was coming through the driver side window at speeds in excess of 40 MPH…..Problem fixed with a replacement of the felt-like molding on the inside of the window.

5. the heated and cooled seats buttons on the AC cluster will not light up and therefore the seat will not heat or cool. The passenger side works fine. …Problem not fixed yet…

6. Also, the leather on the driver seat is wearing much faster than my previous Expy’s.

7. When I put the truck in reverse and I apply the breaks to stop I sometimes hear a “thud” coming from what I think is the rear brakes. I does not do it all the time. The “thud” ranges from very loud, to where I think I have hit something, to very quiet.

My rear windows are also very slow...

I hope this helps some of you with similar issues….

Reply With Quote
  #8  
Old 08-08-2008, 03:39 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Quote:
Originally Posted by D-Rock View Post
Hey all - '07 Expy...still low miles (6k)...traded up from an '01 Mountaineer and I love it...used to frequent the Exploder forums here.

That said, a few minor things that I have noticed outside of aleady existing topics here and I'm looking for input or experiences. (it should be noted, that I am taking it in for a bunch of this stuff, so I'll update as I get more info)

When I roll up more than one window at at time, the speed of of roll up becomes ridiculous - like 15-20 seconds. This is with the engine running, while driving, with engine off....doesn't matter. Very slow if you pull more than on switch. Odd.

Rear glass closes very hard...check for missing rubber stops, but everything appears to be in place. Anyone else seen this?

Also need the tranny reflash, which they will do, so not much more that what has been said.

Any thoughts?

Just took mine in for this on a back window. They replaced the motor and regulator. Now it flies!
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #9  
Old 08-09-2008, 03:39 AM
andry andry is offline
New User
 
Join Date: Aug 2008
Posts: 3
andry is starting off with a positive reputation.
i suspect to the motor.

open 3 or 4 windows (the same time) slower than open 1 window, it is normal....(my car too).
Reply With Quote
Old 08-09-2008, 03:39 AM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Tags
2004, electric, expedition, ford, power, slow, uing, windows

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
87 bigfoot edition ranger parts, decals, etc. sureshot37745 Ranger & B-Series 7 08-22-2010 10:38 PM
Did I get a bad window motor? Dsl Lover Super Duty & Heavy Duty 13 01-19-2010 09:55 AM
Power window fully closes only when stopped spikedog 1997 - 2003 F150 0 05-22-2009 09:25 AM
electric window problems KAS300 Bronco II 5 08-28-2008 08:12 PM
Rear window moving slow wildfowl 1978 - 1996 Big Bronco 7 09-05-2003 05:02 PM



All times are GMT -5. The time now is 02:04 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup