Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator
Sign in using an external account
Register Forgot Password?


Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #211  
Old 09-19-2009, 11:46 PM
Rus Rus is offline
New User
 
Join Date: Jun 2008
Posts: 5
Rus is starting off with a positive reputation.
Quote:
Originally Posted by 79schaefer View Post
1999 4.6 4x4 XLT. 156000. I have had to replace the rear wiper motor once, and it just went bad again. The tranfer case lock up in 4wd once. It was a $10 internal part. I had to replace the radiator due to external damage not of the trucks doing. Replaced the alternator at 153000. Other than that it has been routine maintance. It has been a great truck. I will be painting it shortly becuase we will have it for some time to come.

A buddy of mine had a 1998 5.4 4x4 EB that he traded last year at 388000 miles. He replaced the rear axle twice, and had the tranfer case resealed due to a leak. Other that that it was routine maintance. 75% of the time he had a 20' box trailer attached to it.

Steve S.
To many to list
Not to cut in. I tried a private message but found no option.Do you recall what the $10 part was in the transfer case?
Mine is experiencing same problem. Can it be repaired in vehicle or do I need to pull it out of vehicle.

My 1999 Navigator has 136,758 . Replaced Elbow vacuum, balljoints. Trouble with 4wd at present.
Reply With Quote
  #212  
Old 09-23-2009, 10:57 PM
mjpmn mjpmn is offline
New User
 
Join Date: Mar 2004
Posts: 15
mjpmn is starting off with a positive reputation.
2003 Expy EB 91000 miles Bought a little over 2 years ago. I had a spark plug blow out of the engine. $4500. Drivers side window broke. $400 Fuel pump loosing pressure. New fuel pump $500. Auto seat, mirror memory module bad. $500. I bought an exended warranty for 1600 and it covered all the above repairs. I just had to spend $500 for a front air bag sensor module that went bad. Ford didn't coat the sensor wiring with electric grease to prevent corrosion. After all the money spent, I still luv my EXPY.

Mike
Reply With Quote
  #213  
Old 09-23-2009, 11:07 PM
alloro alloro is offline
Post Fiend
 
Join Date: Apr 2008
Location: 0,0,1
Posts: 9,586
alloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to all
Quote:
Originally Posted by mjpmn View Post
2003 Expy EB 91000 miles

I had a spark plug blow out of the engine. $4500.
Say what? First off, 2001 was the last year for spark plug blow outs. Starting in 2002, more threads were added to the plug holes to prevent this from happening. Second, no one would ever pay $4,500 to have a spark plug hole repaired...you can change the entire engine for that kind of money.

Count your blessing that you have a warranty to cover the costs, but once it runs out, you'll also want to run out...of that repair shop that is.
__________________
To thank someone, click the left red "Add to Reputation" button
right of the word "permalink" top right of the poster's message.
Reply With Quote
  #214  
Old 09-24-2009, 09:27 AM
mikecox1 mikecox1 is offline
Senior User
 
Join Date: Mar 2004
Posts: 125
mikecox1 is starting off with a positive reputation.
2000 5.4 2X4 EB Exp, 198,000 miles, replaced plugs and COP's once (about 50,000 miles ago), replaced alternator once, rear axle seals once (last week), going to replace the pinion seal this weekend (should have replaced it last weekend when I did the axle seals), upper and lower ball joints and tie rod ends at 110,000 miles (went with greasable Moogs and don't expect to have to do that job ever again). No motor or transmission work needed other than fluid and filter changes. I am very hard on vehicles and my Exp has held up better than I could have ever hoped for. I have loved this truck and it has been the best vehicle, bar none, that I have ever owned.
Reply With Quote
  #215  
Old 10-08-2009, 08:35 PM
operator414 operator414 is offline
Senior User
 
Join Date: Jan 2008
Location: Greenwood Indiana
Posts: 154
operator414 is starting off with a positive reputation.
154,980 origanal everything, change oil every 3000k and service tranny at 30000k miles
__________________

1999 Eddie Bauer Expedition
aka "the hog"

White and Tan

Tan leather

134,000 and still counting!

Reply With Quote
  #216  
Old 10-14-2009, 12:57 AM
dirtmonkey11's Avatar
dirtmonkey11 dirtmonkey11 is offline
Senior User
 
Join Date: Sep 2009
Posts: 264
dirtmonkey11 is starting off with a positive reputation.
2000 5.4 XLT with 85,000 miles, no major problems at all, just regual maintenance.
Reply With Quote
  #217  
Old 10-14-2009, 01:07 AM
AlaskanEx's Avatar
AlaskanEx AlaskanEx is offline
Post Fiend
 
Join Date: Apr 2009
Location: Anchorage Alaska
Posts: 9,579
AlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputation
'98 expy xlt 4x4 5.4. with 62,xxx miles on her as of today. few minor issues i wanna fix otherwise mint.
__________________
Russ-
2011 F-150 Limited #3679 6.2 V8 4x4, Retrax bed cover, Husky mud flaps and wheel liners, HIDs, 35% tint
2002 Excursion Limited V10 4x4, 2.5/2" lift, HIDs,LEDs,20" DC wheels
1998 Expedition XLT 5.4 4x4,HIDs,16x8 ultra wheels,LEDs, HIDs
1991 F-250 lairat 4x4 5.0, 7'6" BOSS snow plow, Back Rack, Strobes, Work lights
Reply With Quote
  #218  
Old 10-14-2009, 12:37 PM
NorthCarolinaExpy's Avatar
NorthCarolinaExpy NorthCarolinaExpy is offline
Senior User
 
Join Date: Dec 2003
Location: Planet Earth
Posts: 108
NorthCarolinaExpy is starting off with a positive reputation.
Still a cool SUV

2001 Expedition XLT 2wd. . 5.4L with 238,000 and still going strong. Recently had the rear axle rebuilt, front wheel bearings replaced. Original motor still knocks at cold start (same as day one). Odometer goes out sometimes, rear wiper works sometimes, rear washer leaks so i disconnected it and plugged it so i dont lose my windshield washer fluid and now it only operates the front windshield (which is ok). A vibration issue when i get past 70mph (cant find a tire store that can solve that problem yet).
__________________
2001 Expedition XLT Triton 5.4L.
Mobil 1 5w20 oil
Continental ContiTrac SUV 265/70r17
Purchased new December 2000.
324,000 miles.
Reply With Quote
  #219  
Old 10-14-2009, 10:31 PM
luv2pla luv2pla is offline
New User
 
Join Date: Aug 2007
Posts: 6
luv2pla is starting off with a positive reputation.
1997 4x4 w/ 214,000 miles. Still going strong but probably needs front wheel bearings/hubs.
Reply With Quote
  #220  
Old 10-28-2009, 11:01 PM
Morris08 Morris08 is offline
Freshman User
 
Join Date: Feb 2004
Posts: 41
Morris08 is starting off with a positive reputation.
2004 5.4L 2WD XLT ... I have put 109,500 miles on it, never towed anything.
MSRP was 35,930, paid 29,600 driveout in March 2004.

had numerous problems at first but got most of them fixed/worked out by Ford:
- dealer replace all four crappy Continentals, out of round at 600 miles!
- replaced rear-end assembly/ring&pinion gear, had constant grinding noise/humm at 4k miles
- replaced stereo/6cd unit - CD's were HOT!! when ejected
- windshield washer low fluid light kept coming on, faulty sensor
- dark gray moulding along bottom sides, replace - fading from sun at 55k miles
- windshield washer sprayer not working
- replaced Alternator at 87k and A/C vacuum hose (cost $510)

now at 109k miles and my Service Engine soon light is coming on... have a slight hesitation issue at 50-60 mph, almost as if the transmission thinks about shifting but doesn't, a few times.
Reply With Quote
  #221  
Old 10-29-2009, 12:49 AM
97ExpGuy 97ExpGuy is offline
Senior User
 
Join Date: Feb 2009
Location: Southern Illinois
Posts: 482
97ExpGuy is gaining momentum as a positive member of FTE.
Quote:
Originally Posted by Morris08 View Post
2004 5.4L 2WD XLT ... had numerous problems at first but got most of them fixed/worked out by Ford:
- dealer replace all four crappy Continentals, out of round at 600 miles!
- replaced rear-end assembly/ring&pinion gear, had constant grinding noise/humm at 4k miles
- replaced stereo/6cd unit - CD's were HOT!! when ejected
- windshield washer low fluid light kept coming on, faulty sensor
- dark gray moulding along bottom sides, replace - fading from sun at 55k miles
- windshield washer sprayer not working
- replaced Alternator at 87k and A/C vacuum hose (cost $510)
Sorry to hear about some of small irritating things that went bad on your vehicle, but this is exactly why I refuse to buy a new vehicle. You pay 30 grand for a truck and within 100k miles, all of this crap happened - and its all the small stupid crap too! It's like the electronics used just get cheaper and cheaper and so does the quality of materials used. Sorry to rant and use you as an example, but when I read of all the small stupid things that fail, I find the irritation not in Ford owning up and replacing items under warranty, but the fact that you have to schedule an appointment, drop the vehicle off, wait for the diagnosis and solutions, etc, deal with a crappy rental, the works. OK, I'm done!

Quote:
Originally Posted by Morris08 View Post
now at 109k miles and my Service Engine soon light is coming on... have a slight hesitation issue at 50-60 mph, almost as if the transmission thinks about shifting but doesn't, a few times.
Hmm...fuel injectors? I had a hesitation on acceleration at highway speeds and when I pulled the injectors, 3 of them had hairline cracks at the tips.
Reply With Quote
  #222  
Old 10-29-2009, 03:22 AM
webmack webmack is offline
New User
 
Join Date: Oct 2009
Posts: 7
webmack is starting off with a positive reputation.
1997 Expedition Eddie Bauer 4x4 8cyl 5.4L - 92000 Kms

Bought it 2 weeks ago from someone selling it on behalf of the owner who left the country. Don't have much history on it, but it was a bargain, and I felt I could get whatever issues there were fixed up. Overall its in good condition and I love it!

Issues that I'm currently looking at getting fixed:
  • 5 x 5 beeps. SRS air bag light does not come on at the start or at any point. I'm hoping this is just a case of looking at the circuit / wires to that light or replacing the light in the dashboard
  • Overdrive light has started flashing and transmission slips / jerks when shifting from 1st to 2nd and back when its hottest outside in the day (40C +) Its there when its cooler but less noticeable. I've changed tranny oil but no luck. I'm hoping its a TTC solenoid or some thing other than needing to replace the whole transmission :/ Have a thread here asking for advice when I take it in: http://www.ford-trucks.com/forums/89...-slipping.html
Reply With Quote
  #223  
Old 11-09-2009, 04:56 PM
themooser themooser is offline
New User
 
Join Date: Sep 2006
Posts: 20
themooser is starting off with a positive reputation.
1997 Expedition 2WD XLT 5.4L V8 (Full leather with towing package) - just went over 230K. With exception of heater core (which has had to be replaced twice), have had no real "major" issues ...

Purchased in 1999 with 32K ... replacements/upgrades since (in no particular order and many I did myself):
- upgraded radiator to heavy duty aluminum (from F350)
- replaced/upgraded rear air suspension with spring coils
- replaced alternator @150K miles
- replaced heater core (twice)
- replaced upper and lower ball joints and tie rod ends
- driver's side window regulator

May seem like alot of stuff but actually it's not ... she's been pretty good to me over the years ...

Items on the "soon-to-do-list" (before the end of the year):
- finally going to fix the dashboard ghosting issue this weekend (thanks to this forum)
- installing cold air intake
- considering installing an oil cooling system (heard those really help with engine life)
- sizeable exterior/interior mods (paint job, chrome replacements, replace carpet, upgrading Captain's chairs to "higher" back seats (Lariat style) with Katskinz covers, upgrading sound system and alarm system, etc.)
Reply With Quote
  #224  
Old 11-09-2009, 05:46 PM
High_Horse's Avatar
High_Horse High_Horse is offline
Elder User
 
Join Date: Jun 2004
Location: Orlando, Fla
Posts: 679
High_Horse is starting off with a positive reputation.
I only have two things to keep in mind ....preventive maintenance and synthetics....my signature doesn't lie.
__________________
If it ain't broke, fix it before it is, preventative maintenance costs less !! 694,000+ FORD tough miles...
97 Expy XLT 2x4, 5.4
Reply With Quote
  #225  
Old 11-09-2009, 05:52 PM
themooser themooser is offline
New User
 
Join Date: Sep 2006
Posts: 20
themooser is starting off with a positive reputation.
I feel you on the synthetics (did that about 3 years ago and has worked beautifully) and I'm "learning as I go" about preventative maintenance ... just got her outta the shop for the suspension conversion and plan on being much more proactive with her in regards to that ...
Reply With Quote
Old 11-09-2009, 05:52 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Towing tire pressure rcosta Excursion - King of SUVs 7 08-08-2012 10:31 PM
EBPV question ReBilld 1994.5 - 1997 7.3L Power Stroke Diesel 10 02-15-2012 10:53 PM
How many Flats U got? idahodisco Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 38 03-23-2010 12:53 AM
How Much You Paying For Your Biodiesel? El Gato Bio-diesel, Propane & Alternative Diesel Engine Fuels 17 12-27-2005 07:54 PM
Do you do your own work on your Aerostar? Racerguy Aerostar 13 08-09-2004 09:48 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator

Tags
150, 2003, 388000, expedition, expeditions, experdition, f250, ford, miles, navigator, run, trucks, worthcom, www1999, yank883

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 09:11 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup