Go Back   Ford Truck Enthusiasts Forums > Regional Chapters > Western Region > California, Southern Chapter
Sign in using an external account
Register Forgot Password?


California, Southern Chapter Join Chapter, Leader: wpnaes

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 12-14-2007, 09:34 AM
forenglishpressone forenglishpressone is offline
New User
 
Join Date: Dec 2007
Location: Long Beach, CA
Posts: 4
forenglishpressone is starting off with a positive reputation.
Greetings So-Cal!

Hello everyone.
I am here trying to keep my expy alive for a few more miles. Seems like I hit 100k and a switch went off...now I'm on a 1st name basis with the AAA man. Thanks in advance for all your help.


Cheers.
-J
Reply With Quote
  #2 (permalink)  
Old 12-14-2007, 09:57 AM
SteveBricks's Avatar
SteveBricks SteveBricks is online now
FTE Administrator
 
Join Date: Aug 2007
Location: Lakewood, Ca.
Posts: 42,009
SteveBricks has a superb reputationSteveBricks has a superb reputationSteveBricks has a superb reputationSteveBricks has a superb reputationSteveBricks has a superb reputationSteveBricks has a superb reputationSteveBricks has a superb reputationSteveBricks has a superb reputationSteveBricks has a superb reputationSteveBricks has a superb reputationSteveBricks has a superb reputation
Welcome! The "King of the SUV's" forum will get you squared away. Lots of knowledgable folks that are happy to help out.
__________________
'06 F250 6.0 / '94 F350 7.5
Regional Chapters Moderator
SoCal FTE
Join our Chapter *HERE*
9/21/54 - 9/25/09
Reply With Quote
  #3 (permalink)  
Old 12-14-2007, 11:22 AM
Kep4's Avatar
Kep4 Kep4 is offline
Jäger
 
Join Date: Jan 2005
Location: Diamond Bar, Kalifornia
Posts: 5,459
Kep4 has a brilliant futureKep4 has a brilliant futureKep4 has a brilliant futureKep4 has a brilliant futureKep4 has a brilliant futureKep4 has a brilliant futureKep4 has a brilliant futureKep4 has a brilliant futureKep4 has a brilliant futureKep4 has a brilliant futureKep4 has a brilliant future
Welcome to FTE!

You may want to go into 'User CP' and add your location and add information about your Expedition ( engine, trans, 2wd/4wd, prior problems, etc...). That will help us help you. (Think Jerry Maguire... )
__________________
Russ
'12 F350 Lariat CCLB 4x4 6.7, Bilstein shocks/leveling coils, AmpSteps, Duraflaps, Buckstop aluminum bumper w/Warn 16.5 winch, Nitto Trail Grappler tires, 57 gallon Transferflow fuel tank
'13 Fuzion 315 5th wheel
'05 F250 Lariat CCSB 4X4 6.0 - Sold 4/26/11 w/96,500 miles
Reply With Quote
  #4 (permalink)  
Old 12-14-2007, 01:50 PM
73f350sc's Avatar
73f350sc 73f350sc is offline
Posting Guru
 
Join Date: Jan 2004
Location: Murray
Posts: 1,254
73f350sc is gaining momentum as a positive member of FTE.73f350sc is gaining momentum as a positive member of FTE.
Welcome,
If you could describe exactly what its doing, that would be helpful in an attempt to help you figure out what the issue is... =)
-Chris
__________________
73 F 350 Super Camper Special
97 Expedition
Proud So-Cal Chapter Member since the dark ages
New Member of the Kentucky Chapter
Reply With Quote
  #5 (permalink)  
Old 12-14-2007, 09:48 PM
forenglishpressone forenglishpressone is offline
New User
 
Join Date: Dec 2007
Location: Long Beach, CA
Posts: 4
forenglishpressone is starting off with a positive reputation.
2001 Expedition 4.6

The truck doesn't like the wet weather @ all. Hard or no start when we get rain, which isn't that often so I have ignored it in the past but recently it has been more of an issue. Recently the truck stranded my wife but managed to start again and limp home. Then a couple days ago it came home on the hook. I looked through the forums here found some common issues and knocked them out today. I needed a new battery and that led to new terminal connections. Totally worth the :45 minutes to clean everything up and install the new ends. So now I had full cranking power but no fuel pump noise so I dropped the tank and swapped out the pump and filter. The truck started right up so hopefully I killed the problem. All in all I am in maybe 4 hours of time and 297$ and everything seems to be working fine.

Now I just have to wait and see if the problem comes back. Hopefully it won't and I'll forget allllllll about it

Does anyone know if the moisture/rain issue is in any way tied to the fuel issues I just addressed? I read something about the GEM module getting wet?
Reply With Quote
Old 12-14-2007, 09:48 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Regional Chapters > Western Region > California, Southern Chapter

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 10:20 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup