Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-08-2007, 01:50 PM
cjgeorge32 cjgeorge32 is offline
Junior User
 
Join Date: Sep 2007
Posts: 71
cjgeorge32 is starting off with a positive reputation.
Unhappy Samll problems with the 2007 Limited EL

I would like to start this new thread by saying I LOVE MY 2007 Expy Limited EL. I am on my 4th Expedition. However my Expy has been in the shop 4 times….I have had it since June 2007 and I have 5,000 miles on it…

Problems:

1. You all know this problem I have in this thread I started a couple of months back..

2007 Chrome Clad Rims...Outraged!!


2. The strut on the motorized liftgate was making a horrible screeching sound going up and down…Problem fixed with a replacement strut.

3. Driver side mirror was very loose….Problem fixed with a replacement mirror.

4. A wind storm was coming through the driver side window at speeds in excess of 40 MPH…..Problem fixed with a replacement of the felt-like molding on the inside of the window.

5. AND NOW….the heated and cooled seats buttons on the AC cluster will not light up and therefore the seat will not heat or cool. The passenger sign works fine. …Problem not fixed yet…

6. Also, the leather on the driver seat is wearing much faster than my previous Expy’s.

I hope this helps some of you with similar issues….


Reply With Quote
  #2  
Old 12-08-2007, 02:19 PM
IQ9 IQ9 is offline
Senior User
 
Join Date: Sep 2007
Posts: 351
IQ9 is starting off with a positive reputation.
Well at least you don't have the tranny issue some have. You do have alot of small stuff but that adds up too.
__________________
White Sand 08 Expy EL Limited 4x4 with everything but the power running boards & trip tunes.
Reply With Quote
  #3  
Old 12-08-2007, 03:59 PM
Ogio Ogio is offline
Junior User
 
Join Date: Sep 2007
Posts: 50
Ogio is starting off with a positive reputation.
I have 4. and 6.

When you say wind storm, was is making a whistling sound? I have had the mirrors replaced and the outer weaterstripping and I still have what I would consider excessive wind noise. Maybe I am being too ****. At about 60mph+ I can hear wind 'whooshing' at the mirrors. I thought the replacement mirrors I had installed would eliminate this.

A snip from this review: http://consumerguideauto.howstuffwor...avigator-5.htm



Quietness

4WD Ultimate w/Elite Pkg. Class Average
7 6.7

Highway-speed wind rush from outside mirrors a blemish on otherwise impressively low noise levels. Engine vocal only in rapid acceleration.

Last edited by Ogio; 12-08-2007 at 04:02 PM.
Reply With Quote
  #4  
Old 12-09-2007, 07:49 PM
cjgeorge32 cjgeorge32 is offline
Junior User
 
Join Date: Sep 2007
Posts: 71
cjgeorge32 is starting off with a positive reputation.
I think the wind noise is very normal around the mirrors....I was getting full on wind in my Expy....Problem was fixed...
Reply With Quote
  #5  
Old 12-12-2007, 04:11 PM
IQ9 IQ9 is offline
Senior User
 
Join Date: Sep 2007
Posts: 351
IQ9 is starting off with a positive reputation.
What part of the power liftgate failed. Mine will no open and close in one motion. No it does not stop to let me put anything in just up and the bells frantically sounds and down it goes. You had the strut replaced-was it the airshock or the arm that does the lifting? I am just trying to get an idea if I am having a problem close to yours-only much worse. The tailgate makes no odd noises. Thanks for the help.
__________________
White Sand 08 Expy EL Limited 4x4 with everything but the power running boards & trip tunes.
Reply With Quote
Old 12-12-2007, 04:11 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
High EOT's AFTER repairs. 06FUN 6.0L Power Stroke Diesel 114 01-28-2014 07:59 AM
Intermittent Battery Light lakerats Super Duty & Heavy Duty 4 03-17-2011 03:40 PM
1996 F250 E40D - No Gears Rooster368 Clutch, Transmission, Differential, Axle & Transfer Case 3 12-06-2009 08:47 PM
1996 F250 E40D - No gears Rooster368 1987 - 1996 F150 & Larger F-Series Trucks 1 12-02-2009 02:23 PM
MAF Sensor joe38socalif 1997 - 2003 F150 28 11-20-2008 05:42 AM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Tags
2007, el, expedition, ford, problems, replacement, strut

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 08:47 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup