Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-26-2007, 03:52 PM
Wildcat_1 Wildcat_1 is offline
Junior User
 
Join Date: Mar 2003
Posts: 95
Wildcat_1 is starting off with a positive reputation.
Seat Issues ?

All

My wife noticed an issue today where she heard what she thought was a fan noise in the 07 Eddie Bauer. She turned all the fans off, radio etc and was still there. Then she noticed she had the heated seats on, turned those off and the fan noise stopped.

Can anyone comment on this as it sounds strange. I will be testing tonight but wondered if anyone knew what this could be and if they had experienced it. Also let me know if you have had this resolved and what steps were taken
Reply With Quote
  #2  
Old 11-26-2007, 03:58 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Well I would assume the fan pushes hot/cold air through the seats. Some heat only seats have elements that warm the seat, these use air as far as I know.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #3  
Old 11-26-2007, 04:14 PM
Wildcat_1 Wildcat_1 is offline
Junior User
 
Join Date: Mar 2003
Posts: 95
Wildcat_1 is starting off with a positive reputation.
that was my thoughts. I only thought it was an element
Reply With Quote
  #4  
Old 11-26-2007, 04:36 PM
rich93cw rich93cw is offline
Senior User
 
Join Date: May 2006
Location: Near the Chesapeake Bay
Posts: 125
rich93cw is starting off with a positive reputation.
I have a shop manual. The seats have a filter, fan, and a peltier heating/cooling element. Depending on which way the electric current is flowing through the element, it will either get hotter, or cooler. In anycase, changing the filter as recommended in your owners manual will keep it working properly.
Reply With Quote
  #5  
Old 11-27-2007, 12:39 AM
Wildcat_1 Wildcat_1 is offline
Junior User
 
Join Date: Mar 2003
Posts: 95
Wildcat_1 is starting off with a positive reputation.
Is it a filter issue then ? I only have 3.5k miles on the truck !!!!
Reply With Quote
  #6  
Old 11-27-2007, 06:20 AM
Newton007's Avatar
Newton007 Newton007 is offline
Senior User
 
Join Date: Jul 2007
Posts: 222
Newton007 is starting off with a positive reputation.
At times the fan on my 07 makes a sort of low growl noise that sounds like it is from the radio. Punching the off button, then the auto button usually stops the noise. May be the fan at just one speed only as it only happens sometimes.
Reply With Quote
  #7  
Old 11-27-2007, 06:40 AM
ExpyBob ExpyBob is offline
Senior User
 
Join Date: Mar 2002
Location: Tannersville PA USA
Posts: 369
ExpyBob is starting off with a positive reputation.
My 2004 and 2007 both make a quiet fan noise when on. It's normal. The filter is fine.

bob
__________________
Bob
Reply With Quote
  #8  
Old 11-27-2007, 12:47 PM
IQ9 IQ9 is offline
Senior User
 
Join Date: Sep 2007
Posts: 351
IQ9 is starting off with a positive reputation.
I have the same noise and it is the fans in the seats... I asked the dealer if they thought the noise was normal and they said yes but they wished it was quieter as they get the question quite alot.
__________________
White Sand 08 Expy EL Limited 4x4 with everything but the power running boards & trip tunes.
Reply With Quote
Old 11-27-2007, 12:47 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow reaction fuel gauge / Gear noise from fuel gauge Gettysburg150 Escape & Escape Hybrid 5 03-15-2014 01:35 AM
04 EB Clicking noise with the rear heat is turned off mayor Expedition & Navigator 8 01-09-2014 09:29 AM
Did Ford Fix These with New Escape? ol'yeller Escape & Escape Hybrid 21 06-30-2012 07:08 PM
new to the forums, I have major problem figgy03 Explorer, Sport Trac, Mountaineer & Aviator 4 12-10-2011 08:24 PM
What tha??? Dean88 Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 52 04-26-2009 12:05 PM



All times are GMT -5. The time now is 06:37 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup