Charge issue, new alt. 03 Lightning - Ford Truck Enthusiasts Forums



Lightning, Harley-Davidson F-150, Roush F-150 & Saleen F-150 SVT Ford F150 Lightning, Roush, Saleen and other performance F150's

Charge issue, new alt. 03 Lightning

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-10-2007, 11:35 PM
commandersander's Avatar
commandersander commandersander is offline
Senior User
Thread Starter
 
Join Date: Feb 2004
Location: Under My Truck
Posts: 211
commandersander is starting off with a positive reputation.
Charge issue, new alt. 03 Lightning

Again....sort of.....

Anyway, the 97 4.6 4x4 turned 03 4x4 Lightning presents me with yet another challenge.

At the near completion of the swap, I realized that my $1400 hi-amp dual-out 400a altenator would NOT fit the new power plant....

$400 lighter due to the local stealer-ship, I finished the top end assembly with the "Lightning" altenator and the rest of the top-side crapolla. Neurotic as I am, the factory 8ga was cast aside for a much nicer looking (and more capable) run of 1ga back to the dist. block on the pass-side firewall.

Issue.....it is not charging the battery. I thought that I heard of a similar issue that is a simple mistake (stock altenator not charging because....) but I can't locate it now.

Any leads?
Reply With Quote
  #2  
Old 11-18-2007, 12:24 AM
Stewart_H's Avatar
Stewart_H Stewart_H is offline
The Nekkid Super Mod
 
Join Date: May 2004
Location: Central Coast of CA
Posts: 24,001
Stewart_H has a superb reputationStewart_H has a superb reputationStewart_H has a superb reputationStewart_H has a superb reputationStewart_H has a superb reputationStewart_H has a superb reputationStewart_H has a superb reputationStewart_H has a superb reputationStewart_H has a superb reputationStewart_H has a superb reputationStewart_H has a superb reputation
No insight, sorry. But again, check out that website I posted in one of your other threads. It will point you in the direction of someone whom I bet can answer your questions.

Stewart
Reply With Quote
 
 
Reply


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 11:30 AM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.