Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator
Sign in using an external account
Register Forgot Password?


Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-05-2007, 06:23 PM
mack6820 mack6820 is offline
Junior User
 
Join Date: Mar 2003
Location: Moore, Oklahoma
Posts: 84
mack6820 is starting off with a positive reputation.
a/c smells like coolant

Hey guys. My beloved 98 Expy 5.4 just developed a bad smell coming from the a/c vents. I cant find a leak anywhere but it really smells strong. smells like antifreeze.
Does this sound like a heater core? Where is it? Ive changed one before on a car and it was under the dash.
Reply With Quote
  #2  
Old 09-05-2007, 06:40 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Heater core went bad?
Reply With Quote
  #3  
Old 09-05-2007, 07:35 PM
Billykidd Billykidd is offline
New User
 
Join Date: Sep 2004
Posts: 4
Billykidd is starting off with a positive reputation.
Same thing just happened to mine! Another thing it started to do is my gauges, lights, instrument panel, and electrical systems are going crazy! RPMs will spike during idle and eventually it will just stall and won't be able to start....dead batter!? I can jump it but it will just do the same thing and eventually stall again?

I'm thinking heater core for yours and mine but any ideas on the crazy dash and electrical system? Is it possible coolant is shorting out the system and causing everything to go crazy?
Reply With Quote
  #4  
Old 09-05-2007, 09:27 PM
twodazeoff twodazeoff is offline
Freshman User
 
Join Date: Aug 2006
Posts: 34
twodazeoff is starting off with a positive reputation.
Is your windshield fogging up? If so then it is your heater core. To replace it you have to pull the dash back. This pays around 7 hour labor to do.
Reply With Quote
  #5  
Old 09-05-2007, 10:09 PM
mack6820 mack6820 is offline
Junior User
 
Join Date: Mar 2003
Location: Moore, Oklahoma
Posts: 84
mack6820 is starting off with a positive reputation.
My windshield isnt fogging up, I just have a very strong smell of antifreeze coming from my a/c vents. Everything else is normal. gauges, water level is a tiny bit lower, no visible leaks.
Reply With Quote
  #6  
Old 09-06-2007, 12:28 AM
dogzpaws dogzpaws is offline
New User
 
Join Date: Aug 2007
Posts: 18
dogzpaws is starting off with a positive reputation.
I haven't had this problem in my Expy, but I did on a 97 BMW 5 series. That ended up being a cracked head. The leak was relatively small but coolant from the block was dripping on the exhaust manifold and evaporating. It intensified the odor that went to the cab. And the leak was hard to find since it would only leak when the car was fully heated and the antifreeze would evaporate when it did leak. I'm not saying you have cracked head, just explore your options, especially if you don't have vapor/fog in the cab.
Reply With Quote
  #7  
Old 09-11-2007, 06:07 PM
mack6820 mack6820 is offline
Junior User
 
Join Date: Mar 2003
Location: Moore, Oklahoma
Posts: 84
mack6820 is starting off with a positive reputation.
a friend says it could be my cabin filter? as I said, the heater works fine, a/c works fine, windshield doesnt fog up. just smells like antifreeze coming from my a/c
Reply With Quote
  #8  
Old 09-11-2007, 06:49 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Why would a cabin filter make your a/c smell like antifreeze?
Reply With Quote
  #9  
Old 09-11-2007, 06:54 PM
mack6820 mack6820 is offline
Junior User
 
Join Date: Mar 2003
Location: Moore, Oklahoma
Posts: 84
mack6820 is starting off with a positive reputation.
that was my question too. thought i would ask
Reply With Quote
  #10  
Old 09-11-2007, 07:00 PM
twodazeoff twodazeoff is offline
Freshman User
 
Join Date: Aug 2006
Posts: 34
twodazeoff is starting off with a positive reputation.
You do not have a cabin air filter in that year expy. Have a shop pressure test the coolant system and I can almost gaurantee that it is the heater. If not than you had an animal get in there and either died or left behind it's markings.
Reply With Quote
  #11  
Old 09-11-2007, 08:07 PM
bmconway76110 bmconway76110 is offline
Freshman User
 
Join Date: Oct 2006
Posts: 32
bmconway76110 is starting off with a positive reputation.
I am taking my 2001 in tomorrow for the same thing. It started off with the smell from the vents. Now, it is dripping from someplace all day long. I tried looking tonight, but I can't find it. It looks like it is dripping from three spots. The other thing that started yesterday was steam from the vents.

I got a quote of 800-900 at the dealer for the heater core, and 600 at a private shop. It goes to the shop in the morning.
Reply With Quote
  #12  
Old 09-11-2007, 08:55 PM
MisterCMK's Avatar
MisterCMK MisterCMK is online now
Avid Winter Hater
 
Join Date: Mar 2003
Location: Maple Grove, MN
Posts: 20,204
MisterCMK has a superb reputationMisterCMK has a superb reputationMisterCMK has a superb reputationMisterCMK has a superb reputationMisterCMK has a superb reputationMisterCMK has a superb reputationMisterCMK has a superb reputationMisterCMK has a superb reputationMisterCMK has a superb reputationMisterCMK has a superb reputationMisterCMK has a superb reputation
Coolant smell is usually a heater core. Have the system pressure tested to confirm this.
__________________
Chris - Avid Winter Hater
2007 F-250 XLT 4x4 CC SB 6.0 PSD - ARP, IPR Gen2 EGR Delete, 4" turbo-back, no muffler, no cat, 6.4 banjo bolts, SCT X3, EA 270A Alt, coolant filter, air bags, Ranchos, etc.
1994 Mustang GT - HCI, Novi2k blower, MM suspension parts, etc
Hope & A Prayer Motorsports
Reply With Quote
  #13  
Old 09-12-2007, 10:55 AM
bmconway76110 bmconway76110 is offline
Freshman User
 
Join Date: Oct 2006
Posts: 32
bmconway76110 is starting off with a positive reputation.
I dropped mine off this morning. When I got up, the overflow tank was empty, so I filled it up, drove to shop. There was steam blowing from the vents the entire way.

I will keep you guys posted.
Reply With Quote
  #14  
Old 09-12-2007, 01:40 PM
Billykidd Billykidd is offline
New User
 
Join Date: Sep 2004
Posts: 4
Billykidd is starting off with a positive reputation.
So it was the heater core on mine! Replaced it this weekend....boy was that fun! I would recommend an air ratchet! Made things a lot easier and faster!

The problem with all the gauges and lights going crazy and finally just stalling ended up being a bad alternator AND battery! Double whammy! Fixed everything up over the weekend and now I'm up and running!

Great forum!
Reply With Quote
  #15  
Old 09-12-2007, 04:18 PM
bmconway76110 bmconway76110 is offline
Freshman User
 
Join Date: Oct 2006
Posts: 32
bmconway76110 is starting off with a positive reputation.
I just heard from the shop on mine. It is a leaking heater core. They said it will be ready tomorrow afternoon. I will let you guys know what the damage to checkbook is.
Reply With Quote
Old 09-12-2007, 04:18 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
another possible evaporator coil leak mebe2k 6.7L Power Stroke Diesel 10 11-14-2014 11:11 PM
My A/C smells nasty ???? Duderoy Explorer, Sport Trac, Mountaineer & Aviator 5 10-16-2011 10:33 PM
A/c smells like anti freeze Fordtrucktexan 1997 - 2003 F150 22 12-20-2008 07:18 PM
2002 Mountaineer a/c funny smell! cbrown Explorer, Sport Trac, Mountaineer & Aviator 5 07-18-2005 07:15 PM
A/C smell rockgt302 Expedition & Navigator 16 07-07-2005 01:15 AM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator

Tags
1994, 1997, 2002, 98, ac, antifreeze, coolant, expedition, ford, gt, mustang, smell, smelling, smells, vents

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 09:42 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup