Go Back   Ford Truck Enthusiasts Forums > Misc. > Air Intakes, Air Filters & Ram Air
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 08-08-2007, 11:58 PM
SANDDEMON08's Avatar
SANDDEMON08 SANDDEMON08 is offline
Posting Guru
 
Join Date: Jun 2007
Location: Henderson, NV
Posts: 1,203
SANDDEMON08 has a very good reputation on FTE.SANDDEMON08 has a very good reputation on FTE.SANDDEMON08 has a very good reputation on FTE.
6.4 PSD Stage II AFE Air Filter

I have had two problems with the new 6.4 AFE stage II filter.
First problem, the intake tube supplied by AFE in the kit has a bad fit up to the existing factory tube to the turbo. AFE is aware of the problem and is working on a fix. Unfiltered air can pass due to this problem.

Second problem, check engine light came on after 2500 miles. Dealer claimed the air box was the problem due to too much air flow. Can't tell if this is true or not, but its what the dealer told me.

I don't know if any of the other aftermarket guys are having the samr problem.
__________________
Got beer ? 611 HP 1205 TQ
08 F350 CC FX4, 6.4 PSD,PMF 4.5" LIFT WITH TRACTION BARS,4.30 REAR,NAV,DASH DAQ,VOLANT INTAKE,SPEARCO INTERCOOLER,STAGE III WATER/METH,67 GAL TITAN TANK,EGR DELETE,ARP HEAD STUDS,72MM LP BILLET TURBO,RCD CONVERTER,FS-2500 BYPASS FILTER, AIR DOG II FUEL PUMP,CUSTOM CCV,MAG-HYTEC TRANS PAN AND DIFF COVER, CUSTOM HD TRANS COOLER, SEIC MOD,AMP STEPS
Reply With Quote
  #2 (permalink)  
Old 08-09-2007, 09:32 PM
BobbyDiesel71's Avatar
BobbyDiesel71 BobbyDiesel71 is offline
Postmaster
 
Join Date: Apr 2005
Location: round rock, tx
Posts: 2,734
BobbyDiesel71 has a very good reputation on FTE.BobbyDiesel71 has a very good reputation on FTE.BobbyDiesel71 has a very good reputation on FTE.
Quote:
Originally Posted by SANDDEMON08
I have had two problems with the new 6.4 AFE stage II filter.
First problem, the intake tube supplied by AFE in the kit has a bad fit up to the existing factory tube to the turbo. AFE is aware of the problem and is working on a fix. Unfiltered air can pass due to this problem.

Second problem, check engine light came on after 2500 miles. Dealer claimed the air box was the problem due to too much air flow. Can't tell if this is true or not, but its what the dealer told me.

I don't know if any of the other aftermarket guys are having the samr problem.
Did AFE say they would send you a replacement when they get a newer design?
Otherwise, get a refund and use stock system till the aftermarket companies get the new design perfected.
AFE is a great company, I had an issue with my Stage II intake for my 02 F-350
A service tech worked with me and sent me a new ProGuard 7 filter
__________________
Sold 08/07/12
DP TUNED
swamps single shots
02 F-350 lariat srw,supercab longbed 4x4 FX4
[i][color=blue]Transgo Tugger II, TRU-COOL 4739, AFE stage II intake, Bully Dog 5" turbo back exhaust
Reply With Quote
  #3 (permalink)  
Old 08-11-2007, 05:23 PM
SANDDEMON08's Avatar
SANDDEMON08 SANDDEMON08 is offline
Posting Guru
 
Join Date: Jun 2007
Location: Henderson, NV
Posts: 1,203
SANDDEMON08 has a very good reputation on FTE.SANDDEMON08 has a very good reputation on FTE.SANDDEMON08 has a very good reputation on FTE.
Quote:
Originally Posted by toyota hauler
Did AFE say they would send you a replacement when they get a newer design?
Otherwise, get a refund and use stock system till the aftermarket companies get the new design perfected.
AFE is a great company, I had an issue with my Stage II intake for my 02 F-350
A service tech worked with me and sent me a new ProGuard 7 filter
YA there supposed to be sending me a upgraded replacment tube.
__________________
Got beer ? 611 HP 1205 TQ
08 F350 CC FX4, 6.4 PSD,PMF 4.5" LIFT WITH TRACTION BARS,4.30 REAR,NAV,DASH DAQ,VOLANT INTAKE,SPEARCO INTERCOOLER,STAGE III WATER/METH,67 GAL TITAN TANK,EGR DELETE,ARP HEAD STUDS,72MM LP BILLET TURBO,RCD CONVERTER,FS-2500 BYPASS FILTER, AIR DOG II FUEL PUMP,CUSTOM CCV,MAG-HYTEC TRANS PAN AND DIFF COVER, CUSTOM HD TRANS COOLER, SEIC MOD,AMP STEPS
Reply With Quote
  #4 (permalink)  
Old 08-27-2007, 05:52 PM
aFepower's Avatar
aFepower aFepower is offline
New User
 
Join Date: Aug 2007
Posts: 5
aFepower is starting off with a positive reputation.
Quote:
Originally Posted by SANDDEMON08
I have had two problems with the new 6.4 AFE stage II filter.
First problem, the intake tube supplied by AFE in the kit has a bad fit up to the existing factory tube to the turbo. AFE is aware of the problem and is working on a fix. Unfiltered air can pass due to this problem.

Second problem, check engine light came on after 2500 miles. Dealer claimed the air box was the problem due to too much air flow. Can't tell if this is true or not, but its what the dealer told me.

I don't know if any of the other aftermarket guys are having the samr problem.
Hello,
The aFe 6.4L intake kit (51/54/75-31262) was designed off a early production 6.4L. Early productions of the '08 6.4L have a solid OE rubber intake tube. This is what we designed the intake tube with. Newer production 6.4L have changed to half rubber & half plastic. As a result we noticed that the OD of our tube is smaller in diameter with newer production '08 6.4L. This may cause CEL to occur. We are fixing this problem and sending out new tubes to customers who have this issue!
Reply With Quote
  #5 (permalink)  
Old 08-27-2007, 10:24 PM
SANDDEMON08's Avatar
SANDDEMON08 SANDDEMON08 is offline
Posting Guru
 
Join Date: Jun 2007
Location: Henderson, NV
Posts: 1,203
SANDDEMON08 has a very good reputation on FTE.SANDDEMON08 has a very good reputation on FTE.SANDDEMON08 has a very good reputation on FTE.
Welcome to the site,

Do you work for AFE?

I recieved the new update tube with the steel band in it, after about 500 miles my CEL came on again, i put the stock box on and after about a day of driving the light went off,any suggustions?
__________________
Got beer ? 611 HP 1205 TQ
08 F350 CC FX4, 6.4 PSD,PMF 4.5" LIFT WITH TRACTION BARS,4.30 REAR,NAV,DASH DAQ,VOLANT INTAKE,SPEARCO INTERCOOLER,STAGE III WATER/METH,67 GAL TITAN TANK,EGR DELETE,ARP HEAD STUDS,72MM LP BILLET TURBO,RCD CONVERTER,FS-2500 BYPASS FILTER, AIR DOG II FUEL PUMP,CUSTOM CCV,MAG-HYTEC TRANS PAN AND DIFF COVER, CUSTOM HD TRANS COOLER, SEIC MOD,AMP STEPS

Last edited by IB Tim; 09-30-2007 at 03:24 PM.
Reply With Quote
  #6 (permalink)  
Old 08-28-2007, 10:07 AM
aFepower's Avatar
aFepower aFepower is offline
New User
 
Join Date: Aug 2007
Posts: 5
aFepower is starting off with a positive reputation.
Quote:
Originally Posted by SANDDEMON08
Welcome to the site,

Do you work for AFE?

I recieved the new update tube with the steel band in it, after about 500 miles my CEL came on again, i put the stock box on and after about a day of driving the light went off,any suggustions?
Yes, we are a forum sponsor here on Ford-trucks.com and we will be here on the community helping out as best as we can!

Could you tell me what production date you have on your truck? Also, the tube that is in your truck, is it solid rubber or half rubber/half plastic?
Reply With Quote
  #7 (permalink)  
Old 08-28-2007, 11:58 AM
SANDDEMON08's Avatar
SANDDEMON08 SANDDEMON08 is offline
Posting Guru
 
Join Date: Jun 2007
Location: Henderson, NV
Posts: 1,203
SANDDEMON08 has a very good reputation on FTE.SANDDEMON08 has a very good reputation on FTE.SANDDEMON08 has a very good reputation on FTE.
Quote:
Originally Posted by aFepower
Yes, we are a forum sponsor here on Ford-trucks.com and we will be here on the community helping out as best as we can!

Could you tell me what production date you have on your truck? Also, the tube that is in your truck, is it solid rubber or half rubber/half plastic?
2/07. Its all plastic
__________________
Got beer ? 611 HP 1205 TQ
08 F350 CC FX4, 6.4 PSD,PMF 4.5" LIFT WITH TRACTION BARS,4.30 REAR,NAV,DASH DAQ,VOLANT INTAKE,SPEARCO INTERCOOLER,STAGE III WATER/METH,67 GAL TITAN TANK,EGR DELETE,ARP HEAD STUDS,72MM LP BILLET TURBO,RCD CONVERTER,FS-2500 BYPASS FILTER, AIR DOG II FUEL PUMP,CUSTOM CCV,MAG-HYTEC TRANS PAN AND DIFF COVER, CUSTOM HD TRANS COOLER, SEIC MOD,AMP STEPS
Reply With Quote
  #8 (permalink)  
Old 08-29-2007, 06:19 PM
aFepower's Avatar
aFepower aFepower is offline
New User
 
Join Date: Aug 2007
Posts: 5
aFepower is starting off with a positive reputation.
Quote:
Originally Posted by SANDDEMON08
Same thing happen to mine, i got the new tube with the steel band in it. Few hundred miles and the CEL came on. Took it off and the the light went off after the 2 day driving.

Quote: aFepower

Hello Nick,
We are trying to resolve these issues with this 6.4L! Its almost 1 out of few trucks have this problem. Has your 6.4L had the updated Re-flash? What is the production date?

The updated tube that we sent out works on almost all of these 6.4L's that have this issue. Thank You for being patient and we will take care of this as fast as we can and send you the correct tube or kit needed!

Build date on mine is 02/07 and the stock intake looks to be all hard plastic.

Why is the Intake causing codes to come up that have to do with the exhaust.

I have heard good things about Afe, but are we just paying Gini pigs with our $50,000.00 trucks for you to figure it out? Wheres the R&D for these products? Sorry but im a little agatated at this point.
SANDDEMON08,
I apoligize for any inconvenience that the aFe 6.4L intake is giving you! The R&D for this vehicle was done over a year ago with no issues. Two trucks went through over 8,000 miles on prototype parts with no issues before any part were released as first articles.

These new issues have been grabbing our attention in the past few months. We are trying to pin-point a time at which Ford has either Re-flashed these newer 6.4L, possibly not to have any more issues like the 6.0L International.

We will send you a new tube or kit if needed. If you do not feel comfortable with this kit you can return it! Thank you for being patient!
Reply With Quote
  #9 (permalink)  
Old 08-29-2007, 09:38 PM
SANDDEMON08's Avatar
SANDDEMON08 SANDDEMON08 is offline
Posting Guru
 
Join Date: Jun 2007
Location: Henderson, NV
Posts: 1,203
SANDDEMON08 has a very good reputation on FTE.SANDDEMON08 has a very good reputation on FTE.SANDDEMON08 has a very good reputation on FTE.
Quote:
Originally Posted by aFepower
SANDDEMON08,

We will send you a new tube or kit if needed. If you do not feel comfortable with this kit you can return it! Thank you for being patient!
When and how do i go about getting the new update, should i go through my local supplier?
__________________
Got beer ? 611 HP 1205 TQ
08 F350 CC FX4, 6.4 PSD,PMF 4.5" LIFT WITH TRACTION BARS,4.30 REAR,NAV,DASH DAQ,VOLANT INTAKE,SPEARCO INTERCOOLER,STAGE III WATER/METH,67 GAL TITAN TANK,EGR DELETE,ARP HEAD STUDS,72MM LP BILLET TURBO,RCD CONVERTER,FS-2500 BYPASS FILTER, AIR DOG II FUEL PUMP,CUSTOM CCV,MAG-HYTEC TRANS PAN AND DIFF COVER, CUSTOM HD TRANS COOLER, SEIC MOD,AMP STEPS
Reply With Quote
  #10 (permalink)  
Old 08-30-2007, 02:05 PM
ljstoy ljstoy is offline
Freshman User
 
Join Date: Aug 2007
Posts: 47
ljstoy is starting off with a positive reputation.
Hey Nick! What did you mean when you said that you got the new tube with a metal band in it. Was it the flex tube or the hard plastiic tube that the filter gauge and the air flow sensor go in? My flex tube has a metal band in it but the replacement part that AFE sent me was just the hard plastic tube (no metal on it anywhere). The flex tube i have is factory. I hate to give up on the AFE but i'm getting sick of this. I've got it paired up with the magnaflow 5" DPF back and together they sound real good.
Reply With Quote
  #11 (permalink)  
Old 08-30-2007, 02:11 PM
ljstoy ljstoy is offline
Freshman User
 
Join Date: Aug 2007
Posts: 47
ljstoy is starting off with a positive reputation.
when your check engine light comes on does it run like crap. I could tell that the intake gave it more power and response until the check engine light came on. Now it runs like crap. I guess I'll change it back over to stock (again) till we hear from AFE.
Reply With Quote
  #12 (permalink)  
Old 08-30-2007, 08:29 PM
SANDDEMON08's Avatar
SANDDEMON08 SANDDEMON08 is offline
Posting Guru
 
Join Date: Jun 2007
Location: Henderson, NV
Posts: 1,203
SANDDEMON08 has a very good reputation on FTE.SANDDEMON08 has a very good reputation on FTE.SANDDEMON08 has a very good reputation on FTE.
Quote:
Originally Posted by ljstoy
when your check engine light comes on does it run like crap. I could tell that the intake gave it more power and response until the check engine light came on. Now it runs like crap. I guess I'll change it back over to stock (again) till we hear from AFE.
I'm not nick, that post got draged from another thread, but when i recieved the first up date, the new intake tube had a small steel ring on the inside of the tube, possiable reinforcement i dont know. The first tube i got with my kit did not fit well with the factory tube. The AFE tube was to small and you have to over tighten the hose clamp to get any kind of a seal out of it. I checked the seal and found it was not air tight. I called AFE and they sent me the update. The second tube fit better, but was a bear to get the factory tube over it. The second tube still made the check engine light come on.

I took mine to the dealer and it had several codes to do with mass air flow sensor and also the regen pressure sensors. How the regen sensors are affected i dont know, but the result is your truck will go into regen alot or constiant, the white smoke can be from regen, i have tech bullitins that say thats normal. Dealer cleared the codes and the truck and it ran fine the first time. When the update tube afe sent me triped the check engine light again , i just put the factory box back in and the light went off after a little driving. During regen the engine is de-rated alot so that could be the performance issue you are having. If you bring the truck to the dealer make sure and put the stock box on, Dealer told me that my air box would void my warranty because the filter does not filter to the performance of the donaldson factory filter. I checked this and found the donaldson filter's 99.5 of the fine particulte's and the Afe pro-guard 7 filters 95%. If the dealer find that a aftermarket part caused the codes they will make you pay for the cost to check it out and yur warranty will not apply nor the deductible. Take that for what it is. Good luck.
__________________
Got beer ? 611 HP 1205 TQ
08 F350 CC FX4, 6.4 PSD,PMF 4.5" LIFT WITH TRACTION BARS,4.30 REAR,NAV,DASH DAQ,VOLANT INTAKE,SPEARCO INTERCOOLER,STAGE III WATER/METH,67 GAL TITAN TANK,EGR DELETE,ARP HEAD STUDS,72MM LP BILLET TURBO,RCD CONVERTER,FS-2500 BYPASS FILTER, AIR DOG II FUEL PUMP,CUSTOM CCV,MAG-HYTEC TRANS PAN AND DIFF COVER, CUSTOM HD TRANS COOLER, SEIC MOD,AMP STEPS

Last edited by SANDDEMON08; 08-30-2007 at 08:32 PM.
Reply With Quote
  #13 (permalink)  
Old 09-19-2007, 04:50 PM
S&B Filters S&B Filters is offline
New User
 
Join Date: Sep 2007
Posts: 1
S&B Filters is starting off with a positive reputation.
SANDDEMON08 -

When you have a second, shoot me an email. I have something to discuss with you that I think you'll be extremely interested in.

jcrouch@sbfilters.net

Thanks in advance,

Jay Crouch
S&B Filters, Inc.
Reply With Quote
  #14 (permalink)  
Old 01-24-2008, 04:37 PM
SANDDEMON08's Avatar
SANDDEMON08 SANDDEMON08 is offline
Posting Guru
 
Join Date: Jun 2007
Location: Henderson, NV
Posts: 1,203
SANDDEMON08 has a very good reputation on FTE.SANDDEMON08 has a very good reputation on FTE.SANDDEMON08 has a very good reputation on FTE.
Has there been any update to resolve the problems with the AFE stage II intake for the 6.4?
__________________
Got beer ? 611 HP 1205 TQ
08 F350 CC FX4, 6.4 PSD,PMF 4.5" LIFT WITH TRACTION BARS,4.30 REAR,NAV,DASH DAQ,VOLANT INTAKE,SPEARCO INTERCOOLER,STAGE III WATER/METH,67 GAL TITAN TANK,EGR DELETE,ARP HEAD STUDS,72MM LP BILLET TURBO,RCD CONVERTER,FS-2500 BYPASS FILTER, AIR DOG II FUEL PUMP,CUSTOM CCV,MAG-HYTEC TRANS PAN AND DIFF COVER, CUSTOM HD TRANS COOLER, SEIC MOD,AMP STEPS
Reply With Quote
  #15 (permalink)  
Old 02-23-2008, 11:38 AM
tiereta tiereta is offline
New User
 
Join Date: Oct 2007
Posts: 14
tiereta is starting off with a positive reputation.
I still have not heard back from AFE on my intake (check engine light). Looks like they are trying to avoid all the customers looking for some resolution to their $250 investment. All I want is for it to work with my $50,000 truck! I don't think that I am asking for much.
Reply With Quote
Old 02-23-2008, 11:38 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Misc. > Air Intakes, Air Filters & Ram Air

Tags
08, 64, afe, air, box, check, engine, f250, ford, intake, light, lights, psd, stage, stock

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 06:57 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup