Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-07-2007, 06:20 PM
romosugah romosugah is offline
New User
 
Join Date: Aug 2007
Posts: 1
romosugah is starting off with a positive reputation.
Grinding/rubbing noise on 2003 expedition

I have a 2003 ford expedition EB that I purchased a few months ago. It has 63K miles on it, and recently I have noticed these grinding/rubbing noises coming from the front end area of the truck. I had a mechanic look at it, and he couldn't find anything wrong with the tires or wheels. This loud noise seems to happen only when the engine is cold and eventually as the truck warms up, the nosie goes away. The noise also goes away if I put in 4H...Has anyone experienced this or knows what the problem is? I appreciate the help!
Reply With Quote
  #2  
Old 08-07-2007, 08:49 PM
CarbonClear CarbonClear is offline
Senior User
 
Join Date: Jun 2007
Location: All over
Posts: 126
CarbonClear is starting off with a positive reputation.
Not sure what the problem is, but you may get a better response in the other Expedition forum.
Reply With Quote
Old 08-07-2007, 08:49 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
2003, end, expedition, f150, ford, forum, front, grinding, grindingrubbing, loud, makes, navigator, noise, rubbing, sound, starting

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 08:20 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup