Go Back   Ford Truck Enthusiasts Forums > Regional Chapters > Southern Region > South Carolina Chapter
Sign in using an external account
Register Forgot Password?


South Carolina Chapter Join Chapter, Leader:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 07-14-2007, 06:22 PM
ccopes75 ccopes75 is offline
Freshman User
 
Join Date: Jun 2007
Location: Bishopville, SC
Posts: 26
ccopes75 is starting off with a positive reputation.
390 Oiling System

I just bought a 69 F-100 with a 390. I was cleaning some old gunk out from around the valve train when I noticed that my pushrods dont have the holes for oil passage. However, the rocker assembly has holes where it lines up with the pushrod ends. There doesn't seem to be much oil getting to the top of the engine. I read an article online concerning the FE oiling system but it didnt say how the oil got up there. Are these the right pushrods? I appreciate any help ya'll can give me.
Reply With Quote
  #2 (permalink)  
Old 07-14-2007, 06:26 PM
ford390gashog's Avatar
ford390gashog ford390gashog is offline
Post Fiend
 
Join Date: Jan 2004
Location: Brentwood,CA
Posts: 14,762
ford390gashog is a name known to allford390gashog is a name known to allford390gashog is a name known to allford390gashog is a name known to allford390gashog is a name known to allford390gashog is a name known to all
You should try the FE engine forum for the most help. The oil comes through the rocker shafts.
Reply With Quote
  #3 (permalink)  
Old 07-14-2007, 06:38 PM
ccopes75 ccopes75 is offline
Freshman User
 
Join Date: Jun 2007
Location: Bishopville, SC
Posts: 26
ccopes75 is starting off with a positive reputation.
Thanks. I'll check it out.
Reply With Quote
Old 07-14-2007, 06:38 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Regional Chapters > Southern Region > South Carolina Chapter

Tags
390, fe, ford, mods, oiling, system

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 03:43 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup