Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.0L Power Stroke Diesel
Sign in using an external account
Register Forgot Password?


6.0L Power Stroke Diesel 2003 - 2007 F250, F350 pickup and F350+ Cab Chassis, 2003 - 2005 Excursion and 2003 - 2009 van SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 07-04-2007, 05:54 AM
mullins2000 mullins2000 is offline
New User
 
Join Date: Jul 2007
Posts: 4
mullins2000 is starting off with a positive reputation.
04 6.0 loss of power and popping noise

i have a 2004 6.0 with cold air intake and edge chip in it. with about 48,000 on it. started having problems about 2 months ago if i get on it it feels like someone just hooked a 10,000 load up to it and making a popping noise with a lot of black smoke pooring out, but when i do have a trailer she hardly moves, was told it was the turbo so got it replaced but the next day same thing. also it doesn't do it untill it has been running awhile. anyone got any ideas what could this be. gotta have a truck to tow with. am happy to say no other problems as thus far.
Reply With Quote
  #2 (permalink)  
Old 07-04-2007, 01:44 PM
bswanzek bswanzek is offline
Freshman User
 
Join Date: Dec 2003
Location: North Dakota
Posts: 31
bswanzek is starting off with a positive reputation.
Sounds like what my Excursion was doing a couple of weeks ago. New EGR valve is what fixed my 6.0.
Reply With Quote
  #3 (permalink)  
Old 07-05-2007, 09:04 AM
mullins2000 mullins2000 is offline
New User
 
Join Date: Jul 2007
Posts: 4
mullins2000 is starting off with a positive reputation.
thanks guys i just disconnected it because it was cleaned once before which i just found out yesterday when it had done it a little before. and after reading a few other threads decided i'll just eliminat the problem.
Reply With Quote
Old 07-05-2007, 09:04 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.0L Power Stroke Diesel

Tags
04, 2003, 60, 60l, cold, ford, intake, loss, making, noise, noises, popping, power, powerstroke, sounds

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 01:15 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup