firing problems - Ford Truck Enthusiasts Forums



firing problems

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 10-16-2006, 04:49 PM
shaggieshapiro shaggieshapiro is offline
New User
Thread Starter
 
Join Date: Oct 2006
Posts: 2
shaggieshapiro is starting off with a positive reputation.
firing problems

Hi guys I have a 68 ranchero. It runs real sluggish, so I checked the firing order. I have a 302 and the firing order is correct 15426378. When i took the wires off the distributor cap i noticed that 4 cylinders dont fire. Number 1,5,6,8 how can I get all 8 to fire? Thanks
Reply With Quote
  #2  
Old 10-16-2006, 06:01 PM
Jimbare's Avatar
Jimbare Jimbare is offline
all alone in the world
 
Join Date: Feb 2002
Location: oklahoma
Posts: 2,038
Jimbare is gaining momentum as a positive member of FTE.
sounds like you either have a vac leak or the carb is stopped up on one side.
Reply With Quote
  #3  
Old 10-16-2006, 07:08 PM
shaggieshapiro shaggieshapiro is offline
New User
Thread Starter
 
Join Date: Oct 2006
Posts: 2
shaggieshapiro is starting off with a positive reputation.
thanks alot thats what I thought. Its the carb. I guess I got to go shopping
Reply With Quote
 
 
Reply


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 01:18 AM.