Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Other Ford Engines > 4 Cylinder Engines
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-29-2006, 02:24 PM
CheapRanger CheapRanger is offline
Elder User
 
Join Date: Apr 2004
Location: State of Misery (Missouri
Posts: 799
CheapRanger is starting off with a positive reputation.
Thought trans, but proved engine

1994 Ranger 2.3 5speed. At first I posted in the transmisson forum, due to what it was doing, but I got it to start to do what it does without the transmission engaged. No cel, and at random times (around shift points) the engine will race, like someone has given it all the gas in the world. When the transmission is engaged, it acts like it doesn't want me to shift it out, due to how high it gets.

Because of all the ideas I have, I am stumped as to where to start, thanks.
Reply With Quote
  #2  
Old 06-29-2006, 04:27 PM
AlfredB1979 AlfredB1979 is offline
Posting Guru
 
Join Date: Jul 2003
Location: Alvin, Texas.
Posts: 1,978
AlfredB1979 is starting off with a positive reputation.
I'm thinking a vacuum leak is calling out to you...

Maybe even the Throttle Position Sensor as well, but that is testable.
Reply With Quote
Old 06-29-2006, 04:27 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Other Ford Engines > 4 Cylinder Engines

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 01:09 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup