Go Back   Ford Truck Enthusiasts Forums > Diesel > 1999 - 2003 7.3L Power Stroke Diesel
Sign in using an external account
Register Forgot Password?


1999 - 2003 7.3L Power Stroke Diesel SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 03-07-2006, 04:58 PM
bjvagts bjvagts is offline
New User
 
Join Date: Sep 2005
Location: Eddyville, KY
Posts: 22
bjvagts is starting off with a positive reputation.
Unhappy My Truck Is Sick

My 2000 F-250 has started acting funny. I has started idling rough and louder(pre hpx) and it seems like it has a miss in it when its between 1300 and 1800 rpms(not when excellerating). It all started after I changed the oil(rot5-40syn) and filled up the tank. That day it also got really cold and when I excellerated it was very jumpy. My first thought was fuel gelling (fueled up at a different station) but I use the diesel kleen white during the winter. Then when the temp warmed up the truck ran fine. Then the symptoms came back. Since then I have had the truck scanned, no codes and the injectors where tested and all checked ok. The diesel tech wanted to check the fuel pressure at a differnet time. So instead of paying another $80+ to have it check I bought a new fuel pump on ebay for $140. Needless to say still running the same. I replaced the CPS about 12000 miles ago when I had a miss around the 1500rpm (didn't help). Also I've changed the oil and fuel filter and have went to my ussual watering hole and filled up with no change. It seems to have lost some power. Fuel mileage has dropped a little. It isn't smoking. I'm wondering if it's a sensor or something worse.
Reply With Quote
Old 03-07-2006, 04:58 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Diesel > 1999 - 2003 7.3L Power Stroke Diesel

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 06:26 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup