NE1 install a chip in their PSD? - Ford Truck Enthusiasts Forums

Colorado Chapter Join Chapter, Leader:

NE1 install a chip in their PSD?

LinkBack Thread Tools Search this Thread
Old 12-08-2005, 07:13 PM
PowerStrokeMe's Avatar
PowerStrokeMe PowerStrokeMe is offline
Senior User
Thread Starter
Join Date: Sep 2005
Location: NE Ft Collins, Colorado
Posts: 222
PowerStrokeMe is starting off with a positive reputation.
NE1 install a chip in their PSD?

I got a TS Performance 6 position chip for my 00 PSD and am having problems with the install. I followed directions and when went to turn the motor over, all lights when crazy and ECM is clicking....took chip out and still does it.

I didnt know if there was anyone near Ft Collins that had put a chip on their stroke and maybe could give me some info.
Reply With Quote

Go Back   Ford Truck Enthusiasts Forums > >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

All times are GMT -5. The time now is 02:10 AM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.