AdvanceTrac light... - Ford Truck Enthusiasts Forums



Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator

AdvanceTrac light...

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-13-2005, 03:20 AM
2005Mariner 2005Mariner is offline
New User
Thread Starter
 
Join Date: Jan 2005
Posts: 23
2005Mariner is starting off with a positive reputation.
Angry AdvanceTrac light...

I have a 2003 4WD Expedition with the 5.4L enigne, that is also equipped with the AdvanceTrac option. Over the past year we have been having problems with the AdvanceTrac light coming on, on the dash. It will just come on sometimes when we start the engine. If you turn the engine off and restart, the light goes out. It will stay on until you restart the engine. Also, it will come on while driving, for now reason, and not got out until you restart the engine. I have had the light come on when I needed the traction control, but then it goes out when everything returns to normal. The two times it came on was when I was in the snow. The dealer checks it and they find nothing. Last time they did something with the software and said they reset it. The problem is that it never comes on when we are near a dealer, so we could have themm take a look at it before we turn the engine off.

Has anyone else had this "phantom" problem before? The Expedition has an extended warranty for 7 years and 100,000 miles, so I guess I just wait until it really breaks? Any thoughts would be appreciated.
Reply With Quote
  #2  
Old 04-13-2005, 03:06 PM
Monsta's Avatar
Monsta Monsta is offline
Post Fiend
 
Join Date: Oct 2001
Location: The Island of Maui
Posts: 18,306
Monsta has a spectacular reputation.Monsta has a spectacular reputation.Monsta has a spectacular reputation.Monsta has a spectacular reputation.Monsta has a spectacular reputation.Monsta has a spectacular reputation.Monsta has a spectacular reputation.Monsta has a spectacular reputation.Monsta has a spectacular reputation.Monsta has a spectacular reputation.Monsta has a spectacular reputation.
Quote:
Originally Posted by 2005Mariner
The problem is that it never comes on when we are near a dealer
Only drive near your dealership then.

I would talk with them again and find out if when the light comes back on in its mysterious way if you can shoot over to have them scan the computer. If it goes out and acts normal once you get close to the dealer...well...then there is something definantly ALIVE in your truck's computer.

I would also check all your tire pressures & tread deptch and make sure they are even.
Reply With Quote
  #3  
Old 04-13-2005, 05:13 PM
Ammie Ammie is offline
Junior User
 
Join Date: Jan 2004
Posts: 56
Ammie is starting off with a positive reputation.
Quote:
Originally Posted by 2005Mariner

Has anyone else had this "phantom" problem before? The Expedition has an extended warranty for 7 years and 100,000 miles, so I guess I just wait until it really breaks? Any thoughts would be appreciated.
I've had this happen to me on my '03 EB. First they re-calibrated the system, then I brought it back in because it happened again and they ordered something (not sure what). It's fine now.
Reply With Quote
  #4  
Old 04-13-2005, 05:19 PM
teatowej teatowej is offline
Junior User
 
Join Date: Sep 2002
Location: Maryland
Posts: 98
teatowej is starting off with a positive reputation.
I had happen on my 03 eb as well but, I sold it a month or two later.
Reply With Quote
  #5  
Old 04-13-2005, 06:47 PM
hmbliving hmbliving is offline
New User
 
Join Date: Jan 2004
Posts: 8
hmbliving is starting off with a positive reputation.
I have the same problem with the reoccuring advance trac light. I also get a warning tone and a "check advance trac" message when I shut off the engine, but it does not happen every time. The dealer never verified the "check advance trac" light and tone problem so it has never been fixed. He did verify the advance trac light coming on in the instrument display and, as you said, performed a software update. He also said that he had to reset the sensors in the wheels, whbich had been disturbed when they checked on a brake problem that I had.

Bottom line is that BOTH problems continue to occur and I can't get my dealer to fix them.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2004 EB Expy, Check advancetrac/abs/ 4x4 high flash josh1095 Expedition & Navigator 3 08-28-2016 10:47 AM
Service Advancetrac message folwtruck 2009 - 2014 F150 11 12-26-2015 08:04 AM
2011 F150 gauges cycle power off and on while driving stephkc24 Electrical Systems/Wiring 3 05-24-2015 08:27 AM
2005 Explorer Advancetrac eskew11 Explorer, Sport Trac, Mountaineer & Aviator 3 12-19-2007 09:44 PM
2005 Advancetrac problem jasongt06 Explorer, Sport Trac, Mountaineer & Aviator 3 01-23-2007 11:06 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
2003, 2005, 2006, advance, advancetrac, blinking, check, dash, expedition, ford, light, navigator, reset, trac, tread, warning

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 05:38 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.