Go Back   Ford Truck Enthusiasts Forums > Regional Chapters > Mid-West Region > Iowa Chapter
Sign in using an external account
Register Forgot Password?


Iowa Chapter Join Chapter, Leader: fellro86

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 02-09-2005, 08:22 AM
69 and 85's Avatar
69 and 85 69 and 85 is offline
Elder User
 
Join Date: Dec 2003
Posts: 633
69 and 85 is starting off with a positive reputation.
A cold, straight ride

Drove my truck for the first time in about a month today. She started right up and all seemed normal. Got a mile down the road and found out my turn signals aren't working. Then I flipped on the blower as my temp guage said the well anticipated heat was ready - blower is dead.

I just got to work and haven't looked into it yet.... I imagine one of the flashers is bad. Guess I will be cheking fuses, etc tonight ( if I don't freeze on the way home!)
Reply With Quote
  #2 (permalink)  
Old 02-09-2005, 11:52 AM
monsterbaby's Avatar
monsterbaby monsterbaby is offline
Super Moderator
 
Join Date: Dec 2003
Location: iowa
Posts: 18,064
monsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputation
that stinks in this weather I have the same problem with the little ranger no turn signals I can only go straight, guess thats better than a stuck signal where you go in circles all the time. my problem with my heater is the truck sat for like 2 yrs, adn has moisture in the ducts somewhere, so when I turn the defrost on it fogs the windows.
__________________
Rob

RIP Steve Bricks. FTE will not be teh same.

Will be forever glad to have had the privilage to shake your hand and BS in person.
Reply With Quote
  #3 (permalink)  
Old 02-09-2005, 12:15 PM
Sam_Fear's Avatar
Sam_Fear Sam_Fear is offline
Posting Guru
 
Join Date: Jul 2003
Location: Davenport, IA
Posts: 1,398
Sam_Fear has a good reputation on FTE.Sam_Fear has a good reputation on FTE.
Quote:
Originally Posted by monsterbaby
so when I turn the defrost on it fogs the windows.
Sounds like a pinhole leak in the heater core. But then I used to have a vehicle (Datson 310?) that would blow snow inside the defroster from the cowl! Crappiest vehicle I ever owned. Hmmmm...
__________________
I'm nothing more than words on your monitor.
Reply With Quote
  #4 (permalink)  
Old 02-09-2005, 12:20 PM
monsterbaby's Avatar
monsterbaby monsterbaby is offline
Super Moderator
 
Join Date: Dec 2003
Location: iowa
Posts: 18,064
monsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputation
nope not a hole in the heater core 2 reasons I know this one if it is antifreeze you can smell it, second no loss of coolant or wet in cab, it has a fabricated air box to clear the 302, and I figure that in the 2 years of sitting a mouse nest was built in there and got wet, and this is the moisture from that when I get it warmed up. (only does it when it is completely warmed up, and putting out hot air)
__________________
Rob

RIP Steve Bricks. FTE will not be teh same.

Will be forever glad to have had the privilage to shake your hand and BS in person.
Reply With Quote
  #5 (permalink)  
Old 02-10-2005, 09:17 AM
69 and 85's Avatar
69 and 85 69 and 85 is offline
Elder User
 
Join Date: Dec 2003
Posts: 633
69 and 85 is starting off with a positive reputation.
Musta been gremlins... anyway, they left for now. When I left work yesterday the heat was good and the turn signals worked. I guess she justed needed a day in the sun. Go figure.
Reply With Quote
  #6 (permalink)  
Old 02-10-2005, 04:20 PM
truckertaz's Avatar
truckertaz truckertaz is offline
Posting Guru
 
Join Date: Jul 2001
Location: Eastern Iowa Soon Texas
Posts: 1,944
truckertaz is starting off with a positive reputation.
Sometimes some of them old things just need a good swift kick in the tires and a few cuss words to wake them up
__________________
Bill

Teamster local 421
Do not disturb.....Already disturbed
Reply With Quote
  #7 (permalink)  
Old 02-12-2005, 05:16 AM
wyldstallyn73 wyldstallyn73 is offline
Elder User
 
Join Date: Apr 2004
Posts: 650
wyldstallyn73 is starting off with a positive reputation.
My guess is its your ignition switch has play in it and needs to be in just the right spot to make contact with everything.
__________________
"It's not that I'm lazy,,,, It's that I just dont care."
Reply With Quote
  #8 (permalink)  
Old 02-12-2005, 12:05 PM
monsterbaby's Avatar
monsterbaby monsterbaby is offline
Super Moderator
 
Join Date: Dec 2003
Location: iowa
Posts: 18,064
monsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputationmonsterbaby has a superb reputation
Quote:
Originally Posted by wyldstallyn73
My guess is its your ignition switch has play in it and needs to be in just the right spot to make contact with everything.
I just had another thought along those lines, I had one that was just old and gummy, and when it got cold the grease was just stickly enough that it wouldn't come all the way back to the run position on its own, but just a slight amount of preasure would bring it into position and away you go.
Good call stallyn don't know why I didn't remember that one.
__________________
Rob

RIP Steve Bricks. FTE will not be teh same.

Will be forever glad to have had the privilage to shake your hand and BS in person.
Reply With Quote
  #9 (permalink)  
Old 02-13-2005, 11:48 PM
69 and 85's Avatar
69 and 85 69 and 85 is offline
Elder User
 
Join Date: Dec 2003
Posts: 633
69 and 85 is starting off with a positive reputation.
Hey thanks guys... makes sense. If it happens again, I'l give it a lil pressure. These really are great ol' trucks.... but it doesn't hurt to learn sometricks along the way!

Thanks again!
__________________
91 Blue F250
Reply With Quote
Old 02-13-2005, 11:48 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Regional Chapters > Mid-West Region > Iowa Chapter

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 09:49 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup