Go Back   Ford Truck Enthusiasts Forums > Regional Chapters > Mid-West Region > Ohio Chapter
Sign in using an external account
Register Forgot Password?


Ohio Chapter Join Chapter, Leader: RUNVS

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-12-2005, 09:51 AM
Matt_Ranger2000 Matt_Ranger2000 is offline
New User
 
Join Date: Dec 2004
Location: North Ridgeville, OH
Posts: 12
Matt_Ranger2000 is starting off with a positive reputation.
Oil Pressure Guage

Hey just a simple question. I have a 2000 Plain Jane Ranger with almost 70,000 miles. About a month ago the oil pressure guage started to act up. When I start the truck the guage doesn't go normal until the truck is warm. Is this a common problem? I know I'm getting oil pressure because the truck runs cherry, just want to know wether it's worth spending the time and money to replace the guage sensor. Thanks!
Reply With Quote
  #2  
Old 01-12-2005, 06:00 PM
F2504x4's Avatar
F2504x4 F2504x4 is offline
Post Fiend
 
Join Date: Dec 2003
Location: On the road in Ohio
Posts: 6,735
F2504x4 has much to be proud ofF2504x4 has much to be proud ofF2504x4 has much to be proud ofF2504x4 has much to be proud ofF2504x4 has much to be proud ofF2504x4 has much to be proud ofF2504x4 has much to be proud ofF2504x4 has much to be proud ofF2504x4 has much to be proud of
Well the first thing i would do is get a test gage and remove the sending unit on the engine, and test the oil pressure there and see if the readings are the same. if they are the same, it could be a number of issue's, clogged oil pick-up screen in the pan, oil pump is starting to fail, crank or cam journals are worn, first thing to do is verify the oil pressure by testing it, you can buy these gages at any auto parts store
Reply With Quote
  #3  
Old 01-13-2005, 09:13 AM
Matt_Ranger2000 Matt_Ranger2000 is offline
New User
 
Join Date: Dec 2004
Location: North Ridgeville, OH
Posts: 12
Matt_Ranger2000 is starting off with a positive reputation.
Great thanks!
Reply With Quote
Old 01-13-2005, 09:13 AM
 
 
 
Reply


Go Back   Ford Truck Enthusiasts Forums > Regional Chapters > Mid-West Region > Ohio Chapter

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 12:32 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup