2005 Escape XLT noise: could it be motor mounts? - Ford Truck Enthusiasts Forums



Escape & Escape Hybrid Ford Escape, Ford Escape Hybrid, Mercury Mariner, Mazda Tribute

2005 Escape XLT noise: could it be motor mounts?

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-12-2004, 11:50 AM
musumeche musumeche is offline
New User
Thread Starter
 
Join Date: Jun 2004
Posts: 1
musumeche is starting off with a positive reputation.
2005 Escape XLT noise: could it be motor mounts?

I have a 2005 Escape XLT with 2500 miles. When I first accelerate from 0 MPH to about 3 MPH, there is a grinding-squeeky-kind of sound for about 1/2 sec. The sound began when I reached about 1000 total miles. It does this each time I use the Escape(not just first thing in the morning). I read in another forum that it could be motor mounts needing lubrication. What do members of this forum think? Any ideas about this problem? How difficult is it for technicans to lubricate motor mounts?
Reply With Quote
  #2  
Old 09-14-2004, 12:29 AM
echoy97 echoy97 is offline
Junior User
 
Join Date: Aug 2004
Posts: 95
echoy97 is starting off with a positive reputation.
My 2005 has 1000 miles now and it started making squeeky noise too. If I hear it right, it is from one of the rear wheel and not the engine. It doesn't make noise everyday, but when it make noise, it is when I am going 5-30mph.
Reply With Quote
  #3  
Old 09-18-2004, 05:36 PM
Mojave2k Mojave2k is offline
Senior User
 
Join Date: Jun 2004
Location: Southern California.. Nea
Posts: 107
Mojave2k is starting off with a positive reputation.
check the rotors

Just a thought.. It might be brake pads momentarily sticking to the soft rotors that Escapes are known for.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
F-250 2005 XLT 4x4 Problem! Rémi Mercier 1999 to 2016 Super Duty 18 01-19-2016 01:55 PM
2005 Ford Escape History donsabi Escape & Escape Hybrid 7 07-05-2015 03:27 PM
2005 Escape rear glass won't register closed mhans311 Escape & Escape Hybrid 1 12-17-2014 08:12 AM
2005 Escape Highway Vibration mattbal Escape & Escape Hybrid 3 10-08-2011 11:14 AM
noise in escape after installing rear u joint birdseyelogger Escape & Escape Hybrid 5 03-31-2011 09:10 AM


Go Back   Ford Truck Enthusiasts Forums >

Tags
2003, 2004, 2005, chassis, escaoe, escape, ford, location, lubricate, motor, mount, mounts, noise, problem, problems

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 01:59 AM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.