2005 Escape XLT noise: could it be motor mounts? - Ford Truck Enthusiasts Forums
 

Go Back   Ford Truck Enthusiasts Forums > Small Chassis Trucks > Escape & Escape Hybrid
Log In 


Escape & Escape Hybrid Ford Escape, Ford Escape Hybrid, Mercury Mariner, Mazda Tribute

2005 Escape XLT noise: could it be motor mounts?

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-12-2004, 10:50 AM
musumeche musumeche is offline
New User
 
Join Date: Jun 2004
Posts: 1
musumeche is starting off with a positive reputation.
2005 Escape XLT noise: could it be motor mounts?

I have a 2005 Escape XLT with 2500 miles. When I first accelerate from 0 MPH to about 3 MPH, there is a grinding-squeeky-kind of sound for about 1/2 sec. The sound began when I reached about 1000 total miles. It does this each time I use the Escape(not just first thing in the morning). I read in another forum that it could be motor mounts needing lubrication. What do members of this forum think? Any ideas about this problem? How difficult is it for technicans to lubricate motor mounts?
Reply With Quote
  #2  
Old 09-13-2004, 11:29 PM
echoy97 echoy97 is offline
Junior User
 
Join Date: Aug 2004
Posts: 95
echoy97 is starting off with a positive reputation.
My 2005 has 1000 miles now and it started making squeeky noise too. If I hear it right, it is from one of the rear wheel and not the engine. It doesn't make noise everyday, but when it make noise, it is when I am going 5-30mph.
Reply With Quote
  #3  
Old 09-18-2004, 04:36 PM
Mojave2k Mojave2k is offline
Senior User
 
Join Date: Jun 2004
Location: Southern California.. Nea
Posts: 107
Mojave2k is starting off with a positive reputation.
check the rotors

Just a thought.. It might be brake pads momentarily sticking to the soft rotors that Escapes are known for.
__________________
Mojave2k
Reply With Quote
Old 09-18-2004, 04:36 PM
 
 
 
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Ford Escape History donsabi Escape & Escape Hybrid 7 07-05-2015 02:27 PM
Thinking about buying a 2012 Escape, thoughts? locknload223 Escape & Escape Hybrid 4 03-11-2015 12:34 AM
2005 Escape rear glass won't register closed mhans311 Escape & Escape Hybrid 1 12-17-2014 07:12 AM
2009 Climate Control Fan Rattle Issue msh213 Escape & Escape Hybrid 5 10-26-2013 09:53 PM
2001 ford escape wont go into gear Escapemomma Escape & Escape Hybrid 1 03-01-2013 07:04 AM


Go Back   Ford Truck Enthusiasts Forums > Small Chassis Trucks > Escape & Escape Hybrid

Tags
2003, 2004, 2005, chassis, escaoe, escape, ford, location, lubricate, motor, mount, mounts, noise, problem, problems

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 07:11 PM.

 

Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup