Go Back   Ford Truck Enthusiasts Forums > Ford Vans and other vehicles > Ranchero & 1961 - 1967 Econoline
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 07-28-2004, 11:15 PM
slim_falcon slim_falcon is offline
Junior User
 
Join Date: May 2003
Location: Big Ol' Texas...
Posts: 67
slim_falcon is starting off with a positive reputation.
weak starter????

ive got an ol 1960 falcon ranchero and ive put a new carb and other bs on it and it still wont stay runnin, ive had it runnin for a week straight , then winter hit and i had to park er, now it wont start. i put a new battery in it and i get in to start it and it just clicks.....whats goin on guys, gimme some answers please....thanks
__________________
slim

1981 Ford F-150 Ranger XLT
302 ci, AOD tranny
mud tires and stacks!!!
Reply With Quote
  #2 (permalink)  
Old 07-28-2004, 11:51 PM
jpass2 jpass2 is offline
New User
 
Join Date: Jul 2004
Posts: 6
jpass2 is starting off with a positive reputation.
Sounds like corosion in the circuit. Start by removing the ground cable where it attaches to the engine and clean the cable and the battery connection with a wire brush or sanpaper. If that doesn't do it, remove the positive from the battery to the solenoid amd clean both ends. Next clean the cable from the solenoid to the starter. If this doesn't do it, replace the solenoid. Good Luck. jpass2
Reply With Quote
  #3 (permalink)  
Old 07-29-2004, 12:20 AM
slim_falcon slim_falcon is offline
Junior User
 
Join Date: May 2003
Location: Big Ol' Texas...
Posts: 67
slim_falcon is starting off with a positive reputation.
new wire

from the solinoid to the starter is a new wire, i just regrounded it the other day too...but ill clean er up n check it out....thank ya
__________________
slim

1981 Ford F-150 Ranger XLT
302 ci, AOD tranny
mud tires and stacks!!!
Reply With Quote
Old 07-29-2004, 12:20 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Ford Vans and other vehicles > Ranchero & 1961 - 1967 Econoline

Tags
73, clicks, descil, f100, f150, f250, falcon, ford, starter, weak

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 04:16 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup