Go Back   Ford Truck Enthusiasts Forums > Ford Vans and other vehicles > Ranchero & 1961 - 1967 Econoline
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-10-2004, 04:17 PM
Nitro375 Nitro375 is offline
Junior User
 
Join Date: Mar 2003
Location: N.W.
Posts: 79
Nitro375 is starting off with a positive reputation.
Thumbs up 02 sensors, who'd a thought


Well for the longest time the o'l Bronco [96 5.8 E40D] has had a pinging problem that has slowly gotten worse. Full tune up, decarbonizing, checked cats,premium fuel, etc,etc. A friend of mine with a 99 Mustang Cobra said that some folks on that forum had had the same trouble after fifty or sixty thousand miles and changed their 02 sensors despite no MIL light or codes.

All I can say is wow!!!!.....it isn't even the same truck, not only does it not ping, but overall drives remarkably better. Part throttle accerlation, the way the trans shifts, hard accleration...you name it.
I rember back in the day [80's-90's] they used to say change your 02's every 50,000 or soo. Perhaps it isn't a bad idea. Oh and by the way it fixed my buddies 99 Cobra also of the same problem....pretty cool!!!!!!

__________________
Nitro out
Reply With Quote
  #2  
Old 06-30-2004, 05:49 PM
ncranchero's Avatar
ncranchero ncranchero is offline
Postmaster
 
Join Date: May 2003
Location: E.Lincoln County, NC
Posts: 2,778
ncranchero has a good reputation on FTE.ncranchero has a good reputation on FTE.
steve.mckellop
Good information, thanks.
__________________
Steve,
'94 F150 4x4 4.9L/5-speed/3.55(H9) 166K miles
'00 Taurus SES DOHC 87K miles
'02 Escape XLT 3.0/auto 165K miles
'14 TRANSIT Connect
Reply With Quote
Old 06-30-2004, 05:49 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Ford Vans and other vehicles > Ranchero & 1961 - 1967 Econoline

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 11:43 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup