Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 1997 - 2003 F150
Sign in using an external account
Register Forgot Password?


1997 - 2003 F150 1997-2003 F150, 1997-1999 F250LD, 7700 & 2004 F150 Heritage SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-25-2004, 05:06 PM
iahte my ford4.2 iahte my ford4.2 is offline
New User
 
Join Date: Jan 2004
Posts: 15
iahte my ford4.2 is starting off with a positive reputation.
4.2 fuel pressure

i did a fuel pressure test on my 97 f150 4.2 everything is within specs except when i remove the vacume line from the presure regulator the presure didnt increase like the book said it should does this tell me my regulator is bad?
Reply With Quote
  #2  
Old 01-25-2004, 08:41 PM
LxMan1's Avatar
LxMan1 LxMan1 is offline
Moderator
 
Join Date: Dec 2001
Location: Louisville,Ky.
Posts: 22,225
LxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant future
Did the line have vacuum on it?
What was the pressure that you were getting?
__________________
Jimmy- FTE Moderator

88 5.0 LX Mustang
63 F100 351W/C6

Reply With Quote
  #3  
Old 01-26-2004, 05:56 AM
iahte my ford4.2 iahte my ford4.2 is offline
New User
 
Join Date: Jan 2004
Posts: 15
iahte my ford4.2 is starting off with a positive reputation.
the line had vacum i was getting between 30 and 40 psi
Reply With Quote
  #4  
Old 01-26-2004, 07:12 AM
LxMan1's Avatar
LxMan1 LxMan1 is offline
Moderator
 
Join Date: Dec 2001
Location: Louisville,Ky.
Posts: 22,225
LxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant future
It should be about 32 psi with vacuum and 40 or so without.
If it sin't changing and you have a contant 40psi, then I would suspect the regulator. Did any gas come out of the vacuum port on the regulator?
__________________
Jimmy- FTE Moderator

88 5.0 LX Mustang
63 F100 351W/C6

Reply With Quote
  #5  
Old 01-26-2004, 07:39 AM
iahte my ford4.2 iahte my ford4.2 is offline
New User
 
Join Date: Jan 2004
Posts: 15
iahte my ford4.2 is starting off with a positive reputation.
no gas came out that i noticed thank you for the response
Reply With Quote
  #6  
Old 01-29-2004, 12:01 PM
iahte my ford4.2 iahte my ford4.2 is offline
New User
 
Join Date: Jan 2004
Posts: 15
iahte my ford4.2 is starting off with a positive reputation.
4.2 fuel presure

i changed my pressure regulator it fixed the stumble and the hard starts for 1 day now its doint it again sometimes it surges when i take off it acts like it is running out of fuel but it takes off about a secong later
Reply With Quote
  #7  
Old 01-29-2004, 05:00 PM
LxMan1's Avatar
LxMan1 LxMan1 is offline
Moderator
 
Join Date: Dec 2001
Location: Louisville,Ky.
Posts: 22,225
LxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant future
Clean the MAF. Also, check the TPS sensor, it could have a bad spot in it.
Jimmy
__________________
Jimmy- FTE Moderator

88 5.0 LX Mustang
63 F100 351W/C6

Reply With Quote
  #8  
Old 01-29-2004, 09:32 PM
iahte my ford4.2 iahte my ford4.2 is offline
New User
 
Join Date: Jan 2004
Posts: 15
iahte my ford4.2 is starting off with a positive reputation.
tps is a week old cleaned the maf 2 weeks ago
Reply With Quote
Old 01-29-2004, 09:32 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 1997 - 2003 F150

Tags
150, 2002, 42, 97, 99, f150, ford, fuel, location, motor, port, pressure, regulator, test, v6

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 04:08 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup