Go Back   Ford Truck Enthusiasts Forums > Diesel > 1999 - 2003 7.3L Power Stroke Diesel
Sign in using an external account
Register Forgot Password?


1999 - 2003 7.3L Power Stroke Diesel SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 12-22-2003, 04:50 AM
domslude domslude is offline
New User
 
Join Date: Nov 2003
Location: Norman
Posts: 22
domslude is starting off with a positive reputation.
turn signals not working

i posted ealier, but I can't find any help. I'm trying to get my turn signals to work. I don't have a owners manual. I have a 2000 superduty 4X4. Can someone send me a pic of the actual diagram, of what fuse goes to what, so I can check fuses, or if anyone has any advice it would be great! Thanks The weird thing is that the hazard's work, but the turns' don't

sean
Reply With Quote
  #2 (permalink)  
Old 12-22-2003, 07:39 AM
99f250 99f250 is offline
Senior User
 
Join Date: Mar 2003
Posts: 226
99f250 is starting off with a positive reputation.
my situation is the opposite--turns work but hazards dont. they told me it was the whole switch mechanism.
__________________
JEFF
99 F250 PSD 4X4,INTAKE,EXHAUST,60HP SUPERTUNER
95 SOA YJ
Reply With Quote
  #3 (permalink)  
Old 12-22-2003, 02:23 PM
domslude domslude is offline
New User
 
Join Date: Nov 2003
Location: Norman
Posts: 22
domslude is starting off with a positive reputation.
so, the whole mechnism eh? who told you that, and what did it cost to get it fixed? Thanks
sean
Reply With Quote
  #4 (permalink)  
Old 12-22-2003, 04:45 PM
99f250 99f250 is offline
Senior User
 
Join Date: Mar 2003
Posts: 226
99f250 is starting off with a positive reputation.
a repair shop--didnt get it fixed. thought id fix it myself but then i was told it was kinda tricky because of the airbag. so-------im doing w/out hazards for the time being. i think the whole switch was about $100
__________________
JEFF
99 F250 PSD 4X4,INTAKE,EXHAUST,60HP SUPERTUNER
95 SOA YJ
Reply With Quote
  #5 (permalink)  
Old 12-22-2003, 09:37 PM
f350xlt460's Avatar
f350xlt460 f350xlt460 is offline
Elder User
 
Join Date: Feb 2003
Location: Virginia
Posts: 674
f350xlt460 is starting off with a positive reputation.
ive heard the assembly is expensive. Hopefully ill be getting a flatbed all-in-one for christmas, if i do ( i am but will pretend to act suprised) ill scan in the owners manual diagram for fuses. Email me or contact me after christmas...
__________________
'99 F350 PSD C/C, DRW, 4x4, 6spd, 4.10 ls, superchip, 4" exhst, on-board air, custom fab'd rear bumper, 2 1/2" receiver hitch

'01 F250 PSD Ext Cab 4x4 Auto 3.73 ls, diablo tuner, 4" exhaust, custom fab'd rear bumper
Reply With Quote
  #6 (permalink)  
Old 12-24-2003, 02:03 PM
Jporterfield Jporterfield is offline
New User
 
Join Date: Jul 2003
Location: Fountain Inn,SC
Posts: 6
Jporterfield is starting off with a positive reputation.
I'm having similar problem, I have brake and stop and runing but not turn or hazard. I replaced switch assembly on strreing wheel it cost me $44 and very simple to change but I'm still having same problem.

Let me know if you find out anything !!


Merry Christmas to all !!!!!!
Reply With Quote
  #7 (permalink)  
Old 12-24-2003, 07:10 PM
99f250 99f250 is offline
Senior User
 
Join Date: Mar 2003
Posts: 226
99f250 is starting off with a positive reputation.
where did you get the switch assembly for $44?
__________________
JEFF
99 F250 PSD 4X4,INTAKE,EXHAUST,60HP SUPERTUNER
95 SOA YJ
Reply With Quote
  #8 (permalink)  
Old 01-03-2004, 10:55 PM
g8rh8r g8rh8r is offline
Freshman User
 
Join Date: Nov 2003
Location: Ormond Beach, FL.
Posts: 32
g8rh8r is starting off with a positive reputation.
I had the same problem with my 99. But my turns were intermittent. They worked when they wanted to. Then my hazards went. No one could tell me about the fuses, but the box was clicking. For whatever reason, they started workin out of the blue. No problems for about a year and a half.
__________________
'99 F-250 Super Duty 4x4, PSD, Superchips Micro Tuner, A little gloss black paint on the argent accessories, slotted rotors(let the brakes go to long), K&N Air Filter, tiny tires(for now)
Reply With Quote
  #9 (permalink)  
Old 01-09-2004, 07:16 AM
Jporterfield Jporterfield is offline
New User
 
Join Date: Jul 2003
Location: Fountain Inn,SC
Posts: 6
Jporterfield is starting off with a positive reputation.
This is a great day !

I have fixed my signal problem !!!!!

I found a relay under the dash (you could feel it click when the siginals would work intermitly) it was in a holder bracket with a snap cover approx 1.5" wide and 3 " long "Black in color) to the right of driver leg, it was a real bear to get out ( i had to take cover off and remove 7 MM screw and pull holder down so I could see it. I checked the part number with ford parts and it was a flasher relay PN; TBB89 H252 MADE IN USA F65B ( 5 PRONG) .

Maybe this will help others !

I purchased all of my parts from FORD dealer, I have a neighbor that works in parts thath is why the good price.
Reply With Quote
  #10 (permalink)  
Old 10-15-2009, 05:25 PM
CorpusBragg CorpusBragg is offline
New User
 
Join Date: Feb 2008
Posts: 10
CorpusBragg is starting off with a positive reputation.
2000 Excursion Turn Signals Hazard Flashers Not Working

I had a similar discrepancy. After doing some radio work, my turn signals did not work at all. The hazard flashers were intermittent dependent upon the height of the adjustable steering wheel. I set the steering wheel full down, flashers on and pressed upwards on the wiring harness running into the steering wheel. The flashers worked. This particular was under some strain as evidenced by the fact that it was being pulled from its mounting bracket (which is plastic). I tywrapped the harness up, and those two systems are good. Cruise control is still on the blink...
Reply With Quote
  #11 (permalink)  
Old 06-01-2010, 12:10 AM
Jerry Edwards Jerry Edwards is offline
Junior User
 
Join Date: Dec 2008
Location: Pittsburgh,Pa
Posts: 87
Jerry Edwards is starting off with a positive reputation.
Left Rear Turn Signal

My left turn signal light was flashings fast,so i figured it needed a bulb.I picked one up on the way home,well it wasn't burnt out.Checked the flasher it was flashing normal for everthing other than left turn,so i replaced it,so everthing flashed normal but still the left rear turn signal didn't work.Any ideas?
Reply With Quote
  #12 (permalink)  
Old 06-01-2010, 12:12 AM
Jerry Edwards Jerry Edwards is offline
Junior User
 
Join Date: Dec 2008
Location: Pittsburgh,Pa
Posts: 87
Jerry Edwards is starting off with a positive reputation.
Sorry,2002 F250,SuperDuty
Reply With Quote
  #13 (permalink)  
Old 06-01-2010, 11:03 PM
firestroker8706's Avatar
firestroker8706 firestroker8706 is offline
Senior User
 
Join Date: Mar 2010
Location: Arlington, Texas
Posts: 222
firestroker8706 is starting off with a positive reputation.
That sounds to me like the relay under the dash that was described a few posts earlier. I had the same thing happen and that's what it wound up being. I don't have my manual on me right now but hopefully someone else will chime in with one. If not I'll try and get it to you this weekend.
__________________
Luke

'02 F350, Stolen twice, never found after the second time.
'09 Honda Civic, no mods......yet.
'03 Honda CRV, Wifes car, All stock.....
Reply With Quote
  #14 (permalink)  
Old 06-02-2010, 12:31 AM
twags6's Avatar
twags6 twags6 is offline
PAA Member #7 and FTE
 
Join Date: Jan 2001
Location: Laurys Station, PA
Posts: 2,724
twags6 has a very good reputation on FTE.twags6 has a very good reputation on FTE.twags6 has a very good reputation on FTE.twags6 has a very good reputation on FTE.
Does the brake light on that side work? What about the parking light? If neither works, I'd say bad ground on that light, if the parking works, but not the brake/turn, its probably the wire feeding that part of the light.
__________________
Trevor
01 F-350 CC 8ft bed SRW 7.3L a/t. 190k
PAA Member #7
Reply With Quote
  #15 (permalink)  
Old 06-04-2010, 12:43 PM
Jerry Edwards Jerry Edwards is offline
Junior User
 
Join Date: Dec 2008
Location: Pittsburgh,Pa
Posts: 87
Jerry Edwards is starting off with a positive reputation.
Turn signal not working

Have parking lights but no turn signal,brake light or 4way on that side in the rear.I have replaced the flasher relay,never checked the brake light till today,finally had help.
Reply With Quote
Old 06-04-2010, 12:43 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Diesel > 1999 - 2003 7.3L Power Stroke Diesel

Tags
03, 1999, 2002, 99, f150, f250, focus, ford, inop, signal, signals, tbb89, truck, turn, working, zx5

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 03:30 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup