99 psd 7.3 super duty snap on solus cct test questions - Ford Truck Enthusiasts Forums
 

Go Back   Ford Truck Enthusiasts Forums > Diesel > 1999 - 2003 7.3L Power Stroke Diesel
Log In 


1999 - 2003 7.3L Power Stroke Diesel SPONSORED BY:

99 psd 7.3 super duty snap on solus cct test questions

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-12-2015, 10:31 AM
f350hammer's Avatar
f350hammer f350hammer is offline
Senior User
 
Join Date: Aug 2013
Location: Muskogee Oklahoma
Posts: 436
f350hammer is starting off with a positive reputation.
Liquidfirex@yahoo.com
99 psd 7.3 super duty snap on solus cct test questions

Hey guys. Thanks for your time!

I have been having injector issue out of my truck...... The problem has been there since I got it..... I'm really starting to worry about this sneaking up on me and biting me in my butt.....

The issue is - when cold below 50s [thr colder it is the worse it is]
the truck has a miss fire - in order to get rid of the misfire you have to let it warm up for about 5 to 10 mins [depending on how cold it is] once the temp gauge is in the normal area you have to wot it once and it will clear up - it won't completely go away until you drive it [ you basically have to wot it in gear one good time and it's gone] [1/4th of a block] and won't fully return until complete cool down......


The other day I let it cool down a bit and pulled the valve cover on the passenger side. I pulled the plug for each injector - one at a time and independently and reconnected - trying to find the bad injector........ starting from the radiator/drivers side.....
The 1st injector made some difference
the 2nd made a huge difference -
the 3rd made some difference-
the 4th made no difference

Up to operating temp they all made a huge difference......

Iv also been seeing over 20mpg on the highways.
Only issue is when it's cold.

I wanna run a cct test on the truck just to see what the code reader will say - my buddy has a snap on solus and will read the codes for free..... The problem is he doesn't know how - we have been told it will do a buzz and cct test. Could someone inlightin us on how to do such? Any thoughts or ideas!

Iv got a bud who can rebuild the injectors for my truck - he said worse case around 90$ an injector..... but it will require me to shut the truck for a few days and I can't do that..... I'm on the hunt for a few ab injectors cheap pm me if you got any you wanna let go of cheap or maybe trade for...... iv got a lot of family issues going on right now and I'm carrying more then my share - supporting 5 others on just my check...... so I need to make sure I don't get taken advantage of or for a ride..... I need this truck fixed properly. Thanks guys - any advice.
Reply With Quote
  #2  
Old 02-12-2015, 12:23 PM
David7.3's Avatar
David7.3 David7.3 is offline
Where is the beer?
 
Join Date: Jun 2014
Location: Oakhust NJ Jersey Shore
Posts: 2,695
David7.3 is a splendid one to beholdDavid7.3 is a splendid one to beholdDavid7.3 is a splendid one to beholdDavid7.3 is a splendid one to beholdDavid7.3 is a splendid one to beholdDavid7.3 is a splendid one to beholdDavid7.3 is a splendid one to behold
When you put your info into the soluus go into generic mode, there you will see a bunch of test you can do, thats were the CCT is, sounds like you got a couple glow plugs out, or the UVCH Valve cover harness is bad, you can unplug them and command the GPR on with the scan tool and make sure your getting 12volts to the glow plugs. I'm betting on glow plug related, you can ohm them out at the connectors just unplug the connector at the valve cover, the glowplug terminal is the big ones. Take and OHM meter and ground one lead, and touch each glow plug terminal should be 5-6 ohms depending on temp. If it reads infinity glow plug is open, done, gone, then you can pull the valve covers and test the glow plugs again with the harness unplugged still not 5-6 ohm, you know you have a bad glow plug, if you now have a good reading UVCH el garbago. Look for codes while your in there, make sure your oil temp and coolant temp are close, thats what the PCM uses to activate the plugs. good luck
__________________
1999 F-350 PSD, 6 inch all spring, 35" Toyo load E tires, 140 gallons of fuel, Detroit true trac front, Detroit locker rear, BDS trans, banks billet converter, banks trans command, TS chip, banks turbo housing, wicked wheel II, FRx Kit w/black spring, Non-EBV Pedestal, diesel site coolant filter, 203 t-stat, IAH delete, 4" turbo back exhaust, 6.0 trans cooler, Riff-Raff wastegate, 1994 Ford f-350 ambulance, 7.3 IDI 40,000 miles, rear air suspension, full light bars, strobes, sirens ect. for sale
Reply With Quote
  #3  
Old 02-12-2015, 10:54 PM
f350hammer's Avatar
f350hammer f350hammer is offline
Senior User
 
Join Date: Aug 2013
Location: Muskogee Oklahoma
Posts: 436
f350hammer is starting off with a positive reputation.
Liquidfirex@yahoo.com
Quote:
Originally Posted by David7.3 View Post
When you put your info into the soluus go into generic mode, there you will see a bunch of test you can do, thats were the CCT is, sounds like you got a couple glow plugs out, or the UVCH Valve cover harness is bad, you can unplug them and command the GPR on with the scan tool and make sure your getting 12volts to the glow plugs. I'm betting on glow plug related, you can ohm them out at the connectors just unplug the connector at the valve cover, the glowplug terminal is the big ones. Take and OHM meter and ground one lead, and touch each glow plug terminal should be 5-6 ohms depending on temp. If it reads infinity glow plug is open, done, gone, then you can pull the valve covers and test the glow plugs again with the harness unplugged still not 5-6 ohm, you know you have a bad glow plug, if you now have a good reading UVCH el garbago. Look for codes while your in there, make sure your oil temp and coolant temp are close, thats what the PCM uses to activate the plugs. good luck
You really think this is glow plugs?
i thought the glow plugs only ran for 2 or 3 mins max...... This miss fire remains for 10 mins or until in the warm rang or more until and you drive it -wot it. I'll test to glow plugs before i do anything. Thanks bud
Reply With Quote
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Just bought a truck, injector issues and ICP seems pretty high - possibly related? Lead Head 1999 - 2003 7.3L Power Stroke Diesel 9 07-01-2016 12:54 AM
Help! 2000 7.3L bad miss or stutter/knock at high rpm and decel carguy3j 1999 - 2003 7.3L Power Stroke Diesel 91 09-21-2015 01:27 PM
CCT, CRV, and PERDEL explained. Tugly 1999 - 2003 7.3L Power Stroke Diesel 17 09-18-2014 03:27 PM
AE or spare IDM in Seattle? I'll buy dinner and beer. lemonshindig 1994.5 - 1997 7.3L Power Stroke Diesel 1 06-14-2014 10:11 PM
Low boost! JMWRIGHT335 1994.5 - 1997 7.3L Power Stroke Diesel 39 09-16-2013 07:54 AM


Go Back   Ford Truck Enthusiasts Forums > Diesel > 1999 - 2003 7.3L Power Stroke Diesel

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 07:28 PM.

 

Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup